a3e1aea82452921d2ca455c722670b5c2af6faf9
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 7.1
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 # Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 # f29 does not come with an rpm for that; use pip instead
27 # Requires: Django
28 Requires: postgresql, postgresql-server
29 # We use set everywhere
30 Requires: python3
31 Requires: python3-postgresql
32 Requires: python3-psycopg2
33 Requires: python3-pycurl
34 # used in GPG.py as a replacement to PyXML's Canonicalize
35 Requires: python3-lxml
36 # for the RebootNodeWithPCU method
37 #Requires: pcucontrol >= 1.0-6
38 # for memcache
39 Requires: memcached python3-memcached
40
41 ####################
42 # phpxmlrpc
43 ####################
44 # standard xmlrpc.so that ships with PHP does not marshal NULL
45 # prior to May 2017 we used to ship our own brew of xmlrpc but
46 # that does not build anymore on f25
47 # So bottom line is:
48 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
49 # * don't use our own that is way too old
50 # * instead - thank you Ciro - we pull it as a git subtree from
51 # https://github.com/gggeek/phpxmlrpc.git
52 # that stuff requires the following though
53 Requires: php-xml
54 ####################
55
56
57 # PostgreSQL and SOAPpy are necessary to run the API server, but not
58 # plcsh. Since the only supported method of running the server is via
59 # MyPLC anyway, don't be so stringent about binary requirements, in
60 # case people want to install this package just for plcsh.
61 # Requires: postgresql-server, SOAPpy
62 AutoReqProv: no
63
64 %description
65 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
66 PlanetLab Central (PLC) database. The API may be accessed directly via
67 the Python shell program plcsh, through a toy standalone server, or
68 through Apache mod_python.
69
70 %prep
71 %setup -q
72
73 %build
74 # python-pycurl and python-psycopg2 avail. from fedora 5
75 # we used to ship our own version of psycopg2 and pycurl, for fedora4
76 # starting with 4.3, support for these two modules is taken out
77 #
78 # Build __init__.py metafiles and PHP API.
79 %{__make} %{?_smp_mflags}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
84
85 # Install shell symlink
86 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
87 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
88
89 # Install initscripts
90 echo "* Installing initscripts"
91 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
92 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
93
94 # Install db-config.d files
95 echo "* Installing db-config.d files"
96 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
97 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
98 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
99
100 # Create log file for plcapi
101 mkdir -p $RPM_BUILD_ROOT/var/log
102 touch $RPM_BUILD_ROOT/var/log/plcapi.log
103 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
104
105 # Install ratelimit log
106 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
107 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 ###%define php_extension_dir %(php-config --extension-dir)
113
114 %files
115 %defattr(-,root,root,-)
116 %dir %{_datadir}/plc_api
117 #%dir /var/log/omf/
118 %{_datadir}/plc_api/*
119 %{_bindir}/plcsh
120 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
121 /etc/plc.d
122 /etc/planetlab/db-config.d
123 #/usr/bin/omf_slicemgr.py*
124 #/usr/bin/reset_xmpp_pubsub_nodes.py*
125 /var/log/plcapi.log
126 /var/log/plc_api_ratelimit.log
127
128
129 %changelog
130 * Tue Feb 06 2024 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.1-0
131 - allow GetLeases 'clip' and 'alive' parameters to use lists
132   as tuples cannot be marshalled by the xmlrpc layer
133 - packaging modified for f37
134 - support for pgsql14/f37
135 - use a configurable email as the From: when sending emails
136
137 * Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.1-0
138 - for php8 in f35:
139 - * the phpxmlrpc layer has been upgraded to recent 4.6.1 that is php8-ready
140 - * classes to use __construct() to define a constructor
141 - * curl_setopt with verifyhost being 1 is no longer allowed
142 - also other older changes related to pgsql 12
143
144 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.0-0
145 - based on python3, runs on f27 and f29
146 - removed dependency to aspects, and so to rate limits
147 - remove dependency to the Django rpm that is no longer available in f29
148 - remove deps to python-twisted
149 - use systemctl rather than service to manage postgresql
150
151 * Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
152 - define accessor for site tag disabled_registration (used in plewww-5.2-9)
153 - set disable_existing_loggers = False in logging config, that otherwise voids sfa logs
154
155 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
156 - embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
157 - logs in /var/log/plcapi.log
158 - context managers for most open files
159
160 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
161 - mostly issued for the R2lab deployment
162 - *** major
163 - * dots allowed in login_base and slice name
164 - * new lease filter 'day'
165 - *** minor
166 - * more explicit message in case of overlapping resas
167 - * bugfix: escaping unicode in xml
168 - * GetLeases allowed to anonymous callers
169 - *** miscell
170 - * use plain json library
171
172 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
173 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
174
175 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
176 - new bootstate 'upgrade' is like reinstall but leaves slices intact
177
178 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
179 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
180
181 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
182 - reviewed logging strategy, no more direct print but use log instead
183
184 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
185 - extensions for the ipv6 feature
186 - DeleteSliceTag can be run with the 'node' auth
187 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
188 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
189
190 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
191 - allow GetSlices to filter on tags as well
192
193 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
194 - enable filtering on tags (like hrn) with GetPersons and GetSites
195
196 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
197 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
198
199 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
200 - don't use PyXML that is deprecated in f20, use lxml instead
201 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
202
203 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
204 - create accessor 'hrn' for site as well
205 - create accessors 'sfa_created' for site/slice/person
206 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
207 - UpdatePerson() updates Person HRN according to updated email.
208 - UpdateSite() updates Site HRN according to updated login_base.
209 - Fix AddPersonToSite().
210 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
211 - RefreshPeer() manages Site*Person and Person*Role relationships.
212
213 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
214 - provide a slicename_to_hrn function
215
216 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
217 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
218
219 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
220 - fix for wsgi-based deployments, each thread has its own api()
221
222 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
223 - also cleanup omf-slicemgr initscript
224
225 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
226 - tear down omf-related aspects as this is no longer needed with omfv6
227
228 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
229 - also expose 'expires' in ResolveSlices
230
231 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
232 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
233
234 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
235 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
236
237 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
238 - use SFA code for computing hrn's when available
239
240 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
241 - new slice tag 'interface' for configuring a virtual interface
242 - new builtin 030-interface_tags
243 - new node accessor and tag 'virt' for mixing lxc & vs nodes
244 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
245 - moved ModPypthon and plc.wsgi in the apache/ subdir
246 - renamed PLCAPI.spec into plcapi.spec
247 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
248 - support for php-5.4
249
250 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
251 - implement PLC_VSYS_DEFAULTS in AddSlice
252
253 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
254 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
255 - AddPerson and UpdatePerson are now tag-aware
256 - as a side-effect AddPerson is more picky and rejects invalid fields
257 - which results in a requirement to use sfa-2.1-22 with this tag
258 - marginal improvement on the xml doc on tags
259
260 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
261 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
262 - reset_xmpp_pubsub_nodes now hos options and usage
263 - new Accessors for vicci
264
265 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
266 - fixed imports for tags management with sites and persons
267 - add predefined 'cpu_freezable' tag
268
269 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
270 - tweaks in interface initialization
271 - has 'vsys_vnet' as a predefined tagtype
272 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
273 - bugfix: GetSlivers & nodegroups
274 - bugfix: in jabber groups management
275
276 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
277 - fix gpg-authentication for Persons (thanks Jordan)
278 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
279 - ip address/network check: v4 or v6
280 - customized DB Message survive upgrade
281 - make sync works in lxc-hosted tests
282 - no svn keywords anymore
283
284 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
285 - fix sorting for methods list in docs
286 - untested but needed tweak for postgres startup in f16
287
288 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
289 - tweaks in postgresql setup - in line with sfa
290
291 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
292 - slight tweaks in Persons.py
293
294 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
295 - GetSession has support for more than one day sessions
296 - reset_xmpp_pubsub_nodes is much more efficient
297 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
298 - bugfix - deleting a person in the middle of the signup process
299
300 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
301 - ratelimit aspects
302 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
303 - requires Django for cache_utils
304 - attempt to expose 'pldistro' to sfa
305 - last_time_spent_online, last_time_spent_offline: new fields in Node
306 - new slice tags 'isolate_loopback' and 'cpu_cores'
307 - refresh-peer federation logs dump exceptions
308 - modpython logs have a timestamp
309 - more verbose/accurate php error reporting
310 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
311 - AddNode, UpdateNode: manage tags directly rather than through another method
312 - BootUpdateNode: only update once
313 - GetPersons: techs can access the list of persons on their site
314 - GetSlices and GetSliceTags: techs can see slices on their nodes
315 - GetSlivers: isrootonsite tag; cacheable
316
317 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
318 - rename initscript_body into initscript_code
319
320 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
321 - new initscript_body tag
322
323 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
324 - working draft for GetSliceSshKeys
325
326 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
327 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
328 - (this is for people who cancel their download)
329
330 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
331 - fix db-config sequence : accessors step now merged in, and occurs at the right time
332 - db-config also more robust
333 - no more explicit 'accessors' step in plc.d
334
335 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
336 - session auth: do *not* delete session when node runs a method that does not have 'node' role
337 - session auth: remove support for bootonce in old boot CDs
338 - give a reason when caller_may_write_slice_tag fails
339 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
340
341 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
342 - SetSliceVref needed the node role
343 - protect GetSliceFamily
344 - Fix bugs in tag authorizations
345
346 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
347 - altered checking of optional fields in Interfaces
348 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
349 - has pyxml and python-simplejson as new deps
350
351 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
352 - tweak doc extraction for fedora14
353
354 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
355 - builtin accessors for the myslice page
356 - Get{Node,Interface}Tags allowed to techs
357 - tweak in ratelimitaspect.py
358
359 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
360 - add admin role to accessor-related tags (arch, {fc,pl}distro)
361
362 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
363 - bugfix in {Update,Delete}PersonTag
364 - updated xml doc for filters, accessors and tagtypes
365 - more explicit msg in case of missing roles
366 - improvements in ratelimitaspects.py
367
368 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
369 - fix the roles for ssh_key and hmac tags
370
371 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
372 - tag permissions system based on roles and not min_role_ids
373 - accessors simplified accordingly (no more min_role_id)
374 - new methods AddRoleToTagType and DeleteRoleFromTagType
375 - accessor-related tagtypes are created sooner, and enforced
376 - cleaned up redundancy between db-config.d and accessors
377
378 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
379 - fix RefreshPeer that was not working in 5.0-17
380
381 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
382 - RefreshPeer is able to cope with 2 peers running different releases of the api
383 - DeletePerson can be used on duplicates
384 - first appearance of ModPythonJson.py
385
386 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
387 - set accessors return the new value
388 - tweaks in the pubsub groups management
389
390 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
391 - convert hostnames to lower case and use ILIKE instead of LIKE
392
393 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
394 - use hrn in pubsub groups
395
396 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
397 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
398 - OMF fixes
399
400 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
401 - automatically set vsys tag for omf controlled slices
402
403 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
404 - addition of the 'ssh_key' slice tag
405 - first draft of the LDAP interface
406
407 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
408 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
409 - and readable through GetLeaseGranularity
410 - GetSlivers to expose reservation_policy and lease_granularity
411 - GetBootMedium fixed for reservable nodes
412 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
413 - new Apache mod_wsgi python interface
414
415 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
416 - the leases system
417
418 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
419 - previous tag had gone wrong
420
421 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
422 - fix pubsub hostname
423
424 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
425 - tweaks for the omf support (xmpp groups and RC-controlled slices)
426 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
427 - GetNodeFlavour exposes fcdistro
428
429 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
430 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
431
432 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
433 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
434 - pyaspect hooks allow to  maintain the namespace xmpp groups
435 - new omf_slicemgr is a proxy to xmpp, used by these hooks
436 - nodes have their hrn exposed in the 'hrn' tag
437 - node hrn exposed in GetSlivers, as well as the overall xmpp config
438 - system slice 'drl' gets created by db-config
439 - daniel's changes to Filter for supporting wildcards in lists
440 - AddSliceTag consistency check tweaked
441
442 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
443 - major cleanup
444 - get rid of all 4.2-related legacy code
445 - reset the migrations code, planetlab5.sql somes with (5,100)
446 - uses hashlib module when available
447
448 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
449 - first working version of 5.0:
450 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
451 - nodefamily is 3-fold with pldistro-fcdistro-arch
452 - site and person tags
453 - new methods GetSliceFamily and GetNodeFlavour
454 - deprecated the dummynet stuff that were for the external dummyboxes
455 - tags definition : more consistency between db-config scripts and accessors
456 - (get accessor to create the tag type too if absent)
457 - logging an event for AddSliceToNodes
458
459 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
460 - support for fedora 12
461 - fix subtle bug in filtering with ] and quotes
462
463 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
464 - * patch for php-5.3 (the one in f12)
465 - * validate email addresses with regex
466 - * add PersonTags and SiteTags
467 - * add additional accessors for node tags (kvariant, serial, ..)
468
469 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
470 - Redacting password, session, and authstring values from the event log.
471
472 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
473 - let AddSite set ext_consortium_id - required for the poorman registration pages
474 - drop version constraint on Requires: postgresql-python
475 - don't log system calls nor ReportRunLevel
476
477 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
478 - Fix requires for CentOS.
479
480 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
481 - Require postgresql 8.2 (for array operators && and @>)
482
483 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
484 - Filter now supports the | and & features to match in sequence values
485 - bugfix in the postgresql wrapper for sequence filter values
486 - reviewed GetSlivers to export admin keys more efficiently
487 - fix checking roles in UpdateSliceTag
488
489 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
490 - - Some typos in the documentation were fixed.
491 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
492 - to the tag's min_role_id.
493
494 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
495
496 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
497 - Ongoing work to add upcalls, using new SFA class
498 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
499 - reviewed type-checking for the 3 taggable classes node-interface-slice
500 - cleanup ald dummynet stuff
501 - expose the 'extensions' accessors to the API
502 - tweaked checks in AddSliceTag
503 - GetPersons exposes roles by default
504 - bugfix in ReportRunLevel for non-string levels
505 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
506
507 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
508 - new BindObjectToPeer method for sfa
509 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
510
511 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
512 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
513 - reportrunlevel logs its calls only when run_level changes
514 - pycurl more robust wrt to xmlrpclib.Transport
515
516 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
517 - produce a wsdl interface
518 - bugfix in getbootmedium for nodes with interface tags
519
520 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
521 - bugfix for some rare pattern-based filters
522
523 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
524 - improvements in the 4.2 legacy layer
525
526 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
527 - bugfix required for slice tags set on nodegroups
528
529 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
530 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
531
532 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
533 - more powerful legacy layer with 4.2
534
535 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
536 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
537 - migration script has an option for running interactively
538
539 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
540 - skips already added entries
541
542 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
543 - yet another set of fixes for external dummynet boxes
544
545 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
546 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
547 - and tmp file is cleaned up
548
549 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
550 - restore missing ResolveSlices
551
552 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
553 - new method GetDummyBoxMedium
554
555 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
556 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
557
558 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
559 - support for external dummynet boxes back in 4.3 - first draft
560
561 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
562 - fixes for smooth federation between 4.2 and 4.3
563 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
564
565 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
566 - support for BootCD variants (GetBootMedium ['variant:centos5'])
567 - fix corner case with filters like {'~slice_id':[]}
568 - fix transaction leak that caused the db connections pool to exhaust
569 - properly expose all methods, including Legacy/, and not only Methods/
570
571 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
572 - renumbered as 4.3
573 - nodes have new fields run_level (in addition to boot_state) and verified
574 - tweaked migration from 4.2
575 - tuned rpm dependencies
576 - doc generation more explicit about errors like missing python modules
577 - removed obsolete method GetSlicesMD5
578
579 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
580 - unified all tags
581 - renamed interface settings into interface tags and slice attributes into slice tags
582 - nodes have a node_type
583 - various changes on the way to 4.3
584
585 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
586 - Checkpointing : this version still has interface settings and slice attributes
587
588 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
589 - first iteration with taggable nodes/interfaces/slices
590 - embryo for ilinks
591 - cleaned up boot states
592 - migration script moslty complete
593
594 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
595 - fixed doc build by locating locally installed DTDs at build-time
596
597 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
598 - no more doc packaged outside of myplc-docs - doc/ cleaned up
599 - enhancements in doc on filters
600 - bootcd-aware GetBootMedium merged from onelab
601
602 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
603 - checkpoint while the new myplc-docs package is underway
604 - bugfix: GetSlivers & conf files
605 - doc: removed target files
606
607 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
608 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
609 - the non-deleted fields were index, resulting in massivly slow queries.
610 -
611
612 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
613 - plcsh: better handling of options when running as a shell script
614 - getbootmedium exports compute_key
615 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
616
617 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
618 - GetBootMedium support for build.sh full options, incl. serial & console_spec
619 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
620
621 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
622 - refresh peer script to use a month-dependent logfile
623 - tracking the starting point for UniPi integration of the dummynet boxes
624
625 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
626 - plcsh adds its own path to sys.path
627 - fix so GetNodes can be called from a Node
628
629 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> -
630 - Initial build.
631
632 %define module_current_branch 4.3