added create_network(), delete_network(), create_subnet(), delete_subnet(), process_t...
[plcapi.git] / PLCAPI.spec
index d140608..8922f66 100644 (file)
@@ -1,10 +1,10 @@
 %define name PLCAPI
 %define version 5.1
-%define taglevel 1
+%define taglevel 3
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
-Summary: PlanetLab Central API
+Summary: PlanetLab Nova Central API
 Name: %{name}
 Version: %{version}
 Release: %{release}
@@ -22,12 +22,10 @@ Obsoletes: plcapilib
 
 # We use set everywhere
 Requires: python >= 2.4
-Requires: postgresql >= 8.2, postgresql-server >= 8.2
-Requires: postgresql-python
-Requires: python-psycopg2
 Requires: python-pycurl
 Requires: httpd
-Requires: mod_python
+Requires: python-gevent
+Requires: python-lxml
 # mod_wsgi will replace mod_python when we are ready
 Requires: mod_wsgi
 Requires: mod_ssl
@@ -47,12 +45,6 @@ Requires: memcached
 Requires: Django
 ### avoid having yum complain about updates, as stuff is moving around
 # plc.d/api
-Conflicts: MyPLC <= 4.3
-
-# We use psycopg2
-#
-# but we don't need to rebuild it as we depend on distro's packages - baris
-# BuildRequires: postgresql-devel
 
 # Standard xmlrpc.so that ships with PHP does not marshal NULL
 BuildRequires: php-devel PyXML python-simplejson
@@ -145,6 +137,17 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
+- fixed imports for tags management with sites and persons
+- add predefined 'cpu_freezable' tag
+
+* Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
+- tweaks in interface initialization
+- has 'vsys_vnet' as a predefined tagtype
+- bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
+- bugfix: GetSlivers & nodegroups
+- bugfix: in jabber groups management
+
 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
 - fix gpg-authentication for Persons (thanks Jordan)
 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)