Merge remote-tracking branch 'origin/pycurl' into planetlab-4_0-branch
[plcapi.git] / PLCAPI.spec
index 3b110f0..f96be93 100644 (file)
@@ -1,16 +1,37 @@
 Summary: PlanetLab Central API
 Name: PLCAPI
-Version: 4.0
-Release: 1
+Version: 4.1
+Release: 3%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 License: PlanetLab
 Group: System Environment/Daemons
 URL: http://cvs.planet-lab.org/cvs/new_plc_api
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-BuildRequires: docbook-dtds, docbook-utils-pdf
+Obsoletes: plcapilib
 
-Requires: postgresql-server, SOAPpy
+# We use set everywhere
+Requires: python >= 2.4
+
+# We use psycopg2
+BuildRequires: postgresql-devel
+
+# Standard xmlrpc.so that ships with PHP does not marshal NULL
+BuildRequires: php-devel
+Obsoletes: php-xmlrpc
+Provides: php-xmlrpc
+
+# OpenJade does not honor XML catalog files and tries to access
+# www.oasis-open.org even if DTDs are locally installed. Disable
+# documentation generation for now.
+# BuildRequires: docbook-dtds, docbook-utils-pdf
+
+# PostgreSQL and SOAPpy are necessary to run the API server, but not
+# plcsh. Since the only supported method of running the server is via
+# MyPLC anyway, don't be so stringent about binary requirements, in
+# case people want to install this package just for plcsh.
+# Requires: postgresql-server, SOAPpy
+AutoReqProv: no
 
 %description
 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
@@ -22,33 +43,38 @@ through Apache mod_python.
 %setup -q
 
 %build
-# Build __init__.py metafiles, documentation, and PHP API
-%{__make} %{?_smp_mflags}
-
-# Byte compile
-%{__python} setup.py build
+# Build __init__.py metafiles and PHP API. Do not build documentation
+# for now.
+%{__make} %{?_smp_mflags} subdirs="php php/xmlrpc"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-# Install in /usr/share/plc_api
-%{__python} setup.py install \
-    --install-purelib=$RPM_BUILD_ROOT/%{_datadir}/plc_api \
-    --install-data=$RPM_BUILD_ROOT/%{_datadir}/plc_api
+%{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
 
 # Install shell symlink
 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
-ln -s %{_datadir}/plc_api/Shell.py $RPM_BUILD_ROOT/%{_bindir}/plcsh
+ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
+
+mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
+cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
+; Enable xmlrpc extension module
+extension=xmlrpc.so
+EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%define php_extension_dir %(php-config --extension-dir)
+
 %files
 %defattr(-,root,root,-)
 %doc doc/PLCAPI.xml doc/PLCAPI.pdf doc/PLCAPI.html
 %dir %{_datadir}/plc_api
-%{_datadir}/plc_api
+%{_datadir}/plc_api/*
 %{_bindir}/plcsh
+%{php_extension_dir}/xmlrpc.so
+%{_sysconfdir}/php.d/xmlrpc.ini
+%{_bindir}/refresh-peer.py*
 
 %changelog
 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> -