fixed: encodes boolean and double type values for the requests
[plcapi.git] / plcapi.spec
index 47b84cb..5a8ed46 100644 (file)
@@ -1,6 +1,6 @@
 %define name plcapi
 %define version 5.3
-%define taglevel 10
+%define taglevel 11
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -38,7 +38,7 @@ Requires: python-lxml
 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
 Requires: SOAPpy
 %endif
-Requires: python-simplejson
+#Requires: python-simplejson
 # for the RebootNodeWithPCU method
 Requires: pcucontrol >= 1.0-6
 # for OMF integration
@@ -53,17 +53,15 @@ Requires: memcached python-memcached
 # plc.d/api
 Conflicts: MyPLC <= 4.3
 
-# We use psycopg2
-#
-# but we don't need to rebuild it as we depend on distro's packages - baris
-# BuildRequires: postgresql-devel
-
-# Standard xmlrpc.so that ships with PHP does not marshal NULL
-# for building the wsdl interface we used to require PyXML
-# but this has gone with f20 so turning this off for now
-BuildRequires: php-devel python-simplejson
-Obsoletes: php-xmlrpc
-Provides: php-xmlrpc
+# standard xmlrpc.so that ships with PHP does not marshal NULL
+# prior to May 2017 we used to ship our own brew of xmlrpc but
+# that does not build anymore on f25
+# So bottom line is:
+# * don't use fedora's php-xmlrpc (no support for marshalling NULL)
+# * don't use our own that is way too old
+# * instead, thanks to Ciro we pull it from
+# https://github.com/gggeek/phpxmlrpc.git
+# Requires: php-xmlrpc
 
 # PostgreSQL and SOAPpy are necessary to run the API server, but not
 # plcsh. Since the only supported method of running the server is via
@@ -98,11 +96,11 @@ rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
 
-mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
-cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
-; Enable xmlrpc extension module
-extension=xmlrpc.so
-EOF
+### mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
+### cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
+### ; Enable xmlrpc extension module
+### extension=xmlrpc.so
+### EOF
 
 # Install initscripts
 echo "* Installing initscripts"
@@ -133,7 +131,7 @@ chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%define php_extension_dir %(php-config --extension-dir)
+###%define php_extension_dir %(php-config --extension-dir)
 
 %files
 %defattr(-,root,root,-)
@@ -141,8 +139,8 @@ rm -rf $RPM_BUILD_ROOT
 #%dir /var/log/omf/
 %{_datadir}/plc_api/*
 %{_bindir}/plcsh
-%{php_extension_dir}/xmlrpc.so
-%{_sysconfdir}/php.d/xmlrpc.ini
+### %{php_extension_dir}/xmlrpc.so
+### %{_sysconfdir}/php.d/xmlrpc.ini
 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
 /etc/plc.d
 /etc/planetlab/db-config.d
@@ -153,6 +151,18 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
+- mostly issued for the R2lab deployment
+- *** major
+- * dots allowed in login_base and slice name
+- * new lease filter 'day'
+- *** minor
+- * more explicit message in case of overlapping resas
+- * bugfix: escaping unicode in xml
+- * GetLeases allowed to anonymous callers
+- *** miscell
+- * use plain json library
+
 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console