remove requirements that are no longer available in f29 - use pip when appropriate
[plcapi.git] / plcapi.spec
index b1c32f5..5d95e00 100644 (file)
@@ -1,6 +1,6 @@
 %define name plcapi
-%define version 5.3
-%define taglevel 11
+%define version 5.4
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -23,7 +23,8 @@ Obsoletes: PLCAPI
 
 # requirement to mod_python or mod_wsgi: deferred to myplc
 Requires: httpd mod_ssl
-Requires: Django
+# f29 does not come with an rpm for that; use pip instead
+# Requires: Django
 Requires: postgresql >= 8.2, postgresql-server >= 8.2
 # We use set everywhere
 Requires: python >= 2.7
@@ -43,8 +44,9 @@ Requires: SOAPpy
 Requires: pcucontrol >= 1.0-6
 # for OMF integration
 Requires: pyaspects >= 0.4
-Requires: python-twisted-words
-Requires: python-twisted-web
+# again, these are no longer available in f29
+# Requires: python-twisted-words
+# Requires: python-twisted-web
 # ldap
 Requires: python-ldap
 # for memcache
@@ -53,15 +55,21 @@ Requires: memcached python-memcached
 # plc.d/api
 Conflicts: MyPLC <= 4.3
 
+####################
+# obsolete
+####################
 # standard xmlrpc.so that ships with PHP does not marshal NULL
 # prior to May 2017 we used to ship our own brew of xmlrpc but
 # that does not build anymore on f25
 # So bottom line is:
 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
 # * don't use our own that is way too old
-# * instead, thanks to Ciro we pull it from
+# * instead - thank you Ciro - we pull it as a git subtree from
 # https://github.com/gggeek/phpxmlrpc.git
-# Requires: php-xmlrpc
+# that stuff requires the following though
+Requires: php-xml
+####################
+
 
 # PostgreSQL and SOAPpy are necessary to run the API server, but not
 # plcsh. Since the only supported method of running the server is via
@@ -96,12 +104,6 @@ rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
 
-### mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
-### cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
-### ; Enable xmlrpc extension module
-### extension=xmlrpc.so
-### EOF
-
 # Install initscripts
 echo "* Installing initscripts"
 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
@@ -143,18 +145,26 @@ rm -rf $RPM_BUILD_ROOT
 #%dir /var/log/omf/
 %{_datadir}/plc_api/*
 %{_bindir}/plcsh
-### %{php_extension_dir}/xmlrpc.so
-### %{_sysconfdir}/php.d/xmlrpc.ini
 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
 /etc/plc.d
 /etc/planetlab/db-config.d
 /var/www/html/wsdl/plcapi.wsdl
 #/usr/bin/omf_slicemgr.py*
 #/usr/bin/reset_xmpp_pubsub_nodes.py*
+/var/log/plcapi.log
 /var/log/plc_api_ratelimit.log
 
 
 %changelog
+* Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
+- define accessor for site tag disabled_registration (used in plewww-5.2-9)
+- set disable_existing_loggers = False in logging config, that otherwise voids sfa logs
+
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
+- embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
+- logs in /var/log/plcapi.log
+- context managers for most open files
+
 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
 - mostly issued for the R2lab deployment
 - *** major