change designed for illustrative purposes
[plcapi.git] / plcapi.spec
index 2d3f5f4..b9f523c 100644 (file)
@@ -1,6 +1,6 @@
 %define name plcapi
-%define version 5.2
-%define taglevel 6
+%define version 5.3
+%define taglevel 3
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -21,15 +21,17 @@ URL: %{SCMURL}
 Provides: PLCAPI
 Obsoletes: PLCAPI
 
-# We use set everywhere
-Requires: python >= 2.4
+# requirement to mod_python or mod_wsgi: deferred to myplc
+Requires: httpd mod_ssl
+Requires: Django
 Requires: postgresql >= 8.2, postgresql-server >= 8.2
+# We use set everywhere
+Requires: python >= 2.7
 Requires: postgresql-python
 Requires: python-psycopg2
 Requires: python-pycurl
-Requires: httpd
-# requirement to mod_python or mod_wsgi: deferred to myplc
-Requires: mod_ssl
+# used in GPG.py as a replacement to PyXML's Canonicalize
+Requires: python-lxml
 Requires: SOAPpy
 Requires: python-simplejson
 # for the RebootNodeWithPCU method
@@ -41,9 +43,7 @@ Requires: python-twisted-web
 # ldap
 Requires: python-ldap
 # for memcache
-Requires: python-memcached
-Requires: memcached
-Requires: Django
+Requires: memcached python-memcached
 ### avoid having yum complain about updates, as stuff is moving around
 # plc.d/api
 Conflicts: MyPLC <= 4.3
@@ -54,7 +54,9 @@ Conflicts: MyPLC <= 4.3
 # BuildRequires: postgresql-devel
 
 # Standard xmlrpc.so that ships with PHP does not marshal NULL
-BuildRequires: php-devel PyXML python-simplejson
+# for building the wsdl interface we used to require PyXML
+# but this has gone with f20 so turning this off for now
+BuildRequires: php-devel python-simplejson
 Obsoletes: php-xmlrpc
 Provides: php-xmlrpc
 
@@ -146,6 +148,35 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
+- provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
+- don't use PyXML that is deprecated in f20, use lxml instead
+- higher max size for login_base (32 vs 20) and slice name (64 vs 32)
+
+* Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
+- create accessor 'hrn' for site as well
+- create accessors 'sfa_created' for site/slice/person
+- AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
+- UpdatePerson() updates Person HRN according to updated email.
+- UpdateSite() updates Site HRN according to updated login_base.
+- Fix AddPersonToSite().
+- GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
+- RefreshPeer() manages Site*Person and Person*Role relationships.
+
+* Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
+- provide a slicename_to_hrn function
+
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
+- add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
+
+* Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
+- fix for wsgi-based deployments, each thread has its own api()
+
+* Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
+- also cleanup omf-slicemgr initscript
+
 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
 - tear down omf-related aspects as this is no longer needed with omfv6