Merge from trunk
[plcapi.git] / trunk / setup.py
diff --git a/trunk/setup.py b/trunk/setup.py
new file mode 100755 (executable)
index 0000000..7206a9e
--- /dev/null
@@ -0,0 +1,20 @@
+#!/usr/bin/python
+#
+# Setup script for PLCAPI
+#
+# Mark Huang <mlhuang@cs.princeton.edu>
+# Copyright (C) 2006 The Trustees of Princeton University
+#
+# $Id$
+#
+
+from distutils.core import setup
+from glob import glob
+
+setup(py_modules = ['ModPython'],
+      packages = ['PLC', 'PLC/Methods', 'PLC/Methods/system'],
+      scripts = ['plcsh', 'Server.py'],
+      data_files = [('', ['planetlab4.sql']),
+                    ('php', ['php/plc_api.php']),
+                    ('migrations', ['migrations/README.txt'] + glob('migrations/[0-9][0-9][0-9]*')),
+                    ])