d60d085ece3cc59476cbf3722e485e08ac8077a4
[plewww.git] / plewww.spec
1 # what the myplc rpm requires
2 %define name plewww
3 %define version 4.3
4 %define taglevel 67
5
6 # no need to mention pldistro as this module differs in both distros
7 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %define release %{taglevel}%{?date:.%{date}}
9
10 Summary: PlanetLab Europe (PLC) Web Pages
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: Applications/Systems
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18 BuildArch: noarch
19 BuildRequires: python
20
21 Vendor: OneLab
22 Packager: OneLab <support@one-lab.org>
23 Distribution: PlanetLab %{version}
24 URL: %{SCMURL}
25
26 # We use set everywhere
27 #Requires: httpd >= 2.0
28 Requires: php >= 5.0
29 Requires: postgresql >= 8.0
30 Requires: PLCAPI >= 4.3
31 Requires: drupal = 4.7
32 Requires: plewww-plekit
33
34 # this is what MyPLC requires
35 Provides: PLCWWW
36
37 # on centos5, when rebuilding the full monty, we get:
38 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
39 # and the perl-GD rpm is nowhere to be found
40 AutoReqProv: no
41
42 %package plekit
43 Summary: Utilities used by the plewww pages
44 Group: Applications/Systems
45
46 %description
47 The plewww package is made of the web pages that run on top of the 
48 PLCAPI component to provide the Web Interface to MyPLC users.
49
50 %description plekit
51 This subset of the plewww package has general purpose features for the benefit of other PL-related UI components.
52
53 %prep
54 %setup -q
55
56 %build
57 echo "Compressing javascript files"
58 make compress
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 #
64 # plewww
65 # xxx : uninstall should undo this
66 #
67
68 echo "* PLEWWW: Installing web pages"
69 mkdir -p $RPM_BUILD_ROOT/var/www/html
70 # exclude codebase just in case
71 rsync -a --exclude jsmin.py --exclude Makefile --exclude httpd --exclude \*.spec --exclude .svn ./ $RPM_BUILD_ROOT/var/www/html/
72
73 echo "* PLEWWW: Installing conf files for httpd"
74 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
75 install -D -m 644 httpd/*.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
76
77 %post
78 # attempt to perform most of the drupal post-install stuff - assuming version 6.x
79 drupal_settings_dir=/var/www/html/sites/default
80 if [ ! -d $drupal_settings_dir ] ; then
81     echo "Could not find directory $drupal_settings_dir"
82     echo "This suggests that you do not have a planetlab-custom drupal installed"
83     exit 1
84 fi
85 pushd $drupal_settings_dir
86 # tune $db_url
87 if [ ! -f settings.php.drupal ] ; then
88     cp settings.php settings.php.drupal
89     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
90         settings.php.drupal > settings.php
91 fi
92 popd
93 # append our own database creation hacks to the drupal database schema
94 pushd /var/www/html/database
95 if [ ! -f database.pgsql.drupal ] ; then
96     cp database.pgsql database.pgsql.drupal
97     cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
98 fi
99 popd
100 # hack the welcome page for MyPLC
101 pushd /var/www/html/modules
102 for module in user node; do
103     # backup only once
104     [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
105     # always update so a change in our file can make through
106     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
107 done
108 popd
109 # create myslice.log and change its ownership
110 touch /var/log/myslice.log
111 chown apache:apache /var/log/myslice.log
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(-,root,root,-)
118 /var/www/html/modules
119 /var/www/html/planetlab
120 /var/www/html/googlemap
121 /var/www/html/drupal-hacks
122 /etc/httpd/conf.d
123
124 %files plekit
125 /var/www/html/plekit
126
127 %changelog
128 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
129 - node page can edit interfaces even when no interface
130
131 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
132 - uses a 2-week (!) session
133
134 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
135 - minor/cosmetic fixes in the leases area
136
137 * Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
138 - new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
139 - uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
140 - has a feature to 'test' pcu connection
141 - only admins can add users to different sites.
142 - remove dep. to outdated _gen_planetflow.php
143 - rephrased (disabled, or pending registration)
144 - + various fixes
145
146 * Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
147 - fix display glitch exposed with dimes initscript
148
149 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
150 - rename initscript_body into initscript_code
151
152 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
153 - bugfix for the reservation interface
154
155 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
156 - reservation page uses ajax - no need to reload after submit
157 - reservation dialogs for offset in the future & # slots
158 - fix the timezone in reservations (actually use php.ini)
159 - reservation visible (and hardwired) in nodes view
160 - have pulled prototype 1.7 but not in used yet
161
162 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
163 - set both 'omf_control' and 'vref' for omf-friendly slices
164
165 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
166 - display tags in alphabetic order in node view, tags section, the drop down menu
167
168 * Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
169 - on-the-fly retrieval of data at comon & tophat (unused so far)
170 - use accessors to store person's preference of columns
171 - fix in toggle.js for the '?' button, node table layout tab
172 - sort actions logging improved
173
174 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
175 - keep people from disabling or deleting themselves
176 - cannot become a disabled person
177 - outline people without a role
178
179 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
180 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
181
182 * Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
183 - tagging plewww for a new deployment
184
185 * Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
186 - add a 'report a problem' link for the RebootNode button
187 - new exp page nodes2.php with consistent selectable-columns layout as myslice
188 - tweaks in the exp. myslice (slices.php)
189
190 * Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
191 - new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
192 - my_slice with adjustable set of columns in slices/slice2.php
193 - fix for the 'site registration' page
194
195 * Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
196 - show message about leases - leases tab first in nodes section
197 - fix how reservable nodes show up
198
199 * Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
200 - cosmetic, rendering of textareas was like password fields
201
202 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
203 - bugfix in slice page, had wrong (null) expiration date
204 - upgraded to raphael-1.5.2, don't minimize this lib
205 - nicer layout for password fields as well
206 - long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
207 - marginally optimized slice page (2 GetNodes call down)
208 - minimal profiling cap., and usable in the slice page with _GET[profiling]=1
209 - _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
210 - reservations can cope with a bit more slots - will need scrolling someday
211 - omf text has hyperlinks to the tools
212
213 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
214 - reservation section now effective
215 - can set omf_control at slice-creation time
216 - can set node as reservable at node-creation time
217 - nicer text input fields + various tweaks
218
219 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
220 - show nodegroups form to add new groups
221
222 * Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
223 - just tagging plewww again to test module-tag on git
224
225 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
226 - encode strings properly in forms.
227
228 * Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
229 - Use readfile() function to reduce the memory footprint
230
231 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
232 - removed all deprecated functions for PHP-5.3 on fedora 12
233
234 * Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
235 - * exclude DNS from subnet checking
236 - * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
237 - * allow longer abbreviated names
238 - * don't let empty strings kill the server (postgresql and apache)
239
240 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
241 - disable drupal user registration (hard: patching the user module)
242
243 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
244 - * show error messages for update interface
245 - * 'Add Node' is admin only
246 - * add site selector for 'Add Node'
247
248 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
249 - new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
250 - this affects the settings of ifname and alias that were formerly set unconditionally
251 - review the interface-checking javascript code
252 - changed the interface to plekitform, method is now optional and part of an options hash
253
254 * Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
255 - can't use php objects for showing node status, this is too slow
256 - fix interface add page
257
258 * Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
259 - consistency in the way nodes status is displayed in the node and slice areas
260 - extra tags columns show up on the nodes page as well, tweaked in the process
261 - roles management in person page fixed
262
263 * Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
264 - displaying node tags in the nodes page as well
265 - table headers now can have a 'title' that shows up when hovering on the column header
266
267 * Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
268 - bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
269
270 * Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
271 - extensible set of columns in the nodes area of the (my)slice page
272 - nodegroups can be added/deleted/updated
273 - tags management improved marginally
274
275 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
276 - fix pending sites page - was getting fooled by ext_consortium_id=None
277
278 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
279 - resetting tag as something went wrong when setting 31
280
281 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
282 - nicer look for slice creation, (public) sites
283 - users show with all their sites in the persons page
284
285 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
286 - reviewed registration pages for persons and sites
287
288 * Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
289 - increase memory limit in the nodes page
290
291 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
292 - fixes one typo
293
294 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
295 - minor/cosmetic
296
297 * Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
298 - Add default Interface tags to extra interfaces.
299 - Add clearer 'Add New PCU' link on node page.
300 - Disable user registration for tech and PI roles.
301
302 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
303 - new 'controller' instantiation state available in add slice page
304
305 * Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
306 - exclude datepicler.js from jsmin
307 - table sort function for Last Contact columns
308 - drop options for generic boot images
309
310 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
311 - displays editable mac address for interfaces
312 - properly sorts bandwidths
313 - new 'controller' slice instantiation method
314 - bugfix, division by zero when displaying a just-changed node
315
316 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
317 - bugfix with linetabs
318
319 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
320 - fix add interface from the node page
321
322 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-19
323 - only add users that are enabled and not yet a member of the slice
324 - fix to plc_peers
325 - my sites, my nodes, my persons improvements for users with multiple sites
326 - adds a script to minimize the java script files.
327
328 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-18
329 - planetlab module to show 'All My Sites Nodes' link rather than 'My Site Nodes' if several sites
330
331 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-17
332 - first draft for pcu-handling features
333 - lighter contrat for PLE/PLC toggles
334 - as many 'my site'-like  links as the user has sites
335
336 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-16
337 - fix for whitelisted nodes
338 - now links to the node register wizard
339 - can enable sites
340 - various other minor fixes, like broken planetlab.module for techs, and login link
341
342 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-15
343 - plekittable knows how to turn off sort-on-load, and the admin users pages do
344 - + various cosmetic fixes
345
346 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-14
347 - a few minor improvements pushed on PLE
348
349 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-13
350 - fix for sites that were displayed as not public
351 - improvements to the python interface to sortable tables for monitor
352
353 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-12
354 - various improvements
355
356 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-11
357 - sliver page now correctly shows sliver tags
358 - support for download-node-usb-partition and various other improvements
359
360 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-10
361 - a few tweaks and typos fixed on PLE
362
363 * Tue Apr 21 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-9
364 - slice_add & node_download dialogs use plekit
365 - slice_add can add people in the slice
366 - various improvements after rollout on PLE
367
368 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-8
369 - cosmetic fixes to be in 4.3-rc2
370 - also a first (unpackaged) draft of the plekit table in python
371
372 * Tue Apr 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-7
373 - search in tables more robust
374
375 * Thu Apr 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-6
376 - performance improvements
377
378 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-5
379 - detect expired session and redirect to the login page
380
381 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-4
382 - improve browser health - was using too many cycles
383
384 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-3
385 - more consistency between views, and cosmetic changes
386
387 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-2
388 - area for managing slice tags
389
390 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-1
391 - first checkpoint tag for PLEWWW
392 - mostly functionally complete, probably a lot of tweaks still needed
393
394 * Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
395 - everyone is welcome to add nodes
396
397 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
398 - node-specific bootcd images to include arch in their name
399
400 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
401 - remove explicit dep to bootcd as the rpm name has changed
402
403 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
404 - noarch
405
406 * Fri Feb 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-6 PLCWWW-4.2-7
407 - should fix yum.conf on nodes after install
408
409 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-5 PLCWWW-4.2-6
410 - uses different path for getbootmedium results - should be safer
411
412 * Sun Feb 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-4 PLCWWW-4.2-5
413 - comon icon replaced with the one from the comon website
414
415 * Fri Feb 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-3 PLCWWW-4.2-4
416 - displays rpms in the about page
417
418 * Thu Feb 07 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-2 PLCWWW-4.2-3
419 - safer, reference-less, way to implement layout mechnism - see
420 - settings.php for details
421 - setting types properly displayed according to user's role
422 - setting deletion : fixed (was still using code from slice attribute)
423 - more comon buttons : in the nodes and peers index pages
424 - comon_button knows about peer_id
425
426 * Tue Jan 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-1 PLCWWW-4.2-2
427 - merged the PlanetLabConf from Princeton's tag PLCWWW-4.1-1
428
429 * Mon Apr 16 2007 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
430 - Initial build.