rollback to drupal 4.7
[plewww.git] / PLCWWW.spec
index 450a96d..93c7018 100644 (file)
@@ -76,18 +76,16 @@ if [ ! -f settings.php.distrib ] ; then
     cp settings.php settings.php.distrib
     sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
         settings.php.distrib > settings.php
-#    chown apache:apache settings.php
-#    chmod 444 settings.php
 fi
 popd
-#drupal_files_dirs="/var/www/html/files /var/www/html/sites/default/files"
-#for dir in $drupal_files_dirs; do 
-#    if [ ! -d $dir ] ; then
-#      mkdir -p $dir
-#      chown apache:apache $dir
-#    fi
-#done
-# drupal install script cannot be invoked here yet - pgsql might not even be running
+# append our own database creation hacks to the drupal database schema
+drupal_database_dir=/var/www/html/database
+pushd $drupal_database_dir
+if [ ! -f database.pgsql.distrib ] ; then
+    cp database.pgsql database.pgsql.distrib
+    cat database.pgsql.distrib ../drupal-hacks/database.pgsql > database.pgsql
+fi
+popd
 
 %clean
 rm -rf $RPM_BUILD_ROOT