fix
[plewww.git] / PLCWWW.spec
index 0c4b2d9..ba4aa86 100644 (file)
@@ -1,14 +1,17 @@
 #
-# $Id: PLCWWW.spec 1206 2008-03-03 15:49:07Z thierry $
+# $Id$
 #
-%define module_taglevel_varname subversion
+
+# what the myplc rpm requires
 %define name PLCWWW
-%define version onelab.4.2
-%define subversion 8
+%define version PLE.5.0
+%define taglevel 0
 
-%define release %{subversion}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+# no need to mention pldistro as this module differs in both distros
+#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?date:.%{date}}
 
-Summary: PlanetLab Central (PLC) Web Pages
+Summary: PlanetLab Europe (PLC) Web Pages
 Name: %{name}
 Version: %{version}
 Release: %{release}
@@ -27,7 +30,8 @@ URL: http://svn.one-lab.org/svn/new_plc_www/
 #Requires: httpd >= 2.0
 Requires: php >= 5.0
 Requires: postgresql >= 8.0
-Requires: PLCAPI >= 4.2
+Requires: PLCAPI >= 5.0
+Requires: drupal = 4.7
 
 # on centos5, when rebuilding the full monty, we get:
 # Error: Missing Dependency: perl(GD) is needed by package PLCWWW
@@ -52,13 +56,44 @@ rm -rf $RPM_BUILD_ROOT
 # plcwww
 #
 
-echo "* PLCWWW: Installing web pages"
+echo "* PLEWWW: Installing web pages"
 mkdir -p $RPM_BUILD_ROOT/var/www/html
 # let's be conservative and exclude codebase files, though there should not be any
 rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
 
-echo "* PLCWWW: Installing drupal config for httpd"
-install -D -m 644 drupal.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/drupal.conf
+echo "* PLEWWW: Installing config for httpd"
+install -D -m 644 httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/plcwww.conf
+
+%post
+# attempt to perform most of the drupal post-install stuff - assuming version 6.x
+drupal_settings_dir=/var/www/html/sites/default
+if [ ! -d $drupal_settings_dir ] ; then
+    echo "Could not find directory $drupal_settings_dir"
+    echo "This suggests that you do not have a planetlab-custom drupal installed"
+    exit 1
+fi
+pushd $drupal_settings_dir
+# tune $db_url
+if [ ! -f settings.php.drupal ] ; then
+    cp settings.php settings.php.drupal
+    sed -e 's|^[ \t]*\$db_url.*|require_once("plc_config.php");$db_url="pgsql://" . PLC_DB_USER . ":" . PLC_DB_PASSWORD . "@" . PLC_DB_HOST . ":" . PLC_DB_PORT . "/drupal";|' \
+        settings.php.drupal > settings.php
+fi
+popd
+# append our own database creation hacks to the drupal database schema
+pushd /var/www/html/database
+if [ ! -f database.pgsql.drupal ] ; then
+    cp database.pgsql database.pgsql.drupal
+    cat database.pgsql.drupal ../drupal-hacks/database.pgsql > database.pgsql
+fi
+popd
+# hack the welcome page for MyPLC
+pushd /var/www/html/modules
+if [ ! -f node.module.drupal ] ; then
+    cp node.module node.module.drupal
+    [ -f /var/www/html/drupal-hacks/node.module ] && cp -f /var/www/html/drupal-hacks/node.module /var/www/html/modules/node.module
+fi
+popd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -66,9 +101,18 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(-,root,root,-)
 /var/www/html
-/etc/httpd/conf.d/drupal.conf
+/etc/httpd/conf.d/plcwww.conf
 
 %changelog
+* Fri Apr 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-11
+- everyone is welcome to add nodes
+
+* Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-10
+- node-specific bootcd images to include arch in their name
+
+* Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-onelab.4.2-9
+- remove explicit dep to bootcd as the rpm name has changed
+
 * Mon Mar 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCWWW-4.2-7 PLCWWW-4.2-8
 - noarch