Setting tag plewww-4.3-45
[plewww.git] / plewww.spec
index 47c3bf1..518e559 100644 (file)
@@ -5,7 +5,7 @@
 # what the myplc rpm requires
 %define name plewww
 %define version 4.3
-%define taglevel 40
+%define taglevel 45
 
 # no need to mention pldistro as this module differs in both distros
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -103,10 +103,12 @@ fi
 popd
 # hack the welcome page for MyPLC
 pushd /var/www/html/modules
-if [ ! -f node.module.drupal ] ; then
-    cp node.module node.module.drupal
-    [ -f /var/www/html/drupal-hacks/node.module ] && cp -f /var/www/html/drupal-hacks/node.module /var/www/html/modules/node.module
-fi
+for module in user node; do
+    # backup only once
+    [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
+    # always update so a change in our file can make through
+    cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
+done
 popd
 
 %clean
@@ -124,6 +126,24 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/plekit
 
 %changelog
+* Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
+- encode strings properly in forms.
+
+* Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
+- Use readfile() function to reduce the memory footprint
+
+* Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
+- removed all deprecated functions for PHP-5.3 on fedora 12
+
+* Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
+- * exclude DNS from subnet checking
+- * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
+- * allow longer abbreviated names
+- * don't let empty strings kill the server (postgresql and apache)
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
+- disable drupal user registration (hard: patching the user module)
+
 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
 - * show error messages for update interface
 - * 'Add Node' is admin only