Setting tag plewww-5.2-2
[plewww.git] / plewww.spec
index d42fb6e..62156b0 100644 (file)
@@ -1,11 +1,7 @@
-#
-# $Id$
-#
-
 # what the myplc rpm requires
 %define name plewww
-%define version 4.3
-%define taglevel 49
+%define version 5.2
+%define taglevel 2
 
 # no need to mention pldistro as this module differs in both distros
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -25,13 +21,13 @@ BuildRequires: python
 Vendor: OneLab
 Packager: OneLab <support@one-lab.org>
 Distribution: PlanetLab %{version}
-URL: http://svn.one-lab.org/svn/new_plc_www/
+URL: %{SCMURL}
 
 # We use set everywhere
 #Requires: httpd >= 2.0
 Requires: php >= 5.0
 Requires: postgresql >= 8.0
-Requires: PLCAPI >= 4.3
+Requires: plcapi >= 5.2
 Requires: drupal = 4.7
 Requires: plewww-plekit
 
@@ -110,6 +106,9 @@ for module in user node; do
     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
 done
 popd
+# create myslice.log and change its ownership
+touch /var/log/myslice.log
+chown apache:apache /var/log/myslice.log
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -126,6 +125,116 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/plekit
 
 %changelog
+* Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
+- node page and person page show hrn in details
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
+- late fix of registration for plcapi-5.1-6
+
+* Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
+- add extra code to prevent confidentiality leaks
+- for vicci: $plc->hide_planetlab_block, that should not affect mainstream
+- return_url for add-person and remove-person
+- myslice.log now in /var/log/myslice/ (should have been cleaned up..)
+
+* Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
+- add tags section on site and person pages
+
+* Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
+- slightly tweak profiling points in slice.php
+
+* Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
+- ships with new default images for PLC/PLE from planet-lab.eu
+
+* Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
+- no change, just make sync for lxc-hosted tests
+
+* Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
+- refactoring for tophat/columns
+- should take care of the irritating warning message about columns
+
+* Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
+- do not display the 'node' role when confusing
+
+* Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-68
+- support for setting nodes as reservable
+- rely more on previous state when deciding to open or not toggles in a view
+- remove statements for setting maximum memory usage, that sometimes
+
+* Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-67
+- node page can edit interfaces even when no interface
+
+* Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-66
+- uses a 2-week (!) session
+
+* Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-65
+- minor/cosmetic fixes in the leases area
+
+* Mon Jun 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-64
+- new jstorage to store stuff in the browser, start to use that to "remember" the open/closed tabs
+- uses MYSLICE_TOPHAT_AVAILABLE and MYSLICE_COMON_AVAILABLE to decide whether to add extra data
+- has a feature to 'test' pcu connection
+- only admins can add users to different sites.
+- remove dep. to outdated _gen_planetflow.php
+- rephrased (disabled, or pending registration)
+- + various fixes
+
+* Wed Mar 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-63
+- fix display glitch exposed with dimes initscript
+
+* Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-62
+- rename initscript_body into initscript_code
+
+* Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-61
+- bugfix for the reservation interface
+
+* Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-60
+- reservation page uses ajax - no need to reload after submit
+- reservation dialogs for offset in the future & # slots
+- fix the timezone in reservations (actually use php.ini)
+- reservation visible (and hardwired) in nodes view
+- have pulled prototype 1.7 but not in used yet
+
+* Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-59
+- set both 'omf_control' and 'vref' for omf-friendly slices
+
+* Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-58
+- display tags in alphabetic order in node view, tags section, the drop down menu
+
+* Thu Dec 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-57
+- on-the-fly retrieval of data at comon & tophat (unused so far)
+- use accessors to store person's preference of columns
+- fix in toggle.js for the '?' button, node table layout tab
+- sort actions logging improved
+
+* Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-56
+- keep people from disabling or deleting themselves
+- cannot become a disabled person
+- outline people without a role
+
+* Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-55
+- needed for plcapi-5.0-19, i.e. tag permissions based on roles
+
+* Mon Oct 25 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-54
+- tagging plewww for a new deployment
+
+* Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
+- add a 'report a problem' link for the RebootNode button
+- new exp page nodes2.php with consistent selectable-columns layout as myslice
+- tweaks in the exp. myslice (slices.php)
+
+* Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
+- new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
+- my_slice with adjustable set of columns in slices/slice2.php
+- fix for the 'site registration' page
+
+* Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
+- show message about leases - leases tab first in nodes section
+- fix how reservable nodes show up
+
+* Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
+- cosmetic, rendering of textareas was like password fields
+
 * Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
 - bugfix in slice page, had wrong (null) expiration date
 - upgraded to raphael-1.5.2, don't minimize this lib