Setting tag plewww-4.3-53
[plewww.git] / plewww.spec
index d553e5c..7cbe423 100644 (file)
@@ -5,7 +5,7 @@
 # what the myplc rpm requires
 %define name plewww
 %define version 4.3
-%define taglevel 20
+%define taglevel 53
 
 # no need to mention pldistro as this module differs in both distros
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -103,10 +103,12 @@ fi
 popd
 # hack the welcome page for MyPLC
 pushd /var/www/html/modules
-if [ ! -f node.module.drupal ] ; then
-    cp node.module node.module.drupal
-    [ -f /var/www/html/drupal-hacks/node.module ] && cp -f /var/www/html/drupal-hacks/node.module /var/www/html/modules/node.module
-fi
+for module in user node; do
+    # backup only once
+    [ -f ${module}.module.drupal ] || cp ${module}.module ${module}.module.drupal
+    # always update so a change in our file can make through
+    cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
+done
 popd
 
 %clean
@@ -124,6 +126,140 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/plekit
 
 %changelog
+* Fri Oct 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-53
+- add a 'report a problem' link for the RebootNode button
+- new exp page nodes2.php with consistent selectable-columns layout as myslice
+- tweaks in the exp. myslice (slices.php)
+
+* Wed Oct 13 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-52
+- new action reboot-node-with-pcu & reboot button on node page (not sure about the status of that though)
+- my_slice with adjustable set of columns in slices/slice2.php
+- fix for the 'site registration' page
+
+* Mon Sep 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-51
+- show message about leases - leases tab first in nodes section
+- fix how reservable nodes show up
+
+* Mon Sep 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-50
+- cosmetic, rendering of textareas was like password fields
+
+* Fri Sep 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-49
+- bugfix in slice page, had wrong (null) expiration date
+- upgraded to raphael-1.5.2, don't minimize this lib
+- nicer layout for password fields as well
+- long tag values in the slice page (ssh keys..) get truncated, plain value show on hovering
+- marginally optimized slice page (2 GetNodes call down)
+- minimal profiling cap., and usable in the slice page with _GET[profiling]=1
+- _GET[resa_slots] to set number of slots, _GET[resa_offset] to book in the future (in hours)
+- reservations can cope with a bit more slots - will need scrolling someday
+- omf text has hyperlinks to the tools
+
+* Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-48
+- reservation section now effective
+- can set omf_control at slice-creation time
+- can set node as reservable at node-creation time
+- nicer text input fields + various tweaks
+
+* Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-47
+- show nodegroups form to add new groups
+
+* Wed Jun 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plewww-4.3-46
+- just tagging plewww again to test module-tag on git
+
+* Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-45
+- encode strings properly in forms.
+
+* Wed Apr 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - PLEWWW-4.3-44
+- Use readfile() function to reduce the memory footprint
+
+* Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-43
+- removed all deprecated functions for PHP-5.3 on fedora 12
+
+* Tue Mar 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-42
+- * exclude DNS from subnet checking
+- * redirect pi's and techs to register wizard. only display 'Insuffieient privs' error to users'
+- * allow longer abbreviated names
+- * don't let empty strings kill the server (postgresql and apache)
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-41
+- disable drupal user registration (hard: patching the user module)
+
+* Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLEWWW-4.3-40
+- * show error messages for update interface
+- * 'Add Node' is admin only
+- * add site selector for 'Add Node'
+
+* Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-39
+- new add-interface page : now has a checkbox for non-primary interfaces to chose between virtual or physical
+- this affects the settings of ifname and alias that were formerly set unconditionally
+- review the interface-checking javascript code
+- changed the interface to plekitform, method is now optional and part of an options hash
+
+* Tue Nov 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-38
+- can't use php objects for showing node status, this is too slow
+- fix interface add page
+
+* Mon Nov 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-37
+- consistency in the way nodes status is displayed in the node and slice areas
+- extra tags columns show up on the nodes page as well, tweaked in the process
+- roles management in person page fixed
+
+* Sun Nov 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-36
+- displaying node tags in the nodes page as well
+- table headers now can have a 'title' that shows up when hovering on the column header
+
+* Sat Nov 14 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-35
+- bugfix for the custom sortAlphaNumeric{Bottom,Top} sortable types
+
+* Fri Nov 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-34
+- extensible set of columns in the nodes area of the (my)slice page
+- nodegroups can be added/deleted/updated
+- tags management improved marginally
+
+* Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-33
+- fix pending sites page - was getting fooled by ext_consortium_id=None
+
+* Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-32
+- resetting tag as something went wrong when setting 31
+
+* Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-30
+- nicer look for slice creation, (public) sites
+- users show with all their sites in the persons page
+
+* Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-29
+- reviewed registration pages for persons and sites
+
+* Fri Sep 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-28
+- increase memory limit in the nodes page
+
+* Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-27
+- fixes one typo
+
+* Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-26
+- minor/cosmetic
+
+* Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLEWWW-4.3-25
+- Add default Interface tags to extra interfaces.
+- Add clearer 'Add New PCU' link on node page.
+- Disable user registration for tech and PI roles.
+
+* Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-24
+- new 'controller' instantiation state available in add slice page
+
+* Thu Jul 02 2009 Baris Metin <tmetin@sophia.inria.fr> - PLEWWW-4.3-23
+- exclude datepicler.js from jsmin
+- table sort function for Last Contact columns
+- drop options for generic boot images
+
+* Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-22
+- displays editable mac address for interfaces
+- properly sorts bandwidths
+- new 'controller' slice instantiation method
+- bugfix, division by zero when displaying a just-changed node
+
+* Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-21
+- bugfix with linetabs
+
 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLEWWW-4.3-20
 - fix add interface from the node page