bugfix: the slice page was broken when nobody is in slice
[plewww.git] / plewww.spec
index d4b89d1..39e421e 100644 (file)
@@ -1,10 +1,9 @@
 # what the myplc rpm requires
 %define name plewww
-%define version 4.3
-%define taglevel 69
+%define version 5.3
+%define taglevel 0
 
 # no need to mention pldistro as this module differs in both distros
-#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
 Summary: PlanetLab Europe (PLC) Web Pages
@@ -17,6 +16,8 @@ Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
 BuildRequires: python
+# for patching drupal session code
+BuildRequires: ed
 
 Vendor: OneLab
 Packager: OneLab <support@one-lab.org>
@@ -27,7 +28,7 @@ URL: %{SCMURL}
 #Requires: httpd >= 2.0
 Requires: php >= 5.0
 Requires: postgresql >= 8.0
-Requires: PLCAPI >= 4.3
+Requires: plcapi >= 5.2
 Requires: drupal = 4.7
 Requires: plewww-plekit
 
@@ -106,9 +107,14 @@ for module in user node; do
     cp -f /var/www/html/drupal-hacks/${module}.module /var/www/html/modules/${module}.module
 done
 popd
+# hack drupal's session handler for php8
+pushd /var/www/html/includes
+bash /var/www/html/drupal-hacks/patch-session-inc.sh
+popd
 # create myslice.log and change its ownership
-touch /var/log/myslice.log
-chown apache:apache /var/log/myslice.log
+mkdir -p /var/log/myslice
+touch /var/log/myslice/myslice.log
+chown apache:apache /var/log/myslice/myslice.log
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -125,6 +131,65 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/plekit
 
 %changelog
+* Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plewww-5.3-0
+- for php8 on fedora35
+
+* Wed May 16 2018 Thierry <Parmentelat> - plewww-5.2-9
+- not too clean patches for r2lab:
+- * search for a file named /etc/planetlab/php/person-registration.txt
+- that can override the text message for individuals registration
+- * do not list sites that have the disabled_registration tag set
+- when listing them for individuals registration
+- remove omf-friendly checkbox in slice-creation dialog
+- comment out {Min,Max}SpareServers settings in httpd config
+
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-8
+- a few niceties, thanks to Ciro
+
+* Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-7
+- remove utf8_deode as per Thomas's suggestion
+
+* Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-6
+- Offer the option to set a node in 'upgrade' mode - like reinstall but leaving slices intact
+
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-5
+- tweaks in node_downloads.php about memory size and compression scheme
+
+* Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-4
+- googlemap widget: support for gmap api v3 + various cosmetic tweaks
+- can display site names with odd characters
+
+* Tue Jun 04 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-3
+- typo in help message about initscripts
+
+* Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-2
+- node page and person page show hrn in details
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-5.2-1
+- late fix of registration for plcapi-5.1-6
+
+* Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-75
+- add extra code to prevent confidentiality leaks
+- for vicci: $plc->hide_planetlab_block, that should not affect mainstream
+- return_url for add-person and remove-person
+- myslice.log now in /var/log/myslice/ (should have been cleaned up..)
+
+* Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-74
+- add tags section on site and person pages
+
+* Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-73
+- slightly tweak profiling points in slice.php
+
+* Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-72
+- ships with new default images for PLC/PLE from planet-lab.eu
+
+* Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-71
+- no change, just make sync for lxc-hosted tests
+
+* Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-70
+- refactoring for tophat/columns
+- should take care of the irritating warning message about columns
+
 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plewww-4.3-69
 - do not display the 'node' role when confusing