care for floats being passed as a result of erratic / instead of // when migrating...
[plnode-utils.git] / plnode-utils-lxc.spec
index 83e933e..a5fd3f6 100644 (file)
@@ -1,11 +1,10 @@
 %define name plnode-utils
 %define version 0.2
-%define taglevel 1
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
-# for f12
-%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+%define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
 
 Summary: Python utilities for a PlanetLab node
 Name: %{name}
@@ -24,25 +23,27 @@ URL: %{SCMURL}
 Provides: bwlimit
 
 %description
-This python package provides utilities like bwlimit, used in various places on a PlanetLab node, nodemanager and mom among others. It aims at cleaning up the packaging scheme, as bwlimit used to ship with util-vserver-pl, but is relevant in the lxc variant as well.
+This python3 package provides utilities like bwlimit, used in various places on a PlanetLab node, nodemanager and mom among others. It aims at cleaning up the packaging scheme, as bwlimit used to ship with util-vserver-pl, but is relevant in the lxc variant as well.
 
 %prep
 %setup -q
 
 %build
 # xxx fixme
-# this is where we chose which flavour of bwlimit gets shipped
+# this is where we choose which flavour of bwlimit gets shipped
 cp plnode/bwlimit_lxc.py plnode/bwlimit.py
-/usr/bin/python setup.py build
+python3 setup.py build
 
 %install
-/usr/bin/python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
+python3 setup.py install --skip-build --root "$RPM_BUILD_ROOT"
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%{python_sitelib}/*
+%{python3_sitelib}/*
 %{_bindir}/*
 
 %changelog
+* Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - plnode-utils-0.2-2
+- import bwlimit from plnode dir, and keep legacy support.