populate flavors in initial_data.json
[plstackapi.git] / opencloud.spec
index 5b6bed4..066f926 100644 (file)
@@ -1,7 +1,7 @@
 Summary: OpenCloud core services
 Name: opencloud
-Version: 1.0.20
-Release: 1
+Version: 1.0.25
+Release: 6
 License: GPL+
 Group: Development/Tools
 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
@@ -18,6 +18,7 @@ requires: tar
 requires: gcc
 requires: python-httplib2
 requires: GeoIP
+requires: python-keyczar
 
 %description
 %{summary}
@@ -46,6 +47,7 @@ pip-python install django-suit
 pip-python install django-evolution
 pip-python install django-bitfield
 pip-python install django-ipware
+pip-python install django-encrypted-fields
 
 easy_install django_evolution
 easy_install python_gflags
@@ -73,12 +75,26 @@ install -d %{buildroot}/opt/planetstack
 install -d %{buildroot}/etc/init.d
 
 # in builddir
-cp -rp ./planetstack %{buildroot}/opt/.
+
+
+# don't copy symbolic links (they are handled in %post)
+rsync -rptgoD ./planetstack %{buildroot}/opt/.  
 cp observer-initscript %{buildroot}/etc/init.d/plstackobserver
 
 find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
+echo /etc/init.d/plstackobserver >> %{_tmppath}/tmp-filelist
+
+# remove config files from the file list (see %config below)
+cat > %{_tmppath}/config-files << "EOF"
+/opt/planetstack/plstackapi_config
+/opt/planetstack/deployment_auth.py
+EOF
+
+sort %{_tmppath}/tmp-filelist > %{_tmppath}/tmp-filelist.sorted
+sort %{_tmppath}/config-files > %{_tmppath}/config-files.sorted
+comm -13 %{_tmppath}/config-files.sorted %{_tmppath}/tmp-filelist.sorted > %{_tmppath}/tmp-filelist
+
 cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
-echo /etc/init.d/plstackobserver > %{_tmppath}/tmp-filelist
 
 %clean
 rm -rf %{buildroot}
@@ -89,6 +105,9 @@ rm -rf %{buildroot}
 %config /opt/planetstack/deployment_auth.py
 
 %post
+ln -s ec2_observer /opt/planetstack/observer
+ln -s config-opencloud.py /opt/planetstack/syndicate_observer/syndicatelib_config/config.py
+
 if [ "$1" == 1 ] ; then
     echo "NEW INSTALL - initializing database"
     /opt/planetstack/scripts/opencloud initdb