remove Dashboard Views from user admin
[plstackapi.git] / opencloud.spec
index 4d72a55..0bbf9a6 100644 (file)
@@ -1,7 +1,7 @@
 Summary: OpenCloud core services
 Name: opencloud
-Version: 1.0.25
-Release: 8
+Version: 1.0.29
+Release: 3
 License: GPL+
 Group: Development/Tools
 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
@@ -18,6 +18,7 @@ requires: tar
 requires: gcc
 requires: python-httplib2
 requires: GeoIP
+requires: wget
 
 %description
 %{summary}
@@ -29,8 +30,8 @@ requires: GeoIP
 # Empty section.
 
 %pre
-#pip-python install django==1.5
-pip-python install djangorestframework
+pip-python install django==1.7
+pip-python install djangorestframework==2.4.4
 pip-python install markdown  # Markdown support for the browseable API.
 pip-python install pyyaml    # YAML content-type support.
 pip-python install django-filter  # Filtering support
@@ -48,6 +49,12 @@ pip-python install django-bitfield
 pip-python install django-ipware
 pip-python install django-encrypted-fields
 pip-python install python-keyczar
+pip-python install python-keystoneclient
+pip-python install python-novaclient
+pip-python install python-neutronclient 
+pip-python install python-glanceclient
+pip-python install python-ceilometerclient
+
 
 easy_install django_evolution
 easy_install python_gflags
@@ -98,6 +105,7 @@ comm -13 %{_tmppath}/config-files.sorted %{_tmppath}/tmp-filelist.sorted > %{_tm
 
 cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
 
+
 %clean
 rm -rf %{buildroot}
 
@@ -105,6 +113,7 @@ rm -rf %{buildroot}
 %defattr(-,root,root,-)
 %config /opt/planetstack/plstackapi_config
 %config /opt/planetstack/deployment_auth.py
+%config /opt/planetstack/model-deps
 
 %post
 ln -s ec2_observer /opt/planetstack/observer
@@ -119,12 +128,20 @@ if [ "$1" == 1 ] ; then
     echo "NEW INSTALL - initializing database"
     /opt/planetstack/scripts/opencloud initdb
 else
-    echo "UPGRADE - doing evolution"
+    # scripts/opencloud will choose evolve or migrate depending on django version
+    echo "UPGRADE - doing evolution/migration"
     /opt/planetstack/scripts/opencloud evolvedb
-    #echo "UPGRADE - doing migration"    
-    #/opt/planetstack/scripts/opencloud migratedb
 fi
 
+# Clone ansible with latest openstack modules
+git clone --recursive git://github.com/ansible/ansible.git /opt/ansible
+mkdir -p /etc/ansible
+echo > /etc/ansible/hosts << "EOF"
+[localhost]
+127.0.0.1
+EOF
+
+
 # start the server
 /opt/planetstack/scripts/opencloud runserver