remove Dashboard Views from user admin
[plstackapi.git] / opencloud.spec
index 6d79ed5..0bbf9a6 100644 (file)
@@ -1,7 +1,7 @@
 Summary: OpenCloud core services
 Name: opencloud
-Version: 1.0.28
-Release: 2
+Version: 1.0.29
+Release: 3
 License: GPL+
 Group: Development/Tools
 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
@@ -31,7 +31,7 @@ requires: wget
 
 %pre
 pip-python install django==1.7
-pip-python install djangorestframework
+pip-python install djangorestframework==2.4.4
 pip-python install markdown  # Markdown support for the browseable API.
 pip-python install pyyaml    # YAML content-type support.
 pip-python install django-filter  # Filtering support
@@ -53,6 +53,7 @@ pip-python install python-keystoneclient
 pip-python install python-novaclient
 pip-python install python-neutronclient 
 pip-python install python-glanceclient
+pip-python install python-ceilometerclient
 
 
 easy_install django_evolution
@@ -104,13 +105,6 @@ comm -13 %{_tmppath}/config-files.sorted %{_tmppath}/tmp-filelist.sorted > %{_tm
 
 cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
 
-# Clone ansible with latest openstack modules
-git clone --recursive git://github.com/ansible/ansible.git /opt/ansible
-mkdir -p /etc/ansible
-echo > /etc/ansible/hosts << "EOF"
-[localhost]
-127.0.0.1
-EOF
 
 %clean
 rm -rf %{buildroot}
@@ -119,6 +113,7 @@ rm -rf %{buildroot}
 %defattr(-,root,root,-)
 %config /opt/planetstack/plstackapi_config
 %config /opt/planetstack/deployment_auth.py
+%config /opt/planetstack/model-deps
 
 %post
 ln -s ec2_observer /opt/planetstack/observer
@@ -138,6 +133,15 @@ else
     /opt/planetstack/scripts/opencloud evolvedb
 fi
 
+# Clone ansible with latest openstack modules
+git clone --recursive git://github.com/ansible/ansible.git /opt/ansible
+mkdir -p /etc/ansible
+echo > /etc/ansible/hosts << "EOF"
+[localhost]
+127.0.0.1
+EOF
+
+
 # start the server
 /opt/planetstack/scripts/opencloud runserver