bump version number; add install-keys makefile action
[plstackapi.git] / opencloud.spec
index 45bc849..acd9282 100644 (file)
@@ -1,7 +1,7 @@
 Summary: OpenCloud core services
 Name: opencloud
-Version: 1.0.2
-Release: 1
+Version: 1.0.10
+Release: 3
 License: GPL+
 Group: Development/Tools
 Source0: %{_tmppath}/%{name}-%{version}.tar.gz
@@ -17,6 +17,7 @@ requires: python-pip
 requires: tar
 requires: gcc
 requires: python-httplib2
+requires: GeoIP
 
 %description
 %{summary}
@@ -44,6 +45,7 @@ pip-python install django-extensions
 pip-python install django-suit
 pip-python install django-evolution
 pip-python install django-bitfield
+pip-python install django-ipware
 
 easy_install django_evolution
 easy_install python_gflags
@@ -51,13 +53,24 @@ easy_install google_api_python_client
 
 wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
 
+if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
+   rm -f /usr/share/GeoIP/GeoLiteCity.*
+   wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+   gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
+fi
+
+if [ "$1" == 2 ] ; then
+    echo "UPGRADE - saving current state"
+    /opt/planetstack/scripts/opencloud dumpdata
+fi
+
 %install
 rm -rf %{buildroot}
 mkdir -p  %{buildroot}
 install -d %{buildroot}/opt/planetstack
 
 # in builddir
-cp -rp /opt/plstackapi/planetstack %{buildroot}/opt/.
+cp -rp ./planetstack %{buildroot}/opt/.
 
 find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g"  > %{_tmppath}/tmp-filelist
 
@@ -68,10 +81,21 @@ rm -rf %{buildroot}
 %defattr(-,root,root,-)
 
 %post
-/opt/planetstack/scripts/opencloud initdb
+if [ "$1" == 1 ] ; then
+    echo "NEW INSTALL - initializing database"
+    /opt/planetstack/scripts/opencloud initdb
+else
+    echo "UPGRADE - doing evolution"
+    /opt/planetstack/scripts/opencloud evolvedb
+fi
+# start the server
+/opt/planetstack/scripts/opencloud runserver
 
 %preun
-rm -rf /opt/planetstack
+if [ "$1" = 0 ] ; then
+    echo "UNINSTALL - destroying planetstack"
+    rm -rf /opt/planetstack
+fi
 
 %changelog
 * Sat Feb 22 2014  Siobhan Tully  1.0.0