use install -D
[procprotect.git] / procprotect.spec
index ab08480..d026656 100644 (file)
@@ -1,6 +1,6 @@
 %define name procprotect
-%define version 0.3
-%define taglevel 3
+%define version 0.4
+%define taglevel 1
 
 ### legacy from locally-built kernels, used to define these
 # kernel_release : 1.fc16  (24 is then the planetlab taglevel)
@@ -50,8 +50,9 @@ make -C %{kernelpath} V=1 M=$(pwd) modules
 
 %install
 install -D -m 755 procprotect.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/kernel/net/procprotect/procprotect.ko
-mkdir -p $RPM_BUILD_ROOT/etc/modules-load.d
-install -m 644 procprotect.conf $RPM_BUILD_ROOT/etc/modules-load.d/procprotect.conf
+install -D -m 644 procprotect.conf $RPM_BUILD_ROOT/etc/modules-load.d/procprotect.conf
+install -D -m 644 procprotect.service $RPM_BUILD_ROOT/usr/lib/systemd/system/procprotect.service
+install -D -m 755 procprotect.init $RPM_BUILD_ROOT/usr/sbin/procprotect.init
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -59,13 +60,32 @@ rm -rf $RPM_BUILD_ROOT
 %files
 /lib/modules/%{kernel_id}
 /etc/modules-load.d/procprotect.conf
+/usr/sbin/procprotect.init
+/usr/lib/systemd/system/procprotect.service
 
 %post
 /sbin/depmod -a
+/bin/systemctl enable procprotect.service
 
 %postun
 
 %changelog
+* Mon Aug 19 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - procprotect-0.4-1
+- working version with kernels 3.10
+
+* Tue May 21 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - procprotect-0.3-4
+- Compatibility with kernel 3.9
+
+* Wed Apr 24 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - procprotect-0.3-3
+- - Support for arbitrating writes to entries in /proc
+- - Compatibility fixes to support kernel 3.8
+- - Fixed a slippery race condition that may have been responsible an for intermittent kernel crash, and was causing fedora 18 build tests to fail
+
+* Wed Apr 24 2013 Sapan Bhatia <sapanb@cs.princeton.edu> - procprotect-0.3-2
+
+* Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - procprotect-0.3-1
+- changes for kernel 3.6.2
+
 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - procprotect-0.1-3
 - Fixed bad security loophole in write path