The first argument to get_python_lib specifies if the file is platform specific or...
[pyopenssl.git] / pyOpenSSL.spec
index e818fd2..48a9a80 100644 (file)
@@ -32,10 +32,10 @@ High-level wrapper around a subset of the OpenSSL library.
 
 %build
 rm -rf $RPM_BUILD_ROOT
-python setup.py build
+make rpm
 
 %install
-python setup.py install --skip-build --root $RPM_BUILD_ROOT --record=INSTALLED_FILES.tmp
+python setup.py install  --root $RPM_BUILD_ROOT --record=INSTALLED_FILES.tmp
 # Ghost optimized
 sed 's/\(.*\.pyo\)/%ghost \1/' < INSTALLED_FILES.tmp >INSTALLED_FILES
 
@@ -49,7 +49,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f INSTALLED_OBJECTS
 %defattr(-,root,root,-)
-/usr/lib/python2.5/site-packages/OpenSSL
+%(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1),")/OpenSSL
 
 %changelog
 * Wed May 20 2009 Baris Metin <tmetin@sophia.inria.fr>