Both e1000 and e1000e drivers recognize certain devices. Greylisting
[pypcilib.git] / pypcilib.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name pypcilib
7 %define version 0.2
8 %define taglevel 7
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
13 %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
14
15 Summary: Python library for doing PCI stuff
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 License: BSD
20 Group: System Environment/Libraries
21
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 #URL: http://svn.planet-lab.org/wiki/pypcilib
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Source0: pypcilib-%{version}.tar.bz2
28
29 Requires: /sbin/lspci
30
31 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -un)
32
33 %description
34 pypcilib is a Python library to scan PCI devices using
35 libpci from pciutils, and to parse the modules.pcimap file.
36
37
38 %prep
39 %setup -q
40
41
42 %build
43 %{__python} setup.py build
44
45
46 %install
47 rm -fr "%{buildroot}"
48 %{__python} setup.py install -O1 --skip-build --root "%{buildroot}"
49 touch %{buildroot}%{python_sitelib}/pypcimap.py{c,o}
50 touch %{buildroot}%{python_sitelib}/pypci.py{c,o}
51
52
53 %clean
54 rm -fr "%{buildroot}"
55
56
57 %files
58 %defattr(-,root,root,-)
59 %{python_sitelib}/pypcimap.py
60 %ghost %{python_sitelib}/pypcimap.pyc
61 %ghost %{python_sitelib}/pypcimap.pyo
62 %{python_sitelib}/pypci.py
63 %ghost %{python_sitelib}/pypci.pyc
64 %ghost %{python_sitelib}/pypci.pyo
65 # xxx - quick'n dirty
66 %if "%{distroname}" == "f9" || "%{distroname}" == "f10" || "%{distroname}" == "f11"
67 %{python_sitelib}/pypciscan*.egg-info
68 %endif
69
70
71 %changelog
72 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-7
73 - ready for fedora11
74
75 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-6
76 - use 8139too driver over 8139cp for realtek 8139 chipsets
77
78 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-5
79 - support for building on fedora 10
80
81 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-4
82 - somehow the versions in the specfile are wrong in tag 0.2-3
83
84 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pypcilib-0.2-2
85 - fixes for building on f9/gcc-4.3 - no functional change
86
87 * Fri Mar 14 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.2-1
88 - Remove pypciscan library, reimplemented in Python
89
90 * Mon Nov 19 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
91 - initial release