Rename, will have more than just scan.
[pypcilib.git] / pypciscan.spec
1 %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3 Summary: Scan PCI devices from Python
4 Name: pypciscan
5 Version: 0.1
6 Release: 1
7 License: BSD
8 URL: http://svn.planet-lab.org/wiki/pypciscan
9 Group: System Environment/Libraries
10
11 BuildRequires: pciutils-devel
12
13 Source0: pypciscan-%{version}.tar.bz2
14
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -un)
16
17
18 %description
19 pypciscan is a Python library to scan PCI devices using
20 pciutils' libpci.
21
22
23 %prep
24 %setup -q
25
26
27 %build
28 CFLAGS="%{optflags}" %{__python} setup.py build
29
30
31 %install
32 rm -fr "%{buildroot}"
33 %{__python} setup.py install -O1 --skip-build --root "%{buildroot}"
34
35
36 %clean
37 rm -fr "%{buildroot}"
38
39
40 %files
41 %defattr(-,root,root,-)
42 %{python_sitearch}/pypciscan.so
43
44
45 %changelog
46 * Mon Nov 19 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
47 - initial release