6bd7c1662df3b2842d760a77729ea655ffb9b161
[pyplnet.git] / pyplnet.spec
1 %define name pyplnet
2 %define version 4.3
3 %define taglevel 19
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Network Configuration library
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Requires: python3
22 BuildRequires: python3, python3-devel
23 BuildArch: noarch
24
25 %description
26 pyplnet is used to write the network configuration files based on the
27 configuration data recorded at PLC.
28
29 %prep
30 %setup -q
31
32 %build
33 python3 setup.py build
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 python3 setup.py install --skip-build --root "$RPM_BUILD_ROOT"
38 chmod +x $RPM_BUILD_ROOT/%{python3_sitelib}/plnet.py
39 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
40 ln -s %{python3_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(-,root,root,-)
47 %{_bindir}/plnet
48 %{python3_sitelib}/*
49
50 %changelog
51 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-19
52 - always set NM_CONTROLLED=no in ifcfg files
53 - more modern python
54
55 * Fri Aug 09 2013 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-18
56 - IPv6 changes from Thomas Dreibholz
57
58 * Fri Aug 09 2013 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-17
59 - Added tags for configuring OvS interfaces
60
61 * Thu Jan 03 2013 Scott Baker <smbaker@gmail.com> - pyplnet-4.3-16
62 - verify ovs is running before setting up ovs bridge
63
64 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-15
65 - Add support for bridging using Open vSwitch
66
67 * Wed May 02 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-14
68 - Fix stupid bug
69
70 * Mon Apr 30 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-13
71 - Support for VLAN interfaces
72
73 * Thu Apr 26 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-12
74
75 * Sun Sep 25 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-11
76 - turn off verbose/debug messages
77 - pyplnet-4.3-10 was broken because of that
78
79 * Wed Sep 21 2011 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-10
80 - Enable creation of bridged interfaces
81
82 * Tue Feb 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-9
83 - protect shell vars definition in ifcfg files with ""
84 - tweaks in numbering rules
85
86 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-8
87 - no semantic change - just fixed specfile for git URL
88
89 * Thu Dec 09 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - pyplnet-4.3-7
90 - Secondary interface fixes and features.
91
92 * Wed Apr 28 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-6
93 - aliases don't show up in /sys, so use /sbin/ip to get the configured IP addresses instead
94
95 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-5
96 - This is needed for 5.0, as GetSlivers now exposes 'interfaces' and no 'networks' anymore
97 - this code can handle both..
98
99 * Tue Sep 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-4
100 - alias without a mac address: fix runtime error while issuing warning
101
102 * Tue Jun 09 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - pyplnet-4.3-3
103 - this patch addresses mlab and other multi-interface node confgurations where
104 - the generated boot image and network config files are mis-named.
105
106 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-2
107 - handle wireless settings back again
108
109 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-1
110 - fixes for 4.3
111
112 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.3-1
113 - initial release