9334a1df797409e62c68fa6172b98bb04fe64e9d
[pyplnet.git] / pyplnet.spec
1 %define name pyplnet
2 %define version 4.3
3 %define taglevel 17
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Summary: PlanetLab Network Configuration library
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 Requires: python >= 2.4
24 BuildRequires: python, python-devel
25 BuildArch: noarch
26
27 %description
28 pyplnet is used to write the network configuration files based on the
29 configuration data recorded at PLC.
30
31 %prep
32 %setup -q
33
34 %build
35 python setup.py build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
40 chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/plnet.py
41 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
42 ln -s %{python_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(-,root,root,-)
49 %{_bindir}/plnet
50 %{python_sitelib}/*
51
52 %changelog
53 * Fri Aug 09 2013 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-17
54 - Added tags for configuring OvS interfaces
55
56 * Thu Jan 03 2013 Scott Baker <smbaker@gmail.com> - pyplnet-4.3-16
57 - verify ovs is running before setting up ovs bridge
58
59 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-15
60 - Add support for bridging using Open vSwitch
61
62 * Wed May 02 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-14
63 - Fix stupid bug
64
65 * Mon Apr 30 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-13
66 - Support for VLAN interfaces
67
68 * Thu Apr 26 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-12
69
70 * Sun Sep 25 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-11
71 - turn off verbose/debug messages
72 - pyplnet-4.3-10 was broken because of that
73
74 * Wed Sep 21 2011 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-10
75 - Enable creation of bridged interfaces
76
77 * Tue Feb 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-9
78 - protect shell vars definition in ifcfg files with ""
79 - tweaks in numbering rules
80
81 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-8
82 - no semantic change - just fixed specfile for git URL
83
84 * Thu Dec 09 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - pyplnet-4.3-7
85 - Secondary interface fixes and features.
86
87 * Wed Apr 28 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-6
88 - aliases don't show up in /sys, so use /sbin/ip to get the configured IP addresses instead
89
90 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-5
91 - This is needed for 5.0, as GetSlivers now exposes 'interfaces' and no 'networks' anymore
92 - this code can handle both..
93
94 * Tue Sep 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-4
95 - alias without a mac address: fix runtime error while issuing warning
96
97 * Tue Jun 09 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - pyplnet-4.3-3
98 - this patch addresses mlab and other multi-interface node confgurations where
99 - the generated boot image and network config files are mis-named.
100
101 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-2
102 - handle wireless settings back again
103
104 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-1
105 - fixes for 4.3
106
107 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.3-1
108 - initial release