mention /usr/bin/python when invoking setup.py, because otherwise on
[pyplnet.git] / pyplnet.spec
index eb07cec..794e4f7 100644 (file)
@@ -1,11 +1,6 @@
-#
-# $Id$
-#
-%define url $URL$
-
 %define name pyplnet
 %define version 4.3
-%define taglevel 5
+%define taglevel 14.1.openvswitch
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -23,7 +18,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Requires: python >= 2.4
 BuildRequires: python, python-devel
@@ -37,11 +32,11 @@ configuration data recorded at PLC.
 %setup -q
 
 %build
-python setup.py build
+/usr/bin/python setup.py build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
+/usr/bin/python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
 chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/plnet.py
 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
 ln -s %{python_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
@@ -55,6 +50,34 @@ rm -rf $RPM_BUILD_ROOT
 %{python_sitelib}/*
 
 %changelog
+* Wed May 02 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-14
+- Fix stupid bug
+
+* Mon Apr 30 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-13
+- Support for VLAN interfaces
+
+* Thu Apr 26 2012 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-12
+
+* Sun Sep 25 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-11
+- turn off verbose/debug messages
+- pyplnet-4.3-10 was broken because of that
+
+* Wed Sep 21 2011 Andy Bavier <acb@cs.princeton.edu> - pyplnet-4.3-10
+- Enable creation of bridged interfaces
+
+* Tue Feb 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-9
+- protect shell vars definition in ifcfg files with ""
+- tweaks in numbering rules
+
+* Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-8
+- no semantic change - just fixed specfile for git URL
+
+* Thu Dec 09 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - pyplnet-4.3-7
+- Secondary interface fixes and features.
+
+* Wed Apr 28 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-6
+- aliases don't show up in /sys, so use /sbin/ip to get the configured IP addresses instead
+
 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-5
 - This is needed for 5.0, as GetSlivers now exposes 'interfaces' and no 'networks' anymore
 - this code can handle both..