Use source based routing if secondary interfaces specify different gateway.
[pyplnet.git] / pyplnet.spec
index 7d3ed30..ae23da8 100644 (file)
@@ -5,11 +5,11 @@
 
 %define name pyplnet
 %define version 4.3
-%define taglevel 0
+%define taglevel 6
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
-%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
 Summary: PlanetLab Network Configuration library
 Name: %{name}
@@ -27,6 +27,7 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Requires: python >= 2.4
 BuildRequires: python, python-devel
+BuildArch: noarch
 
 %description
 pyplnet is used to write the network configuration files based on the
@@ -41,8 +42,9 @@ python setup.py build
 %install
 rm -rf $RPM_BUILD_ROOT
 python setup.py install --skip-build --root "$RPM_BUILD_ROOT"
-chmod +x %{python_sitearch}/plnet.py
-ln -s %{python_sitearch}/plnet.py %{_bindir}/plnet
+chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/plnet.py
+mkdir -p $RPM_BUILD_ROOT/%{_bindir}
+ln -s %{python_sitelib}/plnet.py $RPM_BUILD_ROOT/%{_bindir}/plnet
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -50,8 +52,28 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(-,root,root,-)
 %{_bindir}/plnet
-%{python_sitearch}/*
+%{python_sitelib}/*
 
 %changelog
+* Wed Apr 28 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-6
+- aliases don't show up in /sys, so use /sbin/ip to get the configured IP addresses instead
+
+* Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-5
+- This is needed for 5.0, as GetSlivers now exposes 'interfaces' and no 'networks' anymore
+- this code can handle both..
+
+* Tue Sep 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-4
+- alias without a mac address: fix runtime error while issuing warning
+
+* Tue Jun 09 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - pyplnet-4.3-3
+- this patch addresses mlab and other multi-interface node confgurations where
+- the generated boot image and network config files are mis-named.
+
+* Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-2
+- handle wireless settings back again
+
+* Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - pyplnet-4.3-1
+- fixes for 4.3
+
 * Tue Dec  2 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - pyplnet-4.3-1
 - initial release