Fixes package dependencies
[rvm-ruby.git] / rpm / rvm-ruby.spec
index 10dc1d0..284109e 100644 (file)
@@ -6,24 +6,23 @@
 
 Name: rvm-ruby
 Summary: Ruby Version Manager
-Version: 3  # Version will be appended the commit date
-Release: 1.20.9
+Version: 4  # Version will be appended the commit date
+# choose a version from https://github.com/wayneeseguin/rvm/tags
+Release: 1.20.10
 License: ASL 2.0
 URL: http://rvm.beginrescueend.com/
 Group: Applications/System
-
-#BuildArch: noarch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
 
 BuildRequires: bash curl git
-BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
+BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 BuildRequires: sed grep tar gzip bzip2 make file
 
 Requires(pre): shadow-utils
 # For rvm
 Requires: bash curl git
 # Basics for building ruby 1.8/1.9
-#Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
+Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 # Used by the scripts
 Requires: sed grep tar gzip bzip2 make file
 
@@ -40,9 +39,6 @@ ensure correct permissions for the shared RVM content.
 RVM is activated for all logins by default. To disable remove
 %{_sysconfdir}/profile.d/rvm.sh and source rvm from each users shell.
 
-%prep
-%setup -q
-
 %build
 
 %install
@@ -54,15 +50,14 @@ for i in `env | grep ^rvm_ | cut -d"=" -f1`; do
 done
 
 # Install everything into one directory
+(
 export rvm_ignore_rvmrc=1 \
   rvm_user_install_flag=0 \
   rvm_path="%{buildroot}%{rvm_dir}" \
-  rvm_bin_path="%{buildroot}%{_bindir}" \
   rvm_man_path="%{buildroot}%{_mandir}" \
   HOME=%{buildroot}
-
 \curl -L https://get.rvm.io | bash -s stable --version %{release}
-  #./install
+)
 
 # So members of the rvm group can write to it
 find %{buildroot}%{rvm_dir} -exec chmod ug+w {} \;
@@ -103,9 +98,6 @@ END_OF_RVMSH
 
 chmod 755 %{buildroot}%{_sysconfdir}/profile.d/rvm.sh
 
-#mv %{buildroot}%{_bindir}/rake %{buildroot}%{_bindir}/rvm-rake
-
-
 # At this point, install of RVM is finished
 # Now install some rubies
 
@@ -114,7 +106,6 @@ chmod 755 %{buildroot}%{_sysconfdir}/profile.d/rvm.sh
 export rvm_ignore_rvmrc=1
 export rvm_user_install_flag=0
 export rvm_path="%{buildroot}%{rvm_dir}"
-export rvm_bin_path="%{buildroot}%{_bindir}"
 export rvm_man_path="%{buildroot}%{_mandir}"
 source ${rvm_path}/scripts/rvm
 gemi='gem install --no-ri --no-rdoc'
@@ -123,17 +114,21 @@ gemi='gem install --no-ri --no-rdoc'
 ruby_tag=ruby-1.9.3-p286
 rvm install $ruby_tag
 rvm use $ruby_tag
-#$gemi bundler
+$gemi bundler
+#$gemi whatever_gem_you_need
 
 #ruby_tag=ruby-1.8.7-p352
 #rvm install $ruby_tag
 #rvm use $ruby_tag
+rvm cleanup all
 )
 
 export br=%{buildroot}
 
 # Remove sources
-rm -rf $br/usr/lib/rvm/src
+rm -rf $br/usr/lib/rvm/src/*
+# Remove logfiles
+find $br/usr/lib/rvm/log -type f -exec rm {} \;
 
 # Strip binaries
 #find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep 'not stripped' |cut -f1 -d: |xargs -r strip
@@ -152,40 +147,11 @@ done
 find $br -type f \( -name \*.log -o -name \*.la \) -print0 |xargs -0 -r sed -i "s,$br,,g"
 find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': .* text' |cut -f1 -d: |xargs -r sed -i "s,$br,,g"
 
-# Strip object files in ar archives from bad path strings
-for f in `find $br -type f -name \*.a`; do
-  td=`mktemp -d`
-  pushd $td
-  ar x $f
-
-  for g in `find . -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': ELF' |cut -f1 -d:`; do
-    strip $g
-    grep "$br" $g || continue
-
-    # Replace the bad path with the good one, padded by nulls
-    ruby -p -i -e '
-      $_.encode!("UTF-8", "UTF-8", :invalid => :replace).gsub!(/#{ENV["br"]}(.*?)\0/) do |s|
-      $1 + ( "\0" * ENV["br"].size ) + "\0"
-      end
-    ' $g
-  done
-
-  ar r $f *
-  popd
-  rm -rf $td
-done
-
-# Replace paths in libraries strings
-for f in `find $br/usr/lib/rvm/rubies -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': ELF' |cut -f1 -d:`; do
-  grep "$br" $f || continue
-
-  # Replace the bad path with the good one, padded by nulls
-  ruby -p -i -e '
-    $_.encode!("UTF-8", "UTF-8", :invalid => :replace).gsub!(/#{ENV["br"]}(.*?)\0/) do |s|
-    $1 + ( "\0" * ENV["br"].size ) + "\0"
-    end
-  ' $f
-done
+# Replace bad paths in all remaining files
+# Padding with zeroes broke the LOAD_PATH in libruby, therefore prepend path with harmless forward slashes
+printf -vch "%${#br}s" ""
+slashes=$(printf "%s" "${ch// //}")
+find $br -type f -print0 | xargs -0 sed -i "s,$br,$slashes,g"
 
 # Fix symlinks with bad path
 for f in `find $br -type l |grep "$br"`; do
@@ -193,6 +159,7 @@ for f in `find $br -type l |grep "$br"`; do
 done
 
 find $br -maxdepth 1 -name '.*' -exec rm -rf {} \;
+rm $br/usr/share/man/man1/rvm.1.gz
 
 %clean
 rm -rf %{buildroot}
@@ -206,10 +173,15 @@ exit 0
 %config(noreplace) /etc/rvmrc
 %config(noreplace) /etc/profile.d/rvm.sh
 %attr(-,root,%{rvm_group}) %{rvm_dir}
-%{_bindir}/*
 %{_mandir}/man1/*
 
 %changelog
+* Fri May 18 2013 Christoph Dwertmann - 4.xxx
+- downloads RVM instead of relying on local sources
+- works with latest RVM and Fedora
+- removed ruby build dependency
+- no more clashing with distribution ruby
+
 * Fri Mar 30 2012 Alexandre Fouche - 3.xxx
 Add some rubies and gems to compile:
 - 1.9.2-p290 + bundler, bluepill, whenever