Fixes package dependencies
[rvm-ruby.git] / rpm / rvm-ruby.spec
index d4417f2..284109e 100644 (file)
@@ -7,23 +7,22 @@
 Name: rvm-ruby
 Summary: Ruby Version Manager
 Version: 4  # Version will be appended the commit date
-Release: 1.20.9
+# choose a version from https://github.com/wayneeseguin/rvm/tags
+Release: 1.20.10
 License: ASL 2.0
 URL: http://rvm.beginrescueend.com/
 Group: Applications/System
-#Source: %{name}-%{version}.tar
-#BuildArch: noarch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
 
 BuildRequires: bash curl git
-BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
+BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 BuildRequires: sed grep tar gzip bzip2 make file
 
 Requires(pre): shadow-utils
 # For rvm
 Requires: bash curl git
 # Basics for building ruby 1.8/1.9
-#Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
+Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 # Used by the scripts
 Requires: sed grep tar gzip bzip2 make file
 
@@ -99,9 +98,6 @@ END_OF_RVMSH
 
 chmod 755 %{buildroot}%{_sysconfdir}/profile.d/rvm.sh
 
-#mv %{buildroot}%{_bindir}/rake %{buildroot}%{_bindir}/rvm-rake
-
-
 # At this point, install of RVM is finished
 # Now install some rubies
 
@@ -124,6 +120,7 @@ $gemi bundler
 #ruby_tag=ruby-1.8.7-p352
 #rvm install $ruby_tag
 #rvm use $ruby_tag
+rvm cleanup all
 )
 
 export br=%{buildroot}
@@ -150,74 +147,11 @@ done
 find $br -type f \( -name \*.log -o -name \*.la \) -print0 |xargs -0 -r sed -i "s,$br,,g"
 find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': .* text' |cut -f1 -d: |xargs -r sed -i "s,$br,,g"
 
-# courtesy http://everydaywithlinux.blogspot.com.au/2012/11/patch-strings-in-binary-files-with-sed.html
-function patch_strings_in_file() {
-    local FILE="$1"
-    local PATTERN="$2"
-    local REPLACEMENT="$3"
-
-    # Find all unique strings in FILE that contain the pattern 
-    STRINGS=$(strings ${FILE} | grep ${PATTERN} | sort -u -r)
-
-    if [ "${STRINGS}" != "" ] ; then
-        echo "File '${FILE}' contain strings with '${PATTERN}' in them:"
-
-        for OLD_STRING in ${STRINGS} ; do
-            # Create the new string with a simple bash-replacement
-            NEW_STRING=${OLD_STRING//${PATTERN}/${REPLACEMENT}}
-
-            # Create null terminated ASCII HEX representations of the strings
-            OLD_STRING_HEX="$(echo -n ${OLD_STRING} | xxd -g 0 -u -ps -c 256)00"
-            NEW_STRING_HEX="$(echo -n ${NEW_STRING} | xxd -g 0 -u -ps -c 256)00"
-
-            if [ ${#NEW_STRING_HEX} -le ${#OLD_STRING_HEX} ] ; then
-                # Pad the replacement string with null terminations so the
-                # length matches the original string
-                while [ ${#NEW_STRING_HEX} -lt ${#OLD_STRING_HEX} ] ; do
-                    NEW_STRING_HEX="${NEW_STRING_HEX}00"
-                done
-
-                # Now, replace every occurrence of OLD_STRING with NEW_STRING 
-                echo -n "Replacing ${OLD_STRING} with ${NEW_STRING}... "
-                hexdump -ve '1/1 "%.2X"' ${FILE} | \
-                sed "s/${OLD_STRING_HEX}/${NEW_STRING_HEX}/g" | \
-                xxd -r -p > ${FILE}.tmp
-                mv ${FILE}.tmp ${FILE}
-                echo "Done!"
-            else
-                echo "New string '${NEW_STRING}' is longer than old" \
-                     "string '${OLD_STRING}'. Skipping."
-            fi
-        done
-    fi
-}
-
-# Strip object files in ar archives from bad path strings
-for f in `find $br -type f -name \*.a`; do
-  td=`mktemp -d`
-  pushd $td
-  ar x $f
-
-  for g in `find . -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': ELF' |cut -f1 -d:`; do
-    strip $g
-    grep "$br" $g || continue
-
-    # Replace the bad path with the good one, padded by nulls
-    patch_strings_in_file $g "$br"
-  done
-
-  ar r $f *
-  popd
-  rm -rf $td
-done
-
-# Replace paths in libraries strings
-for f in `find $br/usr/lib/rvm/rubies -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': ELF' |cut -f1 -d:`; do
-  grep "$br" $f || continue
-
-  # Replace the bad path with the good one, padded by nulls
-  patch_strings_in_file $f "$br" 
-done
+# Replace bad paths in all remaining files
+# Padding with zeroes broke the LOAD_PATH in libruby, therefore prepend path with harmless forward slashes
+printf -vch "%${#br}s" ""
+slashes=$(printf "%s" "${ch// //}")
+find $br -type f -print0 | xargs -0 sed -i "s,$br,$slashes,g"
 
 # Fix symlinks with bad path
 for f in `find $br -type l |grep "$br"`; do