we have swapped release and version, so this is required
[rvm-ruby.git] / rpm / rvm-ruby.spec
index 43f2f59..3050fb7 100644 (file)
@@ -4,11 +4,17 @@
 # RVM can not be sourced with default /bin/sh
 %define _buildshell /bin/bash
 
-Name: rvm-ruby
-Summary: Ruby Version Manager (including Rubies and Gems)
-Version: 4  # Commit date will be appended
+# PL conventions
+%define name rvm-ruby
 # pick a RVM version from https://github.com/wayneeseguin/rvm/tags
-Release: 1.20.10
+%define version 1.20.10
+%define taglevel 4
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
+Summary: Ruby Version Manager (including Rubies and Gems)
+Name: %{name}
+Version: %{version}
+Release: %{release}
 License: ASL 2.0
 URL: http://rvm.io/
 Group: Applications/System
@@ -54,7 +60,7 @@ export rvm_ignore_rvmrc=1 \
   rvm_path="%{buildroot}%{rvm_dir}" \
   rvm_man_path="%{buildroot}%{_mandir}" \
   HOME=%{buildroot}
-\curl -L https://get.rvm.io | bash -s stable --version %{release}
+\curl -L https://get.rvm.io | bash -s stable --version %{version}
 )
 
 # So members of the rvm group can write to it