rough cleanup of the /etc/ area - should be kept pl-specific
[rvm-ruby.git] / rpm / rvm-ruby.spec
index 3050fb7..63189a7 100644 (file)
@@ -153,7 +153,7 @@ find $br -type f -print0 | xargs -0 sed -i "s,$br,$slashes,g"
 
 # Fix symlinks with bad path
 for f in $(find $br -type l |grep "$br"); do
-    ln -sfn $(readlink -f $f |sed "s,$br,,") $f
+    ln -sfn $(echo $f | sed "s,^$br,,") $f
 done
 
 find $br -maxdepth 1 -name '.*' -exec rm -rf {} \;
@@ -161,6 +161,9 @@ rm $br/usr/share/man/man1/rvm.1.gz
 
 %clean
 rm -rf %{buildroot}
+# it appears that, because we build as root, rvm installs stuff in /etc on the build box
+# which is not desirable, so let us get rid of that - don't worry if that fails
+find /etc -name 'rvm*' | xargs rm || :
 
 %pre
 getent group %{rvm_group} >/dev/null || groupadd -r %{rvm_group}