Documentation cleanups
[rvm-ruby.git] / rpm / rvm-ruby.spec
index 6db60eb..648cb53 100644 (file)
@@ -6,29 +6,28 @@
 
 Name: rvm-ruby
 Summary: Ruby Version Manager
-Version: 4  # Version will be appended the commit date
-Release: 1.20.9
+Version: 4  # Commit date will be appended
+# pick a RVM version from https://github.com/wayneeseguin/rvm/tags
+Release: 1.20.10
 License: ASL 2.0
-URL: http://rvm.beginrescueend.com/
+URL: http://rvm.io/
 Group: Applications/System
-#Source: %{name}-%{version}.tar
-#BuildArch: noarch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
 
 BuildRequires: bash curl git
-BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
+BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 BuildRequires: sed grep tar gzip bzip2 make file
 
 Requires(pre): shadow-utils
 # For rvm
 Requires: bash curl git
 # Basics for building ruby 1.8/1.9
-#Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
+Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 # Used by the scripts
 Requires: sed grep tar gzip bzip2 make file
 
 %description
-RVM is the Ruby Version Manager (rvm). It manages Ruby interpreter environments
+RVM is the Ruby Version Manager. It manages Ruby interpreter environments
 and switching between them.
 
 This package is meant for use by multiple users maintaining a shared copy of
@@ -40,8 +39,6 @@ ensure correct permissions for the shared RVM content.
 RVM is activated for all logins by default. To disable remove
 %{_sysconfdir}/profile.d/rvm.sh and source rvm from each users shell.
 
-%build
-
 %install
 rm -rf %{buildroot}
 
@@ -99,9 +96,6 @@ END_OF_RVMSH
 
 chmod 755 %{buildroot}%{_sysconfdir}/profile.d/rvm.sh
 
-#mv %{buildroot}%{_bindir}/rake %{buildroot}%{_bindir}/rvm-rake
-
-
 # At this point, install of RVM is finished
 # Now install some rubies
 
@@ -114,7 +108,6 @@ export rvm_man_path="%{buildroot}%{_mandir}"
 source ${rvm_path}/scripts/rvm
 gemi='gem install --no-ri --no-rdoc'
 
-#touch $rvm_path/RELEASE
 ruby_tag=ruby-1.9.3-p286
 rvm install $ruby_tag
 rvm use $ruby_tag
@@ -129,11 +122,6 @@ rvm cleanup all
 
 export br=%{buildroot}
 
-# Remove sources
-rm -rf $br/usr/lib/rvm/src/*
-# Remove logfiles
-find $br/usr/lib/rvm/log -type f -exec rm {} \;
-
 # Strip binaries
 #find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep 'not stripped' |cut -f1 -d: |xargs -r strip
 
@@ -152,7 +140,7 @@ find $br -type f \( -name \*.log -o -name \*.la \) -print0 |xargs -0 -r sed -i "
 find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': .* text' |cut -f1 -d: |xargs -r sed -i "s,$br,,g"
 
 # Replace bad paths in all remaining files
-# Padding with zeroes broke the LOAD_PATH in libruby, therefore prepend path with harmless slashes
+# Padding with zeroes broke the LOAD_PATH in libruby, therefore prepend path with harmless forward slashes
 printf -vch "%${#br}s" ""
 slashes=$(printf "%s" "${ch// //}")
 find $br -type f -print0 | xargs -0 sed -i "s,$br,$slashes,g"