reset taglevel
[rvm-ruby.git] / rpm / rvm-ruby.spec
index 6a40fba..9a2953e 100644 (file)
@@ -7,8 +7,8 @@
 # PL conventions
 %define name rvm-ruby
 # pick a RVM version from https://github.com/wayneeseguin/rvm/tags
-%define version 1.20.10
-%define taglevel 4
+%define version 1.22.9
+%define taglevel 0
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: Ruby Version Manager (including Rubies and Gems)
@@ -23,14 +23,19 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
 BuildRequires: bash curl git
 BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 BuildRequires: sed grep tar gzip bzip2 make file
+# for OMF:
+BuildRequires: tar libxml2 libxml2-devel libxslt libxslt-devel
 
 Requires(pre): shadow-utils
 # For rvm
 Requires: bash curl git
 # Basics for building ruby 1.8/1.9
-Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
+# We expect all the building to take place .. at build-time, so let's take this out
+#Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 # Used by the scripts
 Requires: sed grep tar gzip bzip2 make file
+# for OMF:
+Requires: libxml2 libxslt
 
 %description
 RVM is the Ruby Version Manager. It manages Ruby interpreter environments
@@ -115,9 +120,11 @@ source ${rvm_path}/scripts/rvm
 gemi='gem install --no-ri --no-rdoc'
 
 ruby_tag=ruby-1.9.3-p286
-rvm install $ruby_tag
+rvm install $ruby_tag --verify-downloads 1
 rvm use $ruby_tag
-$gemi bundler
+rvm gemset create omf
+rvm use $ruby_tag@omf --default
+$gemi omf_rc
 #$gemi whatever_gem_you_need
 
 #ruby_tag=ruby-1.8.7-p352
@@ -166,7 +173,7 @@ for f in $(find $br -type l); do
        # call readlink with -f so all symlinmks are solved
        # and so we can reliably substitute $brc that is also canonicalized
        destc=$(readlink -f $f | sed -e "s,^$brc,,")
-       ls -sfn $destc $f
+       ln -sfn $destc $f
     fi
 done
 
@@ -191,6 +198,14 @@ exit 0
 %{_mandir}/man1/*
 
 %changelog
+* Sun Jul 14 2013 Thierry Parmentelat - rvm-ruby-1.20.10-8
+- create an omf gemset (in rvm-ruby-1.20.10-7)
+- make omf the default gemset
+- add libxml2 and lixslt dependencies for omf
+
+* Tue Jun 25 2013 Thierry Parmentelat - rvm-ruby-1.20.10-6
+- add omf-rc in the mix
+
 * Fri May 18 2013 Christoph Dwertmann - 4.xxx
 - downloads RVM instead of relying on local sources
 - works with latest RVM and Fedora