reset taglevel
[rvm-ruby.git] / rpm / rvm-ruby.spec
index ec5c5e8..9a2953e 100644 (file)
@@ -4,31 +4,41 @@
 # RVM can not be sourced with default /bin/sh
 %define _buildshell /bin/bash
 
-Name: rvm-ruby
-Summary: Ruby Version Manager
-Version: 4  # Version will be appended the commit date
-Release: 1.20.9
+# PL conventions
+%define name rvm-ruby
+# pick a RVM version from https://github.com/wayneeseguin/rvm/tags
+%define version 1.22.9
+%define taglevel 0
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
+Summary: Ruby Version Manager (including Rubies and Gems)
+Name: %{name}
+Version: %{version}
+Release: %{release}
 License: ASL 2.0
-URL: http://rvm.beginrescueend.com/
+URL: http://rvm.io/
 Group: Applications/System
-#Source: %{name}-%{version}.tar
-#BuildArch: noarch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
 
 BuildRequires: bash curl git
-BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
+BuildRequires: gcc-c++ patch chrpath readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 BuildRequires: sed grep tar gzip bzip2 make file
+# for OMF:
+BuildRequires: tar libxml2 libxml2-devel libxslt libxslt-devel
 
 Requires(pre): shadow-utils
 # For rvm
 Requires: bash curl git
 # Basics for building ruby 1.8/1.9
-#Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel
+# We expect all the building to take place .. at build-time, so let's take this out
+#Requires: gcc-c++ patch readline readline-devel zlib-devel libyaml-devel libffi-devel openssl-devel autoconf automake libtool bison
 # Used by the scripts
 Requires: sed grep tar gzip bzip2 make file
+# for OMF:
+Requires: libxml2 libxslt
 
 %description
-RVM is the Ruby Version Manager (rvm). It manages Ruby interpreter environments
+RVM is the Ruby Version Manager. It manages Ruby interpreter environments
 and switching between them.
 
 This package is meant for use by multiple users maintaining a shared copy of
@@ -40,13 +50,11 @@ ensure correct permissions for the shared RVM content.
 RVM is activated for all logins by default. To disable remove
 %{_sysconfdir}/profile.d/rvm.sh and source rvm from each users shell.
 
-%build
-
 %install
 rm -rf %{buildroot}
 
 # Clean the env
-for i in `env | grep ^rvm_ | cut -d"=" -f1`; do
+for i in $(env | grep ^rvm_ | cut -d"=" -f1); do
   unset $i;
 done
 
@@ -57,7 +65,7 @@ export rvm_ignore_rvmrc=1 \
   rvm_path="%{buildroot}%{rvm_dir}" \
   rvm_man_path="%{buildroot}%{_mandir}" \
   HOME=%{buildroot}
-\curl -L https://get.rvm.io | bash -s stable --version %{release}
+\curl -L https://get.rvm.io | bash -s stable --version %{version}
 )
 
 # So members of the rvm group can write to it
@@ -99,9 +107,6 @@ END_OF_RVMSH
 
 chmod 755 %{buildroot}%{_sysconfdir}/profile.d/rvm.sh
 
-#mv %{buildroot}%{_bindir}/rake %{buildroot}%{_bindir}/rvm-rake
-
-
 # At this point, install of RVM is finished
 # Now install some rubies
 
@@ -114,114 +119,62 @@ export rvm_man_path="%{buildroot}%{_mandir}"
 source ${rvm_path}/scripts/rvm
 gemi='gem install --no-ri --no-rdoc'
 
-#touch $rvm_path/RELEASE
 ruby_tag=ruby-1.9.3-p286
-rvm install $ruby_tag
+rvm install $ruby_tag --verify-downloads 1
 rvm use $ruby_tag
-$gemi bundler
+rvm gemset create omf
+rvm use $ruby_tag@omf --default
+$gemi omf_rc
 #$gemi whatever_gem_you_need
 
 #ruby_tag=ruby-1.8.7-p352
 #rvm install $ruby_tag
 #rvm use $ruby_tag
+rvm cleanup all
 )
 
 export br=%{buildroot}
 
-# Remove sources
-rm -rf $br/usr/lib/rvm/src/*
-# Remove logs
-rm -rf $br/usr/lib/rvm/log/*
-
 # Strip binaries
 #find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep 'not stripped' |cut -f1 -d: |xargs -r strip
 
 # Strip and Fix bad paths in generated files
 # That is not optimized, but that is not supposed to be done often
-for f in `find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': ELF' |cut -f1 -d:`; do
+for f in $(find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': ELF' |cut -f1 -d:); do
   strip $f
   grep "$br" $f || continue
-  line=`chrpath -l $f` || continue
+  line=$(chrpath -l $f) || continue
   echo $line |grep "$br" || continue
-  chrpath -r `echo $line |cut -f2 -d= |sed "s,$br,,"` $f
+  chrpath -r $(echo $line |cut -f2 -d= |sed "s,$br,,") $f
 done
 
 # Replace bad paths in text files
 find $br -type f \( -name \*.log -o -name \*.la \) -print0 |xargs -0 -r sed -i "s,$br,,g"
 find $br -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': .* text' |cut -f1 -d: |xargs -r sed -i "s,$br,,g"
 
-# courtesy http://everydaywithlinux.blogspot.com.au/2012/11/patch-strings-in-binary-files-with-sed.html
-function patch_strings_in_file() {
-    local FILE="$1"
-    local PATTERN="$2"
-    local REPLACEMENT="$3"
-
-    # Find all unique strings in FILE that contain the pattern 
-    STRINGS=$(strings ${FILE} | grep ${PATTERN} | sort -u -r)
-
-    if [ "${STRINGS}" != "" ] ; then
-        echo "File '${FILE}' contain strings with '${PATTERN}' in them:"
-
-        for OLD_STRING in ${STRINGS} ; do
-            # Create the new string with a simple bash-replacement
-            NEW_STRING=${OLD_STRING//${PATTERN}/${REPLACEMENT}}
-
-            # Create null terminated ASCII HEX representations of the strings
-            OLD_STRING_HEX="$(echo -n ${OLD_STRING} | xxd -g 0 -u -ps -c 256)00"
-            NEW_STRING_HEX="$(echo -n ${NEW_STRING} | xxd -g 0 -u -ps -c 256)00"
-
-            if [ ${#NEW_STRING_HEX} -le ${#OLD_STRING_HEX} ] ; then
-                # Pad the replacement string with null terminations so the
-                # length matches the original string
-                while [ ${#NEW_STRING_HEX} -lt ${#OLD_STRING_HEX} ] ; do
-                    NEW_STRING_HEX="${NEW_STRING_HEX}00"
-                done
-
-                # Now, replace every occurrence of OLD_STRING with NEW_STRING 
-                echo -n "Replacing ${OLD_STRING} with ${NEW_STRING}... "
-                hexdump -ve '1/1 "%.2X"' ${FILE} | \
-                sed "s/${OLD_STRING_HEX}/${NEW_STRING_HEX}/g" | \
-                xxd -r -p > ${FILE}.tmp
-                mv ${FILE}.tmp ${FILE}
-                echo "Done!"
-            else
-                echo "New string '${NEW_STRING}' is longer than old" \
-                     "string '${OLD_STRING}'. Skipping."
-            fi
-        done
-    fi
-}
-
-# Strip object files in ar archives from bad path strings
-for f in `find $br -type f -name \*.a`; do
-  td=`mktemp -d`
-  pushd $td
-  ar x $f
-
-  for g in `find . -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': ELF' |cut -f1 -d:`; do
-    strip $g
-    grep "$br" $g || continue
-
-    # Replace the bad path with the good one, padded by nulls
-    patch_strings_in_file $g "$br"
-  done
-
-  ar r $f *
-  popd
-  rm -rf $td
-done
-
-# Replace paths in libraries strings
-for f in `find $br/usr/lib/rvm/rubies -type f -print0 |xargs -0 file --no-dereference --no-pad |grep ': ELF' |cut -f1 -d:`; do
-  grep "$br" $f || continue
-
-  # Replace the bad path with the good one, padded by nulls
-  patch_strings_in_file $f "$br" 
-done
+# Replace bad paths in all remaining files
+# Padding with zeroes broke the LOAD_PATH in libruby, therefore prepend path with harmless forward slashes
+printf -vch "%${#br}s" ""
+slashes=$(printf "%s" "${ch// //}")
+find $br -type f -print0 | xargs -0 sed -i "s,$br,$slashes,g"
 
 # Fix symlinks with bad path
-for f in `find $br -type l |grep "$br"`; do
-    ln -sfn `readlink -f $f |sed "s,$br,,"` $f
+# the canonical path of the build root
+brc=$(readlink -f $br)
+for f in $(find $br -type l); do
+    # some symlinks are relative, in which case we want to preserve them
+    # do *not* mention -f here as it would always return an absolute path
+    dest=$(readlink $f)
+    # relative symlinks have $dest not starting with a /
+    first_step=$(echo $dest | cut -d / -f1)
+    # absolute paths have a void first_step 
+    if [ -z "$first_step" ] ; then
+       # destination is an absolute path, let's fix it
+       # call readlink with -f so all symlinmks are solved
+       # and so we can reliably substitute $brc that is also canonicalized
+       destc=$(readlink -f $f | sed -e "s,^$brc,,")
+       ln -sfn $destc $f
+    fi
 done
 
 find $br -maxdepth 1 -name '.*' -exec rm -rf {} \;
@@ -229,6 +182,9 @@ rm $br/usr/share/man/man1/rvm.1.gz
 
 %clean
 rm -rf %{buildroot}
+# it appears that, because we build as root, rvm installs stuff in /etc on the build box
+# which is not desirable, so let us get rid of that - don't worry if that fails
+find /etc -name 'rvm*' | xargs rm || :
 
 %pre
 getent group %{rvm_group} >/dev/null || groupadd -r %{rvm_group}
@@ -242,6 +198,14 @@ exit 0
 %{_mandir}/man1/*
 
 %changelog
+* Sun Jul 14 2013 Thierry Parmentelat - rvm-ruby-1.20.10-8
+- create an omf gemset (in rvm-ruby-1.20.10-7)
+- make omf the default gemset
+- add libxml2 and lixslt dependencies for omf
+
+* Tue Jun 25 2013 Thierry Parmentelat - rvm-ruby-1.20.10-6
+- add omf-rc in the mix
+
 * Fri May 18 2013 Christoph Dwertmann - 4.xxx
 - downloads RVM instead of relying on local sources
 - works with latest RVM and Fedora