dce6870e6b6abd08ed3ed80adbecc43eedc4e690
[sfa.git] / geniwrapper.spec
1
2 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
3
4 %define name geniwrapper
5 %define version 0.8
6 %define taglevel 0
7
8 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
9 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
10 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
11
12 Name: %{name}
13 Version: %{version}
14 Release: %{release}
15 Source0: %{name}-%{version}.tar.bz2
16 License: GPL
17 Group: Applications/System
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
19
20 Vendor: PlanetLab
21 Packager: PlanetLab Central <support@planet-lab.org>
22 Distribution: PlanetLab %{plrelease}
23 URL: %(echo %{url} | cut -d ' ' -f 2)
24
25 BuildRequires: make
26 Requires: python
27 Requires: pyOpenSSL >= 0.7
28 Requires: m2crypto
29
30 Summary: the GENI layer around MyPLC
31 Group: Applications/System
32
33 %package sfi 
34 Summary: the GENI layer around MyPLC - client side
35 Group: Applications/System
36
37 %description 
38 Geniwrapper implements the Geni interface which serves as a layer
39 between the existing PlanetLab interfaces and the Geni API.
40
41 %description sfi
42 This package provides the client side of the Geni API, in particular
43 sfi.py, together with less important utilities.
44
45 %prep
46 %setup -q
47
48 %build
49 make
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 make install DESTDIR="$RPM_BUILD_ROOT"
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files 
59 %defattr(-,root,root)
60 %config (noreplace) /etc/geni/geni_config
61 %config (noreplace) /etc/geni/aggregates.xml
62 %config (noreplace) /etc/geni/registries.xml
63 /usr/share/keyconvert/
64 /etc/init.d/geni
65 %{_bindir}/geni-config-tty
66 %{_bindir}/gimport.py*
67 %{_bindir}/plc.py*
68 %{python_sitelib}/*
69
70 %files sfi
71 %config (noreplace) /etc/geni/sfi_config
72 %{_bindir}/sfi.py
73 %{_bindir}/getNodes.py*
74 %{_bindir}/getRecord.py*
75 %{_bindir}/setRecord.py*
76 %{_bindir}/genidump.py*
77
78 %post
79 chkconfig --add geni
80
81 %changelog
82 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
83 - snapshot for reproducible builds
84
85 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
86 - snapshot for the convenience of alpha users
87
88 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
89 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
90
91 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
92 - ongoing work - snapshot for 4.3-rc9
93
94 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
95 - various fixes
96
97 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
98 - bugfixes - still a work in progress
99
100 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
101 - initial package
102
103
104 %define module_current_branch 0.2