0ec32797463394ffbf4e40fdf414357387a747bd
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 Summary: the SFA python libraries
23 Group: Applications/System
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # for uuidgen - used in db password generation
31 # on f8 this actually comes with e2fsprogs, go figure
32 Requires: util-linux-ng
33 # xmlbuilder depends on  lxml
34 Requires: python-lxml
35 Requires: python-setuptools
36 Requires: python-dateutil
37 # for the registry
38 Requires: postgresql >= 8.2, postgresql-server >= 8.2
39 Requires: postgresql-python
40 Requires: python-psycopg2
41 Requires: pyOpenSSL >= 0.7
42 Requires: myplc-config
43  
44 # python 2.5 has uuid module added, for python 2.4 we still need it.
45 # we can't really check for if we can load uuid as a python module,
46 # it'll be installed by "devel.pkgs". we have the epel repository so
47 # python-uuid will be provided. but we can test for the python
48 # version.
49 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
50 # %if %has_py24
51 #
52 # this also didn't work very well. I'll just check for distroname - baris
53 #%if %{distroname} == "centos5"
54 #Requires: python-uuid
55 #%endif
56
57 %package plc
58 Summary: the SFA layer around MyPLC
59 Group: Applications/System
60 Requires: sfa
61 Requires: python-psycopg2
62
63 %package client
64 Summary: the SFA experimenter-side CLI
65 Group: Applications/System
66 Requires: sfa
67 Requires: pyOpenSSL >= 0.7
68
69 %package sfatables
70 Summary: sfatables policy tool for SFA
71 Group: Applications/System
72 Requires: sfa
73
74 %package cm
75 Summary: the SFA layer around MyPLC NodeManager
76 Group: Applications/System
77 Requires: sfa
78 Requires: pyOpenSSL >= 0.6
79
80 %package flashpolicy
81 Summary: SFA support for flash clients
82 Group: Applications/System
83 Requires: sfa
84
85 %package tests
86 Summary: unit tests suite for SFA
87 Group: Applications/System
88 Requires: sfa
89
90 %description
91 This package provides the python libraries for the PlanetLab implementation of SFA
92
93 %description plc
94 This package implements the SFA interface which serves as a layer
95 between the existing PlanetLab interfaces and the SFA API.
96
97 %description client
98 This package provides the client side of the SFA API, in particular
99 sfi.py, together with other utilities.
100
101 %description sfatables
102 sfatables is a tool for defining access and admission control policies
103 in an SFA network, in much the same way as iptables is for ip
104 networks. This is the command line interface to manage sfatables
105
106 %description cm
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab NodeManager interfaces and the SFA API.
109  
110 %description flashpolicy
111 This package provides support for adobe flash client applications.  
112  
113 %description tests
114 Provides some binary unit tests in /usr/share/sfa/tests
115
116 %prep
117 %setup -q
118
119 %build
120 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
125 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/*egg-info
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 # sfa and sfatables depend on each other.
132 %{python_sitelib}/sfa
133 %{python_sitelib}/xmlbuilder
134 /etc/init.d/sfa
135 %{_bindir}/sfa-start.py*
136 %{_bindir}/keyconvert.py*
137 %{_bindir}/sfa-config-tty
138 %config /etc/sfa/default_config.xml
139 %config (noreplace) /etc/sfa/aggregates.xml
140 %config (noreplace) /etc/sfa/registries.xml
141 /var/www/html/wsdl/*.wsdl
142
143 %files plc
144 %defattr(-,root,root)
145 /etc/sfa/pl.rng
146 /etc/sfa/credential.xsd
147 /etc/sfa/top.xsd
148 /etc/sfa/sig.xsd
149 /etc/sfa/xml.xsd
150 /etc/sfa/protogeni-rspec-common.xsd
151 /etc/sfa/topology
152 %{_bindir}/sfa-import-plc.py*
153 %{_bindir}/sfa-nuke-plc.py*
154 %{_bindir}/sfa-clean-peer-records.py*
155 %{_bindir}/gen-sfa-cm-config.py*
156 %{_bindir}/sfa-ca.py*
157
158 %files client
159 %config (noreplace) /etc/sfa/sfi_config
160 %{_bindir}/sfi*
161 %{_bindir}/getNodes.py*
162 %{_bindir}/getRecord.py*
163 %{_bindir}/setRecord.py*
164 %{_bindir}/sfadump.py*
165
166 %files sfatables
167 /etc/sfatables/*
168 %{_bindir}/sfatables
169 %{python_sitelib}/sfatables
170
171 %files cm
172 /etc/init.d/sfa-cm
173 %{_bindir}/sfa_component_setup.py*
174 # cron jobs here 
175
176 %files flashpolicy
177 %{_bindir}/sfa_flashpolicy.py*
178 /etc/sfa/sfa_flashpolicy_config.xml
179
180 %files tests
181 %{_datadir}/sfa/tests
182
183 ### sfa-plc installs the 'sfa' service
184 %post plc
185 chkconfig --add sfa
186
187 %preun plc
188 if [ "$1" = 0 ] ; then
189   /sbin/service sfa stop || :
190   /sbin/chkconfig --del sfa || :
191 fi
192
193 %postun plc
194 [ "$1" -ge "1" ] && service sfa restart
195
196 ### sfa-cm installs the 'sfa-cm' service
197 %post cm
198 chkconfig --add sfa-cm
199
200 %preun cm
201 if [ "$1" = 0 ] ; then
202    /sbin/service sfa-cm stop || :
203    /sbin/chkconfig --del sfa-cm || :
204 fi
205
206 %postun cm
207 [ "$1" -ge "1" ] && service sfa-cm restart || :
208
209 %changelog
210 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
211 - sfa should now be started *before* the initial import
212 - sfa to use its own database (default sfa) - can run without myplc
213 - server calls support optional 'options'
214 - client sends options in argument when needed
215 - fix infinite getattr recursion in elements/element.py
216 - error codes in line with geni
217
218 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
219 - fixed links and attributes in rspecs
220 - minor cleanup in the API methods, and more consistent names in manager methods
221
222 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
223 - ongoing refoactoring towards more genericity
224 - passes tests again although known issues remain with attributes/tags
225
226 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
227 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
228 - improvements in the pgv2 rspecs
229 - driver separated from api
230 - code starts moving around where it belongs
231 - sfascan caches getversion across invokations
232 - vini topology extracted as a config file
233
234 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
235 - first support for protogeni rspecs is working
236 - vini no longer needs a specific manager
237 - refactoring underway towards more flexible/generic architecture
238
239 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
240 - Unicode-friendliness for user names with accents/special chars.
241 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
242 - CreaetSliver no longer fails for users that have a capital letter in their URN.
243 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
244 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
245 - Fix bugs and missing imports     
246  
247
248 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
249 - new method record.get_field for sface
250
251 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
252 - new option -c to sfa-nuke-plc.py
253 - CreateSliver fixed for admin-only slice tags
254
255 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
256 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
257 - Fixed holes in certificate verification logic.
258 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
259 - Added 'boot_state' as an attribute of the node element in SFA rspec.
260 - Non authority certificates are marked as CA:FALSE.
261
262 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
263 - fix typo in sfa-1.0-31 tag.
264 - added CreateGid() Registry interface method.
265
266 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
267 - fix typo in sfa-1.0-30 tag
268
269 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
270 - Declare namespace and schema location in the credential.
271 - Fix bug that prevetend connections from timing out.
272 - Fix slice delegation.
273 - Add statistics to slicemaanger listresources/createsliver rspec.
274 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
275   of days a user can extend their slice expiration.
276 - CA certs are only issued to objects of type authority
277    
278 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
279 - tag 1.0-28 was broken due to typo in the changelog
280 - new class sfa/util/httpsProtocol.py that supports timeouts
281
282 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
283 - Resolved issue that caused sfa hold onto idle db connections.
284 - Fix bug that caused the registry to use the wrong type of credential.
285 - Support authority+sm type.
286 - Fix rspec merging bugs.
287 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
288 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
289  planetlab hosted initscripts using the <planetlab:initscript> tag  
290 - Can now handle extraneous whitespace in the rspec without failing.   
291  
292 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
293 - ProtoGENI v2 RSpec updates.
294 - Convert expiration timestamps with timezone info in credentials to utc.
295 - Fixed redundant logging issue. 
296 - Improved SliceManager and SFI client logging.
297 - Support aggregates that don't support the optional 'call_id' argument. 
298 - Only call get_trusted_certs() at aggreage interfaces that support the call.
299 - CreateSliver() now handles MyPLC slice attributes/tags.
300 - Cache now supports persistence.
301 - Hide whitelisted nodes.
302
303 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
304 - fixed issues with sup authority signing
305 - fixed bugs in remove_slivers and SliverStatus
306
307 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
308 - fix typo that prevented aggregates from operating properly
309
310 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
311 - load trusted certs into ssl context prior to handshake
312 - client's logfile lives in ~/.sfi/sfi.log
313
314 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
315 - includes a change on passphrases that was intended in 1.0-22
316
317 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
318 - Added support for ProtoGENI RSpec v2
319  
320 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
321 - stable sfascan
322 - fix in initscript, *ENABLED tags in config now taken into account
323
324 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
325 - some commits had not been pushed in tag 19
326
327 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
328 - GetVersion should now report full URLs with path
329 - scansfa has nicer output and new syntax (entry URLs as args and not options)
330 - dos2unix'ed flash policy pill
331
332 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
333 - fix packaging again for f8
334
335 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
336 - fix packaging (apparently broken in 1.0-16)
337 - first working version of sfascan
338 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
339 - deprecated the sfa_geni_aggregate config category
340
341 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
342 - Fix build problem
343 - First version of SFA scanner
344
345 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
346 - Add support for Flash clients using flashpolicy
347 - Fix problems with tag handling in RSpec
348
349 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
350 - Modifications to the Eucalyptus Aggregate Manager
351 - Fixes for VINI RSpec
352 - Fix tag handling for PL RSpec
353 - Fix XML Schema ordering for <urn> element
354
355 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
356 - just set x509 version to 2
357
358 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
359 - added urn to the node area in rspecs
360 - conversion to urn now exports fqdn
361 - sfa-import-plc.py now creates a unique registry record for each SFA interface
362
363 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
364 - undo broken attempt for python-2.7
365
366 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
367 - SMs avoid duplicates for when call graph has dags;
368 - just based on network's name, when a duplicate occurs, one is just dropped
369 - does not try to merge/aggregate 2 networks
370 - also reviewed logging with the hope to fix the sfa startup msg:
371 - TypeError: not all arguments converted during string formatting
372
373 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
374 - verify credentials against xsd schema
375 - Fix SM to SM communication
376 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
377 - new setting session_key_path
378
379 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
380 - fix registry credential regeneration and handle expiration
381 - support for setting slice tags (min_role=user)
382 - client can display its own version: sfi.py version --local
383 - GetVersion to provide urn in addition to hrn
384 - more code uses plxrn vs previous helper functions
385 - import replaces '+' in email addresses with '_'
386
387 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
388 - fix GetVersion code_tag and add code_url
389
390 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
391 - extend GetVersion towards minimum federation introspection, and expose local tag
392
393 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
394 - fixed some legacy issues (list vs List)
395 - deprecated sfa.util.namespace for xrn and plxrn
396 - unit tests ship as the sfa-tests rpm
397
398 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
399 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
400 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
401 - hrn-urn translations tweaked
402 - fixed 'service sfa status'
403 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
404 - started to repair sfadump - although not usable yet
405 - trust objects now have dump_string method that dump() actually prints
406 - unit tests under review
407 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
408 - binaries now support -v or -vv to increase loglevel
409 - trashed obsolete sfa.util.client
410
411 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
412 - various bugfixes and cleanup, improved/harmonized logging
413
414 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
415 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
416   to avoid returning a PLCAPI exception that might confuse users.
417 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
418 - fix build errors.  
419
420 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
421 - (Architecture) Credential format changed to match ProtoGENI xml format
422 - (Architecture) All interfaces export a new set of methods that are compatible
423    with the ProtoGeni Aggregate spec. These new methods are considered a 
424    replacement  for the pervious methods exported by the interfaces. All 
425    previous methods are still exported and work as normal, but they are 
426    considered deprecated and will not be supported in future releases.  
427 - (Architecture) SFI has been updated to use the new interface methods.
428 - (Architecture) Changed keyconvet implementation from c to python.
429 - (Architecture) Slice Manager now attempts looks for a delegated credential
430   provided by the client before using its own server credential.
431 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
432   This cache now exists only in memory and is cleared when service is restarted
433   or cache lifetime is exceeded.  
434 - (Performance) SliceManager sends request to Aggregates in parallel instead 
435   of sequentially.
436 - (Bug fix) SFA tickets now support the new rspec format.
437 - (Bug fix) SFI only uses cahced credential if they aren't expired.
438 - (Bug fix) Cerdential delegation modified to work with new credential format.
439 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
440   Aggregate instead of relaying through the Slice Manager.
441 - (Enhancement) Simplified caching. Accociated a global cache instance with
442   the api handler on every new server request, making it easier to access the 
443   cache and use in more general ways.     
444
445 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
446 - SfaServer now uses a pool of threads to handle requests concurrently
447 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
448 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
449 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
450 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
451 - Component manager does not install gid files if slice already has them  
452 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
453 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
454 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
455      
456 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
457 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
458 - - sfa-config-tty now has the same features like plc-config-tty
459 - - Contains code to support both urn and hrn
460 - - Cleaned up request_hash related stuff
461 - - SM, AM and Registry code is organized under respective managers
462 - - Site and Slice synchronization across federated aggregates
463 - - Script to generate sfa_component_config
464
465 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
466 - sfa-config-tty now has the same features like plc-config-tty
467 - Contains code to support both urn and hrn
468 - Cleaned up request_hash related stuff
469 - SM, AM and Registry code is organized under respective managers
470 - Slice synchronization across federated aggregates
471 - some bugs are fixed
472
473 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
474 - checkpoint with fewer mentions of geni
475
476 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
477 - checkpointing
478 - this is believed to pass the tests; among other things:
479 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
480
481 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
482 - This tag includes:
483 - - Sfatables
484 - - Preliminary version of hash based authentication
485 - - Initial code for Component Manager
486 - - Authority structure is moved to /var/lib/sfa/
487 - - some bug-fixes
488
489 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
490 - Create_slice and get_resources methods are connected to sfatables.
491 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
492
493 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
494 - Bug fix on update and remove_peer_object methods
495 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
496
497 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
498 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
499
500 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
501 - compatibility with RefreshPeer
502 - incremental mechanism for importing PLC records into SFA tables
503 - unified single database (still inside the underlying PLC db postgresql server)
504 - includes/improves call traceability and logging features
505 - several bug fixes
506
507 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
508 - added libxslt-python dependency
509
510 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
511 - unified single SFA database in the PLC-DB
512 - upcalls from  PLCAPI to SFA methods
513 - SFA call traceability and logging features
514 - many bug fixes
515 - includes first/rough version of sfatables for policy implementation
516
517 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
518 - snapshot after the GEC5 demo
519 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
520
521 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
522 - snapshot july 15 - has gone through superficial manual testing
523 - hopefully a good basis for gec5 demo
524 - multi-dir sfi client tested as well
525
526 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
527 - rename geniwrapper.spec into sfa.spec
528
529 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
530 - clean up in xmlrpc/soap, --protocol option to chose between both
531 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
532 - hopefully more helpful context in case of crashes when importing
533 - bugfixes for using only /etc/sfa for site-dep files
534 - bugfixes in wsdl generation
535
536 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
537 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
538 - config variables in sfa_config now start with SFA_ and not GENI_
539 - config.py can be loaded even with no config present
540
541 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
542 - first step for cleanup and reorganization
543 - mass-renaming from geni to sfa (some are still needed)
544 - sfa/trust implements the security architecture
545
546 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
547 - snapshot for reproducible builds
548
549 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
550 - snapshot for the convenience of alpha users
551
552 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
553 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
554
555 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
556 - ongoing work - snapshot for 4.3-rc9
557
558 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
559 - various fixes
560
561 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
562 - bugfixes - still a work in progress
563
564 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
565 - initial package
566
567
568 %define module_current_branch 0.2