54ea656c1da3ea01226de7f5ae74f617b6bb9ecd
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.1
3 %define taglevel 9
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27
28 Requires: myplc-config
29 Requires: python >= 2.5
30 Requires: pyOpenSSL >= 0.7
31 Requires: m2crypto
32 Requires: xmlsec1-openssl-devel
33 Requires: libxslt-python
34 Requires: python-ZSI
35 # for uuidgen - used in db password generation
36 # on f8 this actually comes with e2fsprogs, go figure
37 Requires: util-linux-ng
38 # xmlbuilder depends on lxml
39 Requires: python-lxml
40 Requires: python-setuptools
41 Requires: python-dateutil
42 # for the registry
43 Requires: postgresql >= 8.2, postgresql-server >= 8.2
44 Requires: postgresql-python
45 Requires: python-psycopg2
46 # f8=0.4 - f12=0.5 f14=0.6 f16=0.7
47 Requires: python-sqlalchemy
48 Requires: python-migrate
49 # the eucalyptus aggregate uses this module
50 Requires: python-xmlbuilder
51  
52 # python 2.5 has uuid module added, for python 2.4 we still need it.
53 # we can't really check for if we can load uuid as a python module,
54 # it'll be installed by "devel.pkgs". we have the epel repository so
55 # python-uuid will be provided. but we can test for the python
56 # version.
57 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
58 # %if %has_py24
59 #
60 # this also didn't work very well. I'll just check for distroname - baris
61 #%if %{distroname} == "centos5"
62 #Requires: python-uuid
63 #%endif
64
65 %package plc
66 Summary: the SFA layer around MyPLC
67 Group: Applications/System
68 Requires: sfa
69 Requires: python-psycopg2
70
71 %package client
72 Summary: the SFA experimenter-side CLI
73 Group: Applications/System
74 Requires: sfa
75 Requires: pyOpenSSL >= 0.7
76
77 %package sfatables
78 Summary: sfatables policy tool for SFA
79 Group: Applications/System
80 Requires: sfa
81
82 %package cm
83 Summary: the SFA layer around MyPLC NodeManager
84 Group: Applications/System
85 Requires: sfa
86 Requires: pyOpenSSL >= 0.6
87
88 %package flashpolicy
89 Summary: SFA support for flash clients
90 Group: Applications/System
91 Requires: sfa
92
93 %package xmlbuilder
94 Summary: third-party xmlbuilder tool
95 Group: Applications/System
96 Provides: python-xmlbuilder
97
98 %package tests
99 Summary: unit tests suite for SFA
100 Group: Applications/System
101 Requires: sfa
102
103 %description
104 This package provides the python libraries for the PlanetLab implementation of SFA
105
106 %description plc
107 This package implements the SFA interface which serves as a layer
108 between the existing PlanetLab interfaces and the SFA API.
109
110 %description client
111 This package provides the client side of the SFA API, in particular
112 sfi.py, together with other utilities.
113
114 %description sfatables
115 sfatables is a tool for defining access and admission control policies
116 in an SFA network, in much the same way as iptables is for ip
117 networks. This is the command line interface to manage sfatables
118
119 %description cm
120 This package implements the SFA interface which serves as a layer
121 between the existing PlanetLab NodeManager interfaces and the SFA API.
122
123 %description flashpolicy
124 This package provides support for adobe flash client applications.  
125
126 %description xmlbuilder
127 This package contains the xmlbuilder python library, packaged for
128 convenience as it is not supported by fedora
129
130 %description tests
131 Provides some binary unit tests in /usr/share/sfa/tests
132
133 %prep
134 %setup -q
135
136 %build
137 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 # sfa and sfatables depend on each other.
148 %{python_sitelib}/sfa
149 /etc/init.d/sfa
150 %{_bindir}/sfa-start.py*
151 %{_bindir}/sfaadmin.py*
152 %{_bindir}/sfaadmin
153 %{_bindir}/keyconvert.py*
154 %{_bindir}/sfa-config-tty
155 %config /etc/sfa/default_config.xml
156 %config (noreplace) /etc/sfa/aggregates.xml
157 %config (noreplace) /etc/sfa/registries.xml
158 /usr/share/sfa/migrations
159 /usr/share/sfa/examples
160 /var/www/html/wsdl/*.wsdl
161
162 %files plc
163 %defattr(-,root,root)
164 /etc/sfa/pl.rng
165 /etc/sfa/credential.xsd
166 /etc/sfa/top.xsd
167 /etc/sfa/sig.xsd
168 /etc/sfa/xml.xsd
169 /etc/sfa/protogeni-rspec-common.xsd
170 /etc/sfa/topology
171 %{_bindir}/gen-sfa-cm-config.py*
172
173 %files client
174 %config (noreplace) /etc/sfa/sfi_config
175 %{_bindir}/sfi*.py*
176 %{_bindir}/sfi
177 %{_bindir}/get*.py*
178 %{_bindir}/setRecord.py*
179 %{_bindir}/sfascan.py*
180 %{_bindir}/sfascan
181 %{_bindir}/sfadump.py*
182
183 %files sfatables
184 /etc/sfatables/*
185 %{_bindir}/sfatables
186 %{python_sitelib}/sfatables
187
188 %files cm
189 /etc/init.d/sfa-cm
190 %{_bindir}/sfa_component_setup.py*
191 # cron jobs here 
192
193 %files flashpolicy
194 %{_bindir}/sfa_flashpolicy.py*
195 /etc/sfa/sfa_flashpolicy_config.xml
196
197 %files xmlbuilder
198 %{python_sitelib}/xmlbuilder
199
200 %files tests
201 %{_datadir}/sfa/tests
202
203 ### sfa installs the 'sfa' service
204 %post 
205 chkconfig --add sfa
206
207 %preun 
208 if [ "$1" = 0 ] ; then
209   /sbin/service sfa stop || :
210   /sbin/chkconfig --del sfa || :
211 fi
212
213 %postun
214 [ "$1" -ge "1" ] && { service sfa dbdump ; service sfa restart ; }
215
216 ### sfa-cm installs the 'sfa-cm' service
217 %post cm
218 chkconfig --add sfa-cm
219
220 %preun cm
221 if [ "$1" = 0 ] ; then
222    /sbin/service sfa-cm stop || :
223    /sbin/chkconfig --del sfa-cm || :
224 fi
225
226 %postun cm
227 [ "$1" -ge "1" ] && service sfa-cm restart || :
228
229 %changelog
230 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-9
231 - fix broken sfa.util.xrn class for lowercase
232
233 * Sat Jun 02 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-8
234 - new 'void' generic_flavour for running in registry-only mode
235 - first shot at refactoring importers - probably needs more work
236 - openstack: various enhancements
237 - sfi interface to registry not based on xml files anymore
238 - sfi show sorts result on record key
239 - bugfix in sfa update on users with a pl-backed registry
240
241 * Mon May 14 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-7
242 - renamed sfa/plc into sfa/planetlab
243 - plxrn moved in sfa/planetlab as well
244 - bugfix for sfaadmin reg update --pi <>
245
246 * Sat May 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-6
247 - native data model now has a authority x user (PI) relationship
248 - no call to 'augment_records_with_testbed_info' for GetCredential
249 - which means, registry can now be used without an underlying testbed
250 - reviewed code about relationships b/w objects and related in pl driver
251 - reviewed PL import wrt roles and pis
252 - removed mentions to is_enabled in driver
253 - small changes in update_relation* in driver interface
254 - sfaadmin: can create authorities and attach pi users to them
255 - sfaadmin: categories can be abbreviated
256 - sfi list and sfaadmin list have a new -r/--recursive option
257 - this means that List now supports an (optional) 'options' argument
258 - sfi config can display config vars
259 - sfaadmin code in sfa.client + /usr/bin/sfaadmin shortcut
260
261 * Mon Apr 16 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-5
262 - make sync now supports vserver or lxc.
263 - Added slice expiration and login info to SliverStatus response. 
264 - Fixed CreateSliver bug that causes the method to fail if any node element is missing
265   the 'component_name' attribute.
266 - Fixed various bugs that caused SFA to generate invalid or incorrect sliver ids.
267   
268 * Tue Mar 20 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.1-4
269 - Introduced new administrative command line script, sfaadmin.py. Removed various single
270  purpose scripts and migrated their functionality into sfaadmin.py.
271 - Refactored Registry import scripts.
272 - Removed SQLAlchemy dependency from sfi.py.
273 - Fixed bugs in sfi.py
274 - Registry, Aggregate and SliceManager now support the OpenStack framework. 
275
276 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-3
277 - slice x researcher rel. in database,
278 - plimporter to maintain that, as well as user.email, and more robust
279 - ongoing draft for sfaadmin tool
280 - support for a federica driver
281 - support for a nova/euca driver
282 - no more sfa-clean-peer-records script
283
284 * Wed Feb 08 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-2
285 - registry database has user's keys and mail (known as v0 for migrate)
286 - pl importer properly maintains user's keys and mail
287 - pl driver now to handle 'role' when adding person record (exp.)
288 - first draft of federica driver with config section
289 - SFA_GENERIC_FLAVOUR in usual variables for sfa-config-tty
290 - plus, from master as of tag merged-in-sfa-2.1-2:
291 - disk_image revisited
292 - new nova_shell nova_driver & various tweaks for openstack
293
294 * Fri Jan 27 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.1-1
295 - uses sqlalchemy and related migrate
296 - thorough migration and upgrade scheme
297 - sfa-import.py and sfa-nuke.py (no more -plc), uses FLAVOUR
298 - trashed dbinfo stuff in auth hierarchy
299 - data model still has little more than plain records
300 - checkpoint tag, not yet intended for release
301
302 * Wed Jan 25 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-10
303 - client: added -R --raw sfi cmdline option that displays raw server response.
304 - client: request GENI RSpec by default. 
305 - server: remove database dependencies from sfa.server.sfaapi.
306 - server: increased default credential lifetime to 31 days.
307 - bugfix: fixed bug in sfa.storage.record.SfaRecord.delete().
308 - bugfix: fixed server key path in sfa.server.sfa-clean-peer-records.
309 - bugfix: fixed bug in sfa.server.sfa-start.install_peer_certs(). 
310  
311 * Sat Jan 7 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-9
312 - bugfix: 'geni_api' should be in the top level struct, not the code struct
313 - bugfix: Display the correct host and port in 'geni_api_versions' field of the GetVersion
314           output returned by the Aggregate Manager.
315 - bugfix: sfa.util.sfatime now handles numeric string inputs correctly.
316 - bugfix: sfa.util.sfatime.datetime_to_epoch() returns integers instead of doubles.
317 - bugfix: Fixed bug that prevented the rspec parser from identifying an rspec's schema when
318           there is extra whitespace in the schemaLocation field.
319 - bugfix: Fixed bug that caused PlanetLab initscripts from showing up in the PGv2 and GENIv3 
320           advertisement rspecs.
321 - bugfix: <login> RSpec element should contain the 'username' attribute.
322 - bugfix: Use sfa.util.plxrn.PlXrn to parse the login_base (authority) out of a urn.      
323  
324 * Wed Jan 4 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-8
325 - bugfix: Fixed a bug in the sfa-import-plc.py script that caused the script to 
326   exit when it encountered a user with an invalid public key.
327 - server: imporved logging in sfa-import-plc.py
328  
329 * Tue Jan 3 2012 Tony Mack <tmack@cs.princeton.edu> - sfa-2.0-7
330 - bugfix: Fixed appending public keys in CreateSliver
331 - bugfix: Fixed various bugs in the PGv2/GENIv3 request, advertisement and manifest rspecs.
332 - client: -c --current option allows users to request the current/uncached rspec.
333 - server: Added 'geni_api_versions' field to GetVersion() output.
334 - server: Moved PLC specific code from sfa.importer.sfaImport to sfa.importer.sfa-import-plc.
335    
336 * Fri Dec 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-6
337 - bugfix: sfi was not sending call_id with ListResources to v2 servers
338 - SFA_API_DEBUG replaced with SFA_API_LOGLEVEL
339 - PlDriver / PlShell : PLCAPI methods now explicitly go to the shell
340
341 * Wed Dec 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-5
342 - client: sfi -a / -p deprecated (use -s instead)
343 - client: sfi cleaned up
344 - client: sfi has backward support for APIv1 aggregates again
345 - server: only APIv2 is supported and should be rather strict
346 - server: settings for turning on/off caching in sm or am
347 - server: plc-dependant code has moved from aggregate to pldriver
348 - server: driver interface extended accordingly
349
350 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-4
351 - screwed up previous tag
352
353 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-3
354 - client side revisited with a bootstrap library
355 - client side has a new source layout
356 - various (nasty) bug fixes wrt options and call_id
357
358 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
359 - various fixes in rspecs for sfav1&slice tags
360 - uses 'geni_rspec_version' and not just 'rspec_version'
361 - example flavour for the max testbed
362 - embryo for an sfa client library
363 - topology.py moved into plc
364 - sql: table is named records; record_types are enforced
365 - sql: table creation cleaned up
366
367 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
368 - cleaned up all references to SFA_*_TYPE in config
369 - enable cache at the aggregate by default
370 - registry now uses the driver in a sensible way (see managers/driver.py)
371 - slice manager supports sfav1/pgv2 neighbours
372 - get_key renamed into get_key_from_incoming_ip
373 - new sfa.storage module for record/table and all db-related stuff
374 - db schema in sfa.storage.sfa.sql
375 - init.d and cron.d move one step up
376 - cleaned up rspec/ directory
377 - add deps to pyopenssl and myplc-config
378 - start support for new API (return value)
379 - plc.remoteshell removed, use plshell instead
380 - plshell uses a 'capability' auth method whenever possible
381 - various tweaks in rspec elements
382 - made dependency on sfatables softer
383
384 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
385 - sfa should now be started *before* the initial import
386 - sfa to use its own database (default sfa) - can run without myplc
387 - server calls support optional 'options'
388 - client sends options in argument when needed
389 - fix infinite getattr recursion in elements/element.py
390 - error codes in line with geni
391
392 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
393 - fixed links and attributes in rspecs
394 - minor cleanup in the API methods, and more consistent names in manager methods
395
396 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
397 - ongoing refoactoring towards more genericity
398 - passes tests again although known issues remain with attributes/tags
399
400 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
401 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
402 - improvements in the pgv2 rspecs
403 - driver separated from api
404 - code starts moving around where it belongs
405 - sfascan caches getversion across invokations
406 - vini topology extracted as a config file
407
408 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
409 - first support for protogeni rspecs is working
410 - vini no longer needs a specific manager
411 - refactoring underway towards more flexible/generic architecture
412
413 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
414 - Unicode-friendliness for user names with accents/special chars.
415 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
416 - CreaetSliver no longer fails for users that have a capital letter in their URN.
417 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
418 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
419 - Fix bugs and missing imports     
420  
421
422 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
423 - new method record.get_field for sface
424
425 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
426 - new option -c to sfa-nuke-plc.py
427 - CreateSliver fixed for admin-only slice tags
428
429 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
430 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
431 - Fixed holes in certificate verification logic.
432 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
433 - Added 'boot_state' as an attribute of the node element in SFA rspec.
434 - Non authority certificates are marked as CA:FALSE.
435
436 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
437 - fix typo in sfa-1.0-31 tag.
438 - added CreateGid() Registry interface method.
439
440 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
441 - fix typo in sfa-1.0-30 tag
442
443 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
444 - Declare namespace and schema location in the credential.
445 - Fix bug that prevetend connections from timing out.
446 - Fix slice delegation.
447 - Add statistics to slicemaanger listresources/createsliver rspec.
448 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
449   of days a user can extend their slice expiration.
450 - CA certs are only issued to objects of type authority
451    
452 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
453 - tag 1.0-28 was broken due to typo in the changelog
454 - new class sfa/util/httpsProtocol.py that supports timeouts
455
456 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
457 - Resolved issue that caused sfa hold onto idle db connections.
458 - Fix bug that caused the registry to use the wrong type of credential.
459 - Support authority+sm type.
460 - Fix rspec merging bugs.
461 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
462 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
463  planetlab hosted initscripts using the <planetlab:initscript> tag  
464 - Can now handle extraneous whitespace in the rspec without failing.   
465  
466 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
467 - ProtoGENI v2 RSpec updates.
468 - Convert expiration timestamps with timezone info in credentials to utc.
469 - Fixed redundant logging issue. 
470 - Improved SliceManager and SFI client logging.
471 - Support aggregates that don't support the optional 'call_id' argument. 
472 - Only call get_trusted_certs() at aggreage interfaces that support the call.
473 - CreateSliver() now handles MyPLC slice attributes/tags.
474 - Cache now supports persistence.
475 - Hide whitelisted nodes.
476
477 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
478 - fixed issues with sup authority signing
479 - fixed bugs in remove_slivers and SliverStatus
480
481 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
482 - fix typo that prevented aggregates from operating properly
483
484 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
485 - load trusted certs into ssl context prior to handshake
486 - client's logfile lives in ~/.sfi/sfi.log
487
488 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
489 - includes a change on passphrases that was intended in 1.0-22
490
491 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
492 - Added support for ProtoGENI RSpec v2
493  
494 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
495 - stable sfascan
496 - fix in initscript, *ENABLED tags in config now taken into account
497
498 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
499 - some commits had not been pushed in tag 19
500
501 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
502 - GetVersion should now report full URLs with path
503 - scansfa has nicer output and new syntax (entry URLs as args and not options)
504 - dos2unix'ed flash policy pill
505
506 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
507 - fix packaging again for f8
508
509 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
510 - fix packaging (apparently broken in 1.0-16)
511 - first working version of sfascan
512 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
513 - deprecated the sfa_geni_aggregate config category
514
515 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
516 - Fix build problem
517 - First version of SFA scanner
518
519 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
520 - Add support for Flash clients using flashpolicy
521 - Fix problems with tag handling in RSpec
522
523 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
524 - Modifications to the Eucalyptus Aggregate Manager
525 - Fixes for VINI RSpec
526 - Fix tag handling for PL RSpec
527 - Fix XML Schema ordering for <urn> element
528
529 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
530 - just set x509 version to 2
531
532 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
533 - added urn to the node area in rspecs
534 - conversion to urn now exports fqdn
535 - sfa-import-plc.py now creates a unique registry record for each SFA interface
536
537 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
538 - undo broken attempt for python-2.7
539
540 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
541 - SMs avoid duplicates for when call graph has dags;
542 - just based on network's name, when a duplicate occurs, one is just dropped
543 - does not try to merge/aggregate 2 networks
544 - also reviewed logging with the hope to fix the sfa startup msg:
545 - TypeError: not all arguments converted during string formatting
546
547 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
548 - verify credentials against xsd schema
549 - Fix SM to SM communication
550 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
551 - new setting session_key_path
552
553 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
554 - fix registry credential regeneration and handle expiration
555 - support for setting slice tags (min_role=user)
556 - client can display its own version: sfi.py version --local
557 - GetVersion to provide urn in addition to hrn
558 - more code uses plxrn vs previous helper functions
559 - import replaces '+' in email addresses with '_'
560
561 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
562 - fix GetVersion code_tag and add code_url
563
564 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
565 - extend GetVersion towards minimum federation introspection, and expose local tag
566
567 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
568 - fixed some legacy issues (list vs List)
569 - deprecated sfa.util.namespace for xrn and plxrn
570 - unit tests ship as the sfa-tests rpm
571
572 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
573 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
574 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
575 - hrn-urn translations tweaked
576 - fixed 'service sfa status'
577 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
578 - started to repair sfadump - although not usable yet
579 - trust objects now have dump_string method that dump() actually prints
580 - unit tests under review
581 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
582 - binaries now support -v or -vv to increase loglevel
583 - trashed obsolete sfa.util.client
584
585 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
586 - various bugfixes and cleanup, improved/harmonized logging
587
588 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
589 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
590   to avoid returning a PLCAPI exception that might confuse users.
591 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
592 - fix build errors.  
593
594 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
595 - (Architecture) Credential format changed to match ProtoGENI xml format
596 - (Architecture) All interfaces export a new set of methods that are compatible
597    with the ProtoGeni Aggregate spec. These new methods are considered a 
598    replacement  for the pervious methods exported by the interfaces. All 
599    previous methods are still exported and work as normal, but they are 
600    considered deprecated and will not be supported in future releases.  
601 - (Architecture) SFI has been updated to use the new interface methods.
602 - (Architecture) Changed keyconvet implementation from c to python.
603 - (Architecture) Slice Manager now attempts looks for a delegated credential
604   provided by the client before using its own server credential.
605 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
606   This cache now exists only in memory and is cleared when service is restarted
607   or cache lifetime is exceeded.  
608 - (Performance) SliceManager sends request to Aggregates in parallel instead 
609   of sequentially.
610 - (Bug fix) SFA tickets now support the new rspec format.
611 - (Bug fix) SFI only uses cahced credential if they aren't expired.
612 - (Bug fix) Cerdential delegation modified to work with new credential format.
613 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
614   Aggregate instead of relaying through the Slice Manager.
615 - (Enhancement) Simplified caching. Accociated a global cache instance with
616   the api handler on every new server request, making it easier to access the 
617   cache and use in more general ways.     
618
619 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
620 - SfaServer now uses a pool of threads to handle requests concurrently
621 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
622 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
623 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
624 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
625 - Component manager does not install gid files if slice already has them  
626 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
627 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
628 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
629      
630 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
631 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
632 - - sfa-config-tty now has the same features like plc-config-tty
633 - - Contains code to support both urn and hrn
634 - - Cleaned up request_hash related stuff
635 - - SM, AM and Registry code is organized under respective managers
636 - - Site and Slice synchronization across federated aggregates
637 - - Script to generate sfa_component_config
638
639 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
640 - sfa-config-tty now has the same features like plc-config-tty
641 - Contains code to support both urn and hrn
642 - Cleaned up request_hash related stuff
643 - SM, AM and Registry code is organized under respective managers
644 - Slice synchronization across federated aggregates
645 - some bugs are fixed
646
647 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
648 - checkpoint with fewer mentions of geni
649
650 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
651 - checkpointing
652 - this is believed to pass the tests; among other things:
653 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
654
655 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
656 - This tag includes:
657 - - Sfatables
658 - - Preliminary version of hash based authentication
659 - - Initial code for Component Manager
660 - - Authority structure is moved to /var/lib/sfa/
661 - - some bug-fixes
662
663 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
664 - Create_slice and get_resources methods are connected to sfatables.
665 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
666
667 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
668 - Bug fix on update and remove_peer_object methods
669 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
670
671 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
672 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
673
674 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
675 - compatibility with RefreshPeer
676 - incremental mechanism for importing PLC records into SFA tables
677 - unified single database (still inside the underlying PLC db postgresql server)
678 - includes/improves call traceability and logging features
679 - several bug fixes
680
681 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
682 - added libxslt-python dependency
683
684 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
685 - unified single SFA database in the PLC-DB
686 - upcalls from  PLCAPI to SFA methods
687 - SFA call traceability and logging features
688 - many bug fixes
689 - includes first/rough version of sfatables for policy implementation
690
691 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
692 - snapshot after the GEC5 demo
693 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
694
695 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
696 - snapshot july 15 - has gone through superficial manual testing
697 - hopefully a good basis for gec5 demo
698 - multi-dir sfi client tested as well
699
700 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
701 - rename geniwrapper.spec into sfa.spec
702
703 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
704 - clean up in xmlrpc/soap, --protocol option to chose between both
705 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
706 - hopefully more helpful context in case of crashes when importing
707 - bugfixes for using only /etc/sfa for site-dep files
708 - bugfixes in wsdl generation
709
710 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
711 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
712 - config variables in sfa_config now start with SFA_ and not GENI_
713 - config.py can be loaded even with no config present
714
715 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
716 - first step for cleanup and reorganization
717 - mass-renaming from geni to sfa (some are still needed)
718 - sfa/trust implements the security architecture
719
720 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
721 - snapshot for reproducible builds
722
723 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
724 - snapshot for the convenience of alpha users
725
726 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
727 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
728
729 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
730 - ongoing work - snapshot for 4.3-rc9
731
732 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
733 - various fixes
734
735 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
736 - bugfixes - still a work in progress
737
738 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
739 - initial package
740
741
742 %define module_current_branch 0.2