6131d19ec9b6e1bb320f0e5db24e01241e6a0592
[sfa.git] / sfa.spec
1
2 #
3 # $Id$
4 #
5
6 %define url $URL$
7
8 %define name sfa
9 %define version 0.9
10 %define taglevel 2
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
15
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 Source0: %{name}-%{version}.tar.bz2
20 License: GPL
21 Group: Applications/System
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
24 Vendor: PlanetLab
25 Packager: PlanetLab Central <support@planet-lab.org>
26 Distribution: PlanetLab %{plrelease}
27 URL: %(echo %{url} | cut -d ' ' -f 2)
28 Summary: the SFA python libraries
29 Group: Applications/System
30
31 BuildRequires: make
32 Requires: python
33 Requires: pyOpenSSL >= 0.7
34 Requires: m2crypto
35 Requires: libxslt-python
36
37 # python 2.5 has uuid module added, for python 2.4 we still need it
38 %define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
39 %if has_uuid
40 %else
41 Requires: python-uuid
42 %endif
43
44 %package plc
45 Summary: the SFA wrapper arounf MyPLC
46 Group: Applications/System
47 Requires: sfa
48
49 %package client
50 Summary: the SFA experimenter-side CLI
51 Group: Applications/System
52 Requires: sfa
53
54 %package sfatables
55 Summary: sfatables policy tool for SFA
56 Group: Applications/System
57 Requires: sfa
58
59 %description
60 This package provides the python libraries that the SFA implementation requires
61
62 %description plc
63 Geniwrapper implements the SFA interface which serves as a layer
64 between the existing PlanetLab interfaces and the SFA API.
65
66 %description client
67 This package provides the client side of the SFA API, in particular
68 sfi.py, together with other utilities.
69
70 %description sfatables
71 sfatables is a tool for defining access and admission control policies
72 in an SFA network, in much the same way as iptables is for ip
73 networks. This is the command line interface to manage sfatables
74
75 %prep
76 %setup -q
77
78 %build
79 make
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 make install DESTDIR="$RPM_BUILD_ROOT"
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %{python_sitelib}/*
90 /usr/bin/keyconvert
91 /var/www/html/wsdl/*.wsdl
92 # sfa and sfatables depend each other.
93 /etc/sfatables/*
94 %{python_sitelib}/sfatables/*
95
96
97 %files plc
98 %defattr(-,root,root)
99 %config (noreplace) /etc/sfa/sfa_config
100 %config (noreplace) /etc/sfa/aggregates.xml
101 %config (noreplace) /etc/sfa/registries.xml
102 /etc/init.d/sfa
103 %{_bindir}/sfa-config-tty
104 %{_bindir}/sfa-import-plc.py*
105 %{_bindir}/sfa-clean-peer-records.py*
106 %{_bindir}/sfa-nuke-plc.py*
107 %{_bindir}/sfa-server.py*
108
109 %files client
110 %config (noreplace) /etc/sfa/sfi_config
111 %{_bindir}/sfi.py*
112 %{_bindir}/getNodes.py*
113 %{_bindir}/getRecord.py*
114 %{_bindir}/setRecord.py*
115 %{_bindir}/genidump.py*
116
117 %files sfatables
118 %{_bindir}/sfatables
119
120 %pre plc
121 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
122
123 %post plc
124 chkconfig --add sfa
125
126 %changelog
127 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
128 - compatibility with RefreshPeer
129 - incremental mechanism for importing PLC records into SFA tables
130 - unified single database (still inside the underlying PLC db postgresql server)
131 - includes/improves call traceability and logging features
132 - several bug fixes
133
134 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
135 - added libxslt-python dependency
136
137 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
138 - unified single SFA database in the PLC-DB
139 - upcalls from  PLCAPI to SFA methods
140 - SFA call traceability and logging features
141 - many bug fixes
142 - includes first/rough version of sfatables for policy implementation
143
144 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
145 - snapshot after the GEC5 demo
146 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
147
148 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
149 - snapshot july 15 - has gone through superficial manual testing
150 - hopefully a good basis for gec5 demo
151 - multi-dir sfi client tested as well
152
153 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
154 - rename geniwrapper.spec into sfa.spec
155
156 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
157 - clean up in xmlrpc/soap, --protocol option to chose between both
158 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
159 - hopefully more helpful context in case of crashes when importing
160 - bugfixes for using only /etc/sfa for site-dep files
161 - bugfixes in wsdl generation
162
163 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
164 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
165 - config variables in sfa_config now start with SFA_ and not GENI_
166 - config.py can be loaded even with no config present
167
168 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
169 - first step for cleanup and reorganization
170 - mass-renaming from geni to sfa (some are still needed)
171 - sfa/trust implements the security architecture
172
173 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
174 - snapshot for reproducible builds
175
176 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
177 - snapshot for the convenience of alpha users
178
179 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
180 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
181
182 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
183 - ongoing work - snapshot for 4.3-rc9
184
185 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
186 - various fixes
187
188 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
189 - bugfixes - still a work in progress
190
191 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
192 - initial package
193
194
195 %define module_current_branch 0.2