6505eaf55447a9aa4bbde7020badd8c2160f51ff
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 1.1
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21 Summary: the SFA python libraries
22 Group: Applications/System
23
24 BuildRequires: make
25 Requires: python >= 2.5
26 Requires: m2crypto
27 Requires: xmlsec1-openssl-devel
28 Requires: libxslt-python
29 Requires: python-ZSI
30 # xmlbuilder depends on  lxml
31 Requires: python-lxml
32 Requires: python-setuptools
33 Requires: python-dateutil
34 # for the registry
35 Requires: postgresql >= 8.2, postgresql-server >= 8.2
36 Requires: postgresql-python
37 Requires: python-psycopg2
38  
39 # python 2.5 has uuid module added, for python 2.4 we still need it.
40 # we can't really check for if we can load uuid as a python module,
41 # it'll be installed by "devel.pkgs". we have the epel repository so
42 # python-uuid will be provided. but we can test for the python
43 # version.
44 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
45 # %if %has_py24
46 #
47 # this also didn't work very well. I'll just check for distroname - baris
48 #%if %{distroname} == "centos5"
49 #Requires: python-uuid
50 #%endif
51
52 %package cm
53 Summary: the SFA layer around MyPLC NodeManager
54 Group: Applications/System
55 Requires: sfa
56 Requires: pyOpenSSL >= 0.6
57
58 %package plc
59 Summary: the SFA layer around MyPLC
60 Group: Applications/System
61 Requires: sfa
62 Requires: python-psycopg2
63 Requires: myplc-config
64 Requires: pyOpenSSL >= 0.7
65
66 %package client
67 Summary: the SFA experimenter-side CLI
68 Group: Applications/System
69 Requires: sfa
70 Requires: pyOpenSSL >= 0.7
71
72 %package sfatables
73 Summary: sfatables policy tool for SFA
74 Group: Applications/System
75 Requires: sfa
76
77 %package flashpolicy
78 Summary: SFA support for flash clients
79 Group: Applications/System
80 Requires: sfa
81
82 %package tests
83 Summary: unit tests suite for SFA
84 Group: Applications/System
85 Requires: sfa
86
87 %description
88 This package provides the python libraries for the PlanetLab implementation of SFA
89
90 %description cm
91 This package implements the SFA interface which serves as a layer
92 between the existing PlanetLab NodeManager interfaces and the SFA API.
93  
94 %description plc
95 This package implements the SFA interface which serves as a layer
96 between the existing PlanetLab interfaces and the SFA API.
97
98 %description client
99 This package provides the client side of the SFA API, in particular
100 sfi.py, together with other utilities.
101
102 %description sfatables
103 sfatables is a tool for defining access and admission control policies
104 in an SFA network, in much the same way as iptables is for ip
105 networks. This is the command line interface to manage sfatables
106
107 %description flashpolicy
108 This package provides support for adobe flash client applications.  
109  
110 %description tests
111 Provides some binary unit tests in /usr/share/sfa/tests
112
113 %prep
114 %setup -q
115
116 %build
117 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 # sfa and sfatables depend each other.
128 %{_bindir}/sfa-start.py*
129 /etc/sfatables/*
130 %{python_sitelib}/*
131 %{_bindir}/keyconvert.py*
132 /var/www/html/wsdl/*.wsdl
133
134 %files cm
135 /etc/init.d/sfa-cm
136 %{_bindir}/sfa_component_setup.py*
137 # cron jobs here 
138
139 %files plc
140 %defattr(-,root,root)
141 %config /etc/sfa/default_config.xml
142 %config (noreplace) /etc/sfa/aggregates.xml
143 %config (noreplace) /etc/sfa/registries.xml
144 /etc/init.d/sfa
145 /etc/sfa/pl.rng
146 /etc/sfa/credential.xsd
147 /etc/sfa/top.xsd
148 /etc/sfa/sig.xsd
149 /etc/sfa/xml.xsd
150 /etc/sfa/protogeni-rspec-common.xsd
151 /etc/sfa/topology
152 %{_bindir}/sfa-config-tty
153 %{_bindir}/sfa-import-plc.py*
154 %{_bindir}/sfa-clean-peer-records.py*
155 %{_bindir}/sfa-nuke-plc.py*
156 %{_bindir}/gen-sfa-cm-config.py*
157 %{_bindir}/sfa-ca.py*
158
159 %files client
160 %config (noreplace) /etc/sfa/sfi_config
161 %{_bindir}/sfi*
162 %{_bindir}/getNodes.py*
163 %{_bindir}/getRecord.py*
164 %{_bindir}/setRecord.py*
165 %{_bindir}/sfadump.py*
166
167 %files sfatables
168 %{_bindir}/sfatables
169
170 %files flashpolicy
171 %{_bindir}/sfa_flashpolicy.py*
172 /etc/sfa/sfa_flashpolicy_config.xml
173
174 %files tests
175 %{_datadir}/sfa/tests
176
177 ### sfa-plc installs the 'sfa' service
178 %post plc
179 chkconfig --add sfa
180
181 %preun plc
182 if [ "$1" = 0 ] ; then
183   /sbin/service sfa stop || :
184   /sbin/chkconfig --del sfa || :
185 fi
186
187 %postun plc
188 [ "$1" -ge "1" ] && service sfa restart
189
190 ### sfa-cm installs the 'sfa-cm' service
191 %post cm
192 chkconfig --add sfa-cm
193
194 %preun cm
195 if [ "$1" = 0 ] ; then
196    /sbin/service sfa-cm stop || :
197    /sbin/chkconfig --del sfa-cm || :
198 fi
199
200 %postun cm
201 [ "$1" -ge "1" ] && service sfa-cm restart || :
202
203 %changelog
204 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
205 - fixed links and attributes in rspecs
206 - minor cleanup in the API methods, and more consistent names in manager methods
207
208 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
209 - ongoing refoactoring towards more genericity
210 - passes tests again although known issues remain with attributes/tags
211
212 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
213 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
214 - improvements in the pgv2 rspecs
215 - driver separated from api
216 - code starts moving around where it belongs
217 - sfascan caches getversion across invokations
218 - vini topology extracted as a config file
219
220 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
221 - first support for protogeni rspecs is working
222 - vini no longer needs a specific manager
223 - refactoring underway towards more flexible/generic architecture
224
225 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
226 - Unicode-friendliness for user names with accents/special chars.
227 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
228 - CreaetSliver no longer fails for users that have a capital letter in their URN.
229 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
230 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
231 - Fix bugs and missing imports     
232  
233
234 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
235 - new method record.get_field for sface
236
237 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
238 - new option -c to sfa-nuke-plc.py
239 - CreateSliver fixed for admin-only slice tags
240
241 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
242 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
243 - Fixed holes in certificate verification logic.
244 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
245 - Added 'boot_state' as an attribute of the node element in SFA rspec.
246 - Non authority certificates are marked as CA:FALSE.
247
248 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
249 - fix typo in sfa-1.0-31 tag.
250 - added CreateGid() Registry interface method.
251
252 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
253 - fix typo in sfa-1.0-30 tag
254
255 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
256 - Declare namespace and schema location in the credential.
257 - Fix bug that prevetend connections from timing out.
258 - Fix slice delegation.
259 - Add statistics to slicemaanger listresources/createsliver rspec.
260 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
261   of days a user can extend their slice expiration.
262 - CA certs are only issued to objects of type authority
263    
264 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
265 - tag 1.0-28 was broken due to typo in the changelog
266 - new class sfa/util/httpsProtocol.py that supports timeouts
267
268 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
269 - Resolved issue that caused sfa hold onto idle db connections.
270 - Fix bug that caused the registry to use the wrong type of credential.
271 - Support authority+sm type.
272 - Fix rspec merging bugs.
273 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
274 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
275  planetlab hosted initscripts using the <planetlab:initscript> tag  
276 - Can now handle extraneous whitespace in the rspec without failing.   
277  
278 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
279 - ProtoGENI v2 RSpec updates.
280 - Convert expiration timestamps with timezone info in credentials to utc.
281 - Fixed redundant logging issue. 
282 - Improved SliceManager and SFI client logging.
283 - Support aggregates that don't support the optional 'call_id' argument. 
284 - Only call get_trusted_certs() at aggreage interfaces that support the call.
285 - CreateSliver() now handles MyPLC slice attributes/tags.
286 - Cache now supports persistence.
287 - Hide whitelisted nodes.
288
289 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
290 - fixed issues with sup authority signing
291 - fixed bugs in remove_slivers and SliverStatus
292
293 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
294 - fix typo that prevented aggregates from operating properly
295
296 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
297 - load trusted certs into ssl context prior to handshake
298 - client's logfile lives in ~/.sfi/sfi.log
299
300 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
301 - includes a change on passphrases that was intended in 1.0-22
302
303 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
304 - Added support for ProtoGENI RSpec v2
305  
306 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
307 - stable sfascan
308 - fix in initscript, *ENABLED tags in config now taken into account
309
310 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
311 - some commits had not been pushed in tag 19
312
313 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
314 - GetVersion should now report full URLs with path
315 - scansfa has nicer output and new syntax (entry URLs as args and not options)
316 - dos2unix'ed flash policy pill
317
318 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
319 - fix packaging again for f8
320
321 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
322 - fix packaging (apparently broken in 1.0-16)
323 - first working version of sfascan
324 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
325 - deprecated the sfa_geni_aggregate config category
326
327 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
328 - Fix build problem
329 - First version of SFA scanner
330
331 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
332 - Add support for Flash clients using flashpolicy
333 - Fix problems with tag handling in RSpec
334
335 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
336 - Modifications to the Eucalyptus Aggregate Manager
337 - Fixes for VINI RSpec
338 - Fix tag handling for PL RSpec
339 - Fix XML Schema ordering for <urn> element
340
341 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
342 - just set x509 version to 2
343
344 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
345 - added urn to the node area in rspecs
346 - conversion to urn now exports fqdn
347 - sfa-import-plc.py now creates a unique registry record for each SFA interface
348
349 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
350 - undo broken attempt for python-2.7
351
352 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
353 - SMs avoid duplicates for when call graph has dags;
354 - just based on network's name, when a duplicate occurs, one is just dropped
355 - does not try to merge/aggregate 2 networks
356 - also reviewed logging with the hope to fix the sfa startup msg:
357 - TypeError: not all arguments converted during string formatting
358
359 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
360 - verify credentials against xsd schema
361 - Fix SM to SM communication
362 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
363 - new setting session_key_path
364
365 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
366 - fix registry credential regeneration and handle expiration
367 - support for setting slice tags (min_role=user)
368 - client can display its own version: sfi.py version --local
369 - GetVersion to provide urn in addition to hrn
370 - more code uses plxrn vs previous helper functions
371 - import replaces '+' in email addresses with '_'
372
373 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
374 - fix GetVersion code_tag and add code_url
375
376 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
377 - extend GetVersion towards minimum federation introspection, and expose local tag
378
379 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
380 - fixed some legacy issues (list vs List)
381 - deprecated sfa.util.namespace for xrn and plxrn
382 - unit tests ship as the sfa-tests rpm
383
384 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
385 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
386 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
387 - hrn-urn translations tweaked
388 - fixed 'service sfa status'
389 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
390 - started to repair sfadump - although not usable yet
391 - trust objects now have dump_string method that dump() actually prints
392 - unit tests under review
393 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
394 - binaries now support -v or -vv to increase loglevel
395 - trashed obsolete sfa.util.client
396
397 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
398 - various bugfixes and cleanup, improved/harmonized logging
399
400 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
401 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
402   to avoid returning a PLCAPI exception that might confuse users.
403 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
404 - fix build errors.  
405
406 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
407 - (Architecture) Credential format changed to match ProtoGENI xml format
408 - (Architecture) All interfaces export a new set of methods that are compatible
409    with the ProtoGeni Aggregate spec. These new methods are considered a 
410    replacement  for the pervious methods exported by the interfaces. All 
411    previous methods are still exported and work as normal, but they are 
412    considered deprecated and will not be supported in future releases.  
413 - (Architecture) SFI has been updated to use the new interface methods.
414 - (Architecture) Changed keyconvet implementation from c to python.
415 - (Architecture) Slice Manager now attempts looks for a delegated credential
416   provided by the client before using its own server credential.
417 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
418   This cache now exists only in memory and is cleared when service is restarted
419   or cache lifetime is exceeded.  
420 - (Performance) SliceManager sends request to Aggregates in parallel instead 
421   of sequentially.
422 - (Bug fix) SFA tickets now support the new rspec format.
423 - (Bug fix) SFI only uses cahced credential if they aren't expired.
424 - (Bug fix) Cerdential delegation modified to work with new credential format.
425 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
426   Aggregate instead of relaying through the Slice Manager.
427 - (Enhancement) Simplified caching. Accociated a global cache instance with
428   the api handler on every new server request, making it easier to access the 
429   cache and use in more general ways.     
430
431 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
432 - SfaServer now uses a pool of threads to handle requests concurrently
433 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
434 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
435 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
436 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
437 - Component manager does not install gid files if slice already has them  
438 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
439 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
440 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
441      
442 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
443 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
444 - - sfa-config-tty now has the same features like plc-config-tty
445 - - Contains code to support both urn and hrn
446 - - Cleaned up request_hash related stuff
447 - - SM, AM and Registry code is organized under respective managers
448 - - Site and Slice synchronization across federated aggregates
449 - - Script to generate sfa_component_config
450
451 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
452 - sfa-config-tty now has the same features like plc-config-tty
453 - Contains code to support both urn and hrn
454 - Cleaned up request_hash related stuff
455 - SM, AM and Registry code is organized under respective managers
456 - Slice synchronization across federated aggregates
457 - some bugs are fixed
458
459 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
460 - checkpoint with fewer mentions of geni
461
462 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
463 - checkpointing
464 - this is believed to pass the tests; among other things:
465 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
466
467 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
468 - This tag includes:
469 - - Sfatables
470 - - Preliminary version of hash based authentication
471 - - Initial code for Component Manager
472 - - Authority structure is moved to /var/lib/sfa/
473 - - some bug-fixes
474
475 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
476 - Create_slice and get_resources methods are connected to sfatables.
477 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
478
479 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
480 - Bug fix on update and remove_peer_object methods
481 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
482
483 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
484 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
485
486 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
487 - compatibility with RefreshPeer
488 - incremental mechanism for importing PLC records into SFA tables
489 - unified single database (still inside the underlying PLC db postgresql server)
490 - includes/improves call traceability and logging features
491 - several bug fixes
492
493 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
494 - added libxslt-python dependency
495
496 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
497 - unified single SFA database in the PLC-DB
498 - upcalls from  PLCAPI to SFA methods
499 - SFA call traceability and logging features
500 - many bug fixes
501 - includes first/rough version of sfatables for policy implementation
502
503 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
504 - snapshot after the GEC5 demo
505 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
506
507 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
508 - snapshot july 15 - has gone through superficial manual testing
509 - hopefully a good basis for gec5 demo
510 - multi-dir sfi client tested as well
511
512 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
513 - rename geniwrapper.spec into sfa.spec
514
515 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
516 - clean up in xmlrpc/soap, --protocol option to chose between both
517 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
518 - hopefully more helpful context in case of crashes when importing
519 - bugfixes for using only /etc/sfa for site-dep files
520 - bugfixes in wsdl generation
521
522 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
523 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
524 - config variables in sfa_config now start with SFA_ and not GENI_
525 - config.py can be loaded even with no config present
526
527 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
528 - first step for cleanup and reorganization
529 - mass-renaming from geni to sfa (some are still needed)
530 - sfa/trust implements the security architecture
531
532 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
533 - snapshot for reproducible builds
534
535 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
536 - snapshot for the convenience of alpha users
537
538 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
539 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
540
541 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
542 - ongoing work - snapshot for 4.3-rc9
543
544 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
545 - various fixes
546
547 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
548 - bugfixes - still a work in progress
549
550 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
551 - initial package
552
553
554 %define module_current_branch 0.2