6d028549563976ffccdfab5262f1405e13b6acdb
[sfa.git] / sfa.spec
1
2 #
3 # $Id$
4 #
5
6 %define url $URL$
7
8 %define name sfa
9 %define version 0.9
10 %define taglevel 2
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
15
16 Name: %{name}
17 Version: %{version}
18 Release: %{release}
19 Source0: %{name}-%{version}.tar.bz2
20 License: GPL
21 Group: Applications/System
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
23
24 Vendor: PlanetLab
25 Packager: PlanetLab Central <support@planet-lab.org>
26 Distribution: PlanetLab %{plrelease}
27 URL: %(echo %{url} | cut -d ' ' -f 2)
28 Summary: the SFA python libraries
29 Group: Applications/System
30
31 BuildRequires: make
32 Requires: python
33 Requires: pyOpenSSL >= 0.7
34 Requires: m2crypto
35 Requires: libxslt-python
36
37 # python 2.5 has uuid module added, for python 2.4 we still need it 
38 %define uuid_missing %(`python -c "import uuid" 2> /dev/null ; echo $?`)
39 %if uuid_missing
40 Requires: python-uuid
41 %endif
42
43 %package plc
44 Summary: the SFA wrapper arounf MyPLC
45 Group: Applications/System
46 Requires: sfa
47
48 %package client
49 Summary: the SFA experimenter-side CLI
50 Group: Applications/System
51 Requires: sfa
52
53 %description
54 This package provides the python libraries that the SFA implementation requires
55
56 %description plc
57 Geniwrapper implements the SFA interface which serves as a layer
58 between the existing PlanetLab interfaces and the SFA API.
59
60 %description client
61 This package provides the client side of the SFA API, in particular
62 sfi.py, together with other utilities.
63
64 %prep
65 %setup -q
66
67 %build
68 make
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 make install DESTDIR="$RPM_BUILD_ROOT"
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %{python_sitelib}/*
79 /usr/bin/keyconvert
80 /var/www/html/wsdl/*.wsdl
81
82 %files plc
83 %defattr(-,root,root)
84 %config (noreplace) /etc/sfa/sfa_config
85 %config (noreplace) /etc/sfa/aggregates.xml
86 %config (noreplace) /etc/sfa/registries.xml
87 /etc/init.d/sfa
88 %{_bindir}/sfa-config-tty
89 %{_bindir}/sfa-import-plc.py*
90 %{_bindir}/sfa-nuke-plc.py*
91 %{_bindir}/sfa-server.py*
92
93 %files client
94 %config (noreplace) /etc/sfa/sfi_config
95 %{_bindir}/sfi.py*
96 %{_bindir}/getNodes.py*
97 %{_bindir}/getRecord.py*
98 %{_bindir}/setRecord.py*
99 %{_bindir}/genidump.py*
100
101 %pre plc
102 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
103
104 %post plc
105 chkconfig --add sfa
106
107 %changelog
108 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
109 - compatibility with RefreshPeer
110 - incremental mechanism for importing PLC records into SFA tables
111 - unified single database (still inside the underlying PLC db postgresql server)
112 - includes/improves call traceability and logging features
113 - several bug fixes
114
115 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
116 - added libxslt-python dependency
117
118 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
119 - unified single SFA database in the PLC-DB
120 - upcalls from  PLCAPI to SFA methods
121 - SFA call traceability and logging features
122 - many bug fixes
123 - includes first/rough version of sfatables for policy implementation
124
125 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
126 - snapshot after the GEC5 demo
127 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
128
129 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
130 - snapshot july 15 - has gone through superficial manual testing
131 - hopefully a good basis for gec5 demo
132 - multi-dir sfi client tested as well
133
134 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
135 - rename geniwrapper.spec into sfa.spec
136
137 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
138 - clean up in xmlrpc/soap, --protocol option to chose between both
139 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
140 - hopefully more helpful context in case of crashes when importing
141 - bugfixes for using only /etc/sfa for site-dep files
142 - bugfixes in wsdl generation
143
144 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
145 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
146 - config variables in sfa_config now start with SFA_ and not GENI_
147 - config.py can be loaded even with no config present
148
149 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
150 - first step for cleanup and reorganization
151 - mass-renaming from geni to sfa (some are still needed)
152 - sfa/trust implements the security architecture
153
154 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
155 - snapshot for reproducible builds
156
157 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
158 - snapshot for the convenience of alpha users
159
160 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
161 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
162
163 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
164 - ongoing work - snapshot for 4.3-rc9
165
166 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
167 - various fixes
168
169 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
170 - bugfixes - still a work in progress
171
172 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
173 - initial package
174
175
176 %define module_current_branch 0.2