9d123a13367e160f2464d167489f4d8617e0f1ba
[sfa.git] / sfa.spec
1 %define name sfa
2 %define version 2.0
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
7 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8
9 Name: %{name}
10 Version: %{version}
11 Release: %{release}
12 Source0: %{name}-%{version}.tar.bz2
13 License: GPL
14 Group: Applications/System
15 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
16
17 # xxx TODO : package cron.d/
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 Summary: the SFA python libraries
25 Group: Applications/System
26 BuildRequires: make
27 Requires: python >= 2.5
28 Requires: m2crypto
29 Requires: xmlsec1-openssl-devel
30 Requires: libxslt-python
31 Requires: python-ZSI
32 # for uuidgen - used in db password generation
33 # on f8 this actually comes with e2fsprogs, go figure
34 Requires: util-linux-ng
35 # xmlbuilder depends on  lxml
36 Requires: python-lxml
37 Requires: python-setuptools
38 Requires: python-dateutil
39 # for the registry
40 Requires: postgresql >= 8.2, postgresql-server >= 8.2
41 Requires: postgresql-python
42 Requires: python-psycopg2
43 Requires: pyOpenSSL >= 0.7
44 Requires: myplc-config
45  
46 # python 2.5 has uuid module added, for python 2.4 we still need it.
47 # we can't really check for if we can load uuid as a python module,
48 # it'll be installed by "devel.pkgs". we have the epel repository so
49 # python-uuid will be provided. but we can test for the python
50 # version.
51 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
52 # %if %has_py24
53 #
54 # this also didn't work very well. I'll just check for distroname - baris
55 #%if %{distroname} == "centos5"
56 #Requires: python-uuid
57 #%endif
58
59 %package plc
60 Summary: the SFA layer around MyPLC
61 Group: Applications/System
62 Requires: sfa
63 Requires: python-psycopg2
64
65 %package client
66 Summary: the SFA experimenter-side CLI
67 Group: Applications/System
68 Requires: sfa
69 Requires: pyOpenSSL >= 0.7
70
71 %package sfatables
72 Summary: sfatables policy tool for SFA
73 Group: Applications/System
74 Requires: sfa
75
76 %package cm
77 Summary: the SFA layer around MyPLC NodeManager
78 Group: Applications/System
79 Requires: sfa
80 Requires: pyOpenSSL >= 0.6
81
82 %package flashpolicy
83 Summary: SFA support for flash clients
84 Group: Applications/System
85 Requires: sfa
86
87 %package tests
88 Summary: unit tests suite for SFA
89 Group: Applications/System
90 Requires: sfa
91
92 %description
93 This package provides the python libraries for the PlanetLab implementation of SFA
94
95 %description plc
96 This package implements the SFA interface which serves as a layer
97 between the existing PlanetLab interfaces and the SFA API.
98
99 %description client
100 This package provides the client side of the SFA API, in particular
101 sfi.py, together with other utilities.
102
103 %description sfatables
104 sfatables is a tool for defining access and admission control policies
105 in an SFA network, in much the same way as iptables is for ip
106 networks. This is the command line interface to manage sfatables
107
108 %description cm
109 This package implements the SFA interface which serves as a layer
110 between the existing PlanetLab NodeManager interfaces and the SFA API.
111  
112 %description flashpolicy
113 This package provides support for adobe flash client applications.  
114  
115 %description tests
116 Provides some binary unit tests in /usr/share/sfa/tests
117
118 %prep
119 %setup -q
120
121 %build
122 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}" install DESTDIR="$RPM_BUILD_ROOT"
127 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/*egg-info
128 # this gets duplicated
129 rm -rf $RPM_BUILD_ROOT/%{python_sitelib}/sfa/storage/sfa.sql
130 # create symlinks
131 (cd $RPM_BUILD_ROOT/%{_bindir}; ln -s sfi.py sfi; ln -s sfascan.py sfascan)
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 # sfa and sfatables depend on each other.
138 %{python_sitelib}/sfa
139 %{python_sitelib}/xmlbuilder
140 /etc/init.d/sfa
141 %{_bindir}/sfa-start.py*
142 %{_bindir}/keyconvert.py*
143 %{_bindir}/sfa-config-tty
144 %config /etc/sfa/default_config.xml
145 %config (noreplace) /etc/sfa/aggregates.xml
146 %config (noreplace) /etc/sfa/registries.xml
147 /usr/share/sfa/sfa.sql
148 /var/www/html/wsdl/*.wsdl
149
150 %files plc
151 %defattr(-,root,root)
152 /etc/sfa/pl.rng
153 /etc/sfa/credential.xsd
154 /etc/sfa/top.xsd
155 /etc/sfa/sig.xsd
156 /etc/sfa/xml.xsd
157 /etc/sfa/protogeni-rspec-common.xsd
158 /etc/sfa/topology
159 %{_bindir}/sfa-import-plc.py*
160 %{_bindir}/sfa-nuke-plc.py*
161 %{_bindir}/sfa-clean-peer-records.py*
162 %{_bindir}/gen-sfa-cm-config.py*
163 %{_bindir}/sfa-ca.py*
164
165 %files client
166 %config (noreplace) /etc/sfa/sfi_config
167 %{_bindir}/sfi*.py*
168 %{_bindir}/sfi
169 %{_bindir}/get*.py*
170 %{_bindir}/setRecord.py*
171 %{_bindir}/sfascan.py*
172 %{_bindir}/sfascan
173 %{_bindir}/sfadump.py*
174
175 %files sfatables
176 /etc/sfatables/*
177 %{_bindir}/sfatables
178 %{python_sitelib}/sfatables
179
180 %files cm
181 /etc/init.d/sfa-cm
182 %{_bindir}/sfa_component_setup.py*
183 # cron jobs here 
184
185 %files flashpolicy
186 %{_bindir}/sfa_flashpolicy.py*
187 /etc/sfa/sfa_flashpolicy_config.xml
188
189 %files tests
190 %{_datadir}/sfa/tests
191
192 ### sfa-plc installs the 'sfa' service
193 %post plc
194 chkconfig --add sfa
195
196 %preun plc
197 if [ "$1" = 0 ] ; then
198   /sbin/service sfa stop || :
199   /sbin/chkconfig --del sfa || :
200 fi
201
202 %postun plc
203 [ "$1" -ge "1" ] && service sfa restart
204
205 ### sfa-cm installs the 'sfa-cm' service
206 %post cm
207 chkconfig --add sfa-cm
208
209 %preun cm
210 if [ "$1" = 0 ] ; then
211    /sbin/service sfa-cm stop || :
212    /sbin/chkconfig --del sfa-cm || :
213 fi
214
215 %postun cm
216 [ "$1" -ge "1" ] && service sfa-cm restart || :
217
218 %changelog
219 * Tue Dec 06 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-2
220 - various fixes in rspecs for sfav1&slice tags
221 - uses 'geni_rspec_version' and not just 'rspec_version'
222 - example flavour for the max testbed
223 - embryo for an sfa client library
224 - topology.py moved into plc
225 - sql: table is named records; record_types are enforced
226 - sql: table creation cleaned up
227
228 * Wed Nov 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-2.0-1
229 - cleaned up all references to SFA_*_TYPE in config
230 - enable cache at the aggregate by default
231 - registry now uses the driver in a sensible way (see managers/driver.py)
232 - slice manager supports sfav1/pgv2 neighbours
233 - get_key renamed into get_key_from_incoming_ip
234 - new sfa.storage module for record/table and all db-related stuff
235 - db schema in sfa.storage.sfa.sql
236 - init.d and cron.d move one step up
237 - cleaned up rspec/ directory
238 - add deps to pyopenssl and myplc-config
239 - start support for new API (return value)
240 - plc.remoteshell removed, use plshell instead
241 - plshell uses a 'capability' auth method whenever possible
242 - various tweaks in rspec elements
243 - made dependency on sfatables softer
244
245 * Thu Nov 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-5
246 - sfa should now be started *before* the initial import
247 - sfa to use its own database (default sfa) - can run without myplc
248 - server calls support optional 'options'
249 - client sends options in argument when needed
250 - fix infinite getattr recursion in elements/element.py
251 - error codes in line with geni
252
253 * Fri Nov 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-4
254 - fixed links and attributes in rspecs
255 - minor cleanup in the API methods, and more consistent names in manager methods
256
257 * Thu Nov 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-3
258 - ongoing refoactoring towards more genericity
259 - passes tests again although known issues remain with attributes/tags
260
261 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-2
262 - checkpoint tag: use SFA_GENERIC_FLAVOUR instead of SFA_*_TYPE
263 - improvements in the pgv2 rspecs
264 - driver separated from api
265 - code starts moving around where it belongs
266 - sfascan caches getversion across invokations
267 - vini topology extracted as a config file
268
269 * Fri Oct 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.1-1
270 - first support for protogeni rspecs is working
271 - vini no longer needs a specific manager
272 - refactoring underway towards more flexible/generic architecture
273
274 * Thu Sep 15 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-36
275 - Unicode-friendliness for user names with accents/special chars.
276 - Fix bug that could cause create the client to fail when calling CreateSliver for a slice that has the same hrn as a user.
277 - CreaetSliver no longer fails for users that have a capital letter in their URN.
278 - Fix bug in CreateSliver that generated incorrect login bases and email addresses for ProtoGENI requests. 
279 - Allow files with .gid, .pem or .crt extension to be loaded into the server's list of trusted certs.
280 - Fix bugs and missing imports     
281  
282
283 * Tue Aug 30 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-35
284 - new method record.get_field for sface
285
286 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-34
287 - new option -c to sfa-nuke-plc.py
288 - CreateSliver fixed for admin-only slice tags
289
290 * Wed Aug 24 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
291 - Fixed exploit that allowed an authorities to issue certs for objects that dont belong to them.
292 - Fixed holes in certificate verification logic.
293 - Aggregates no longer try to lookup slice and person records when processing CreateSliver requests. Clients are now required to specify this info in the 'users' argument. 
294 - Added 'boot_state' as an attribute of the node element in SFA rspec.
295 - Non authority certificates are marked as CA:FALSE.
296
297 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-32
298 - fix typo in sfa-1.0-31 tag.
299 - added CreateGid() Registry interface method.
300
301 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-31
302 - fix typo in sfa-1.0-30 tag
303
304 * Tue Aug 16 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-30
305 - Declare namespace and schema location in the credential.
306 - Fix bug that prevetend connections from timing out.
307 - Fix slice delegation.
308 - Add statistics to slicemaanger listresources/createsliver rspec.
309 - Added SFA_MAX_SLICE_RENEW which allows operators to configure the max ammout
310   of days a user can extend their slice expiration.
311 - CA certs are only issued to objects of type authority
312    
313 * Fri Aug 05 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-29
314 - tag 1.0-28 was broken due to typo in the changelog
315 - new class sfa/util/httpsProtocol.py that supports timeouts
316
317 * Thu Aug 4 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-28
318 - Resolved issue that caused sfa hold onto idle db connections.
319 - Fix bug that caused the registry to use the wrong type of credential.
320 - Support authority+sm type.
321 - Fix rspec merging bugs.
322 - Only load certs that have .gid extension from /etc/sfa/trusted_roots/
323 - Created a 'planetlab' extension to the ProtoGENI v2 rspec for supporting 
324  planetlab hosted initscripts using the <planetlab:initscript> tag  
325 - Can now handle extraneous whitespace in the rspec without failing.   
326  
327 * Fri Jul 8 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-27
328 - ProtoGENI v2 RSpec updates.
329 - Convert expiration timestamps with timezone info in credentials to utc.
330 - Fixed redundant logging issue. 
331 - Improved SliceManager and SFI client logging.
332 - Support aggregates that don't support the optional 'call_id' argument. 
333 - Only call get_trusted_certs() at aggreage interfaces that support the call.
334 - CreateSliver() now handles MyPLC slice attributes/tags.
335 - Cache now supports persistence.
336 - Hide whitelisted nodes.
337
338 * Tue Jun 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-26
339 - fixed issues with sup authority signing
340 - fixed bugs in remove_slivers and SliverStatus
341
342 * Thu Jun 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-25
343 - fix typo that prevented aggregates from operating properly
344
345 * Tue Jun 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-24
346 - load trusted certs into ssl context prior to handshake
347 - client's logfile lives in ~/.sfi/sfi.log
348
349 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-23
350 - includes a change on passphrases that was intended in 1.0-22
351
352 * Thu Jun 6 2011 Tony Mack <tmack@cs.princeton.edu> - sfa-1.0-22
353 - Added support for ProtoGENI RSpec v2
354  
355 * Wed Mar 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-21
356 - stable sfascan
357 - fix in initscript, *ENABLED tags in config now taken into account
358
359 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-20
360 - some commits had not been pushed in tag 19
361
362 * Fri Mar 11 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-19
363 - GetVersion should now report full URLs with path
364 - scansfa has nicer output and new syntax (entry URLs as args and not options)
365 - dos2unix'ed flash policy pill
366
367 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-18
368 - fix packaging again for f8
369
370 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-17
371 - fix packaging (apparently broken in 1.0-16)
372 - first working version of sfascan
373 - tweaks in GetVersion for exposing hrn(AM) and full set of aggregates(SM)
374 - deprecated the sfa_geni_aggregate config category
375
376 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-16
377 - Fix build problem
378 - First version of SFA scanner
379
380 * Mon Mar 07 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-15
381 - Add support for Flash clients using flashpolicy
382 - Fix problems with tag handling in RSpec
383
384 * Wed Mar 02 2011 Andy Bavier <acb@cs.princeton.edu> - sfa-1.0-14
385 - Modifications to the Eucalyptus Aggregate Manager
386 - Fixes for VINI RSpec
387 - Fix tag handling for PL RSpec
388 - Fix XML Schema ordering for <urn> element
389
390 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-13
391 - just set x509 version to 2
392
393 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-12
394 - added urn to the node area in rspecs
395 - conversion to urn now exports fqdn
396 - sfa-import-plc.py now creates a unique registry record for each SFA interface
397
398 * Thu Dec 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-11
399 - undo broken attempt for python-2.7
400
401 * Wed Dec 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-10
402 - SMs avoid duplicates for when call graph has dags;
403 - just based on network's name, when a duplicate occurs, one is just dropped
404 - does not try to merge/aggregate 2 networks
405 - also reviewed logging with the hope to fix the sfa startup msg:
406 - TypeError: not all arguments converted during string formatting
407
408 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-9
409 - verify credentials against xsd schema
410 - Fix SM to SM communication
411 - Fix bug in sfa.util.sfalogging, sfa-import.py now logs to sfa_import.log
412 - new setting session_key_path
413
414 * Tue Nov 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-8
415 - fix registry credential regeneration and handle expiration
416 - support for setting slice tags (min_role=user)
417 - client can display its own version: sfi.py version --local
418 - GetVersion to provide urn in addition to hrn
419 - more code uses plxrn vs previous helper functions
420 - import replaces '+' in email addresses with '_'
421
422 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-7
423 - fix GetVersion code_tag and add code_url
424
425 * Fri Oct 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-6
426 - extend GetVersion towards minimum federation introspection, and expose local tag
427
428 * Wed Oct 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-5
429 - fixed some legacy issues (list vs List)
430 - deprecated sfa.util.namespace for xrn and plxrn
431 - unit tests ship as the sfa-tests rpm
432
433 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
434 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
435 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
436 - hrn-urn translations tweaked
437 - fixed 'service sfa status'
438 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
439 - started to repair sfadump - although not usable yet
440 - trust objects now have dump_string method that dump() actually prints
441 - unit tests under review
442 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
443 - binaries now support -v or -vv to increase loglevel
444 - trashed obsolete sfa.util.client
445
446 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
447 - various bugfixes and cleanup, improved/harmonized logging
448
449 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
450 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
451   to avoid returning a PLCAPI exception that might confuse users.
452 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
453 - fix build errors.  
454
455 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
456 - (Architecture) Credential format changed to match ProtoGENI xml format
457 - (Architecture) All interfaces export a new set of methods that are compatible
458    with the ProtoGeni Aggregate spec. These new methods are considered a 
459    replacement  for the pervious methods exported by the interfaces. All 
460    previous methods are still exported and work as normal, but they are 
461    considered deprecated and will not be supported in future releases.  
462 - (Architecture) SFI has been updated to use the new interface methods.
463 - (Architecture) Changed keyconvet implementation from c to python.
464 - (Architecture) Slice Manager now attempts looks for a delegated credential
465   provided by the client before using its own server credential.
466 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
467   This cache now exists only in memory and is cleared when service is restarted
468   or cache lifetime is exceeded.  
469 - (Performance) SliceManager sends request to Aggregates in parallel instead 
470   of sequentially.
471 - (Bug fix) SFA tickets now support the new rspec format.
472 - (Bug fix) SFI only uses cahced credential if they aren't expired.
473 - (Bug fix) Cerdential delegation modified to work with new credential format.
474 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
475   Aggregate instead of relaying through the Slice Manager.
476 - (Enhancement) Simplified caching. Accociated a global cache instance with
477   the api handler on every new server request, making it easier to access the 
478   cache and use in more general ways.     
479
480 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
481 - SfaServer now uses a pool of threads to handle requests concurrently
482 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
483 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
484 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
485 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
486 - Component manager does not install gid files if slice already has them  
487 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
488 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
489 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
490      
491 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
492 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
493 - - sfa-config-tty now has the same features like plc-config-tty
494 - - Contains code to support both urn and hrn
495 - - Cleaned up request_hash related stuff
496 - - SM, AM and Registry code is organized under respective managers
497 - - Site and Slice synchronization across federated aggregates
498 - - Script to generate sfa_component_config
499
500 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
501 - sfa-config-tty now has the same features like plc-config-tty
502 - Contains code to support both urn and hrn
503 - Cleaned up request_hash related stuff
504 - SM, AM and Registry code is organized under respective managers
505 - Slice synchronization across federated aggregates
506 - some bugs are fixed
507
508 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
509 - checkpoint with fewer mentions of geni
510
511 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
512 - checkpointing
513 - this is believed to pass the tests; among other things:
514 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
515
516 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
517 - This tag includes:
518 - - Sfatables
519 - - Preliminary version of hash based authentication
520 - - Initial code for Component Manager
521 - - Authority structure is moved to /var/lib/sfa/
522 - - some bug-fixes
523
524 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
525 - Create_slice and get_resources methods are connected to sfatables.
526 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
527
528 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
529 - Bug fix on update and remove_peer_object methods
530 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
531
532 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
533 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
534
535 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
536 - compatibility with RefreshPeer
537 - incremental mechanism for importing PLC records into SFA tables
538 - unified single database (still inside the underlying PLC db postgresql server)
539 - includes/improves call traceability and logging features
540 - several bug fixes
541
542 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
543 - added libxslt-python dependency
544
545 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
546 - unified single SFA database in the PLC-DB
547 - upcalls from  PLCAPI to SFA methods
548 - SFA call traceability and logging features
549 - many bug fixes
550 - includes first/rough version of sfatables for policy implementation
551
552 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
553 - snapshot after the GEC5 demo
554 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
555
556 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
557 - snapshot july 15 - has gone through superficial manual testing
558 - hopefully a good basis for gec5 demo
559 - multi-dir sfi client tested as well
560
561 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
562 - rename geniwrapper.spec into sfa.spec
563
564 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
565 - clean up in xmlrpc/soap, --protocol option to chose between both
566 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
567 - hopefully more helpful context in case of crashes when importing
568 - bugfixes for using only /etc/sfa for site-dep files
569 - bugfixes in wsdl generation
570
571 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
572 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
573 - config variables in sfa_config now start with SFA_ and not GENI_
574 - config.py can be loaded even with no config present
575
576 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
577 - first step for cleanup and reorganization
578 - mass-renaming from geni to sfa (some are still needed)
579 - sfa/trust implements the security architecture
580
581 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
582 - snapshot for reproducible builds
583
584 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
585 - snapshot for the convenience of alpha users
586
587 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
588 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
589
590 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
591 - ongoing work - snapshot for 4.3-rc9
592
593 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
594 - various fixes
595
596 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
597 - bugfixes - still a work in progress
598
599 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
600 - initial package
601
602
603 %define module_current_branch 0.2