c11fa2387a11bd702200505d1ba15468ed63cbd1
[sfa.git] / sfa.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name sfa
8 %define version 1.0
9 %define taglevel 5
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27 Summary: the SFA python libraries
28 Group: Applications/System
29
30 BuildRequires: make
31 Requires: python >= 2.5
32 Requires: m2crypto
33 Requires: xmlsec1-openssl-devel
34 Requires: libxslt-python
35 Requires: python-ZSI
36 # xmlbuilder depends on  lxml
37 Requires: python-lxml
38 Requires: python-setuptools
39 Requires: python-dateutil
40  
41 # python 2.5 has uuid module added, for python 2.4 we still need it.
42 # we can't really check for if we can load uuid as a python module,
43 # it'll be installed by "devel.pkgs". we have the epel repository so
44 # python-uuid will be provided. but we can test for the python
45 # version.
46 # %define has_py24 %( python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $? )
47 # %if %has_py24
48 #
49 # this also didn't work very well. I'll just check for distroname - baris
50 #%if %{distroname} == "centos5"
51 #Requires: python-uuid
52 #%endif
53
54 %package cm
55 Summary: the SFA wrapper around MyPLC's NodeManager
56 Group: Applications/System
57 Requires: sfa
58 Requires: pyOpenSSL >= 0.6
59
60 %package plc
61 Summary: the SFA wrapper arounf MyPLC
62 Group: Applications/System
63 Requires: sfa
64 Requires: python-psycopg2
65 Requires: myplc-config
66 Requires: pyOpenSSL >= 0.7
67
68 %package client
69 Summary: the SFA experimenter-side CLI
70 Group: Applications/System
71 Requires: sfa
72 Requires: pyOpenSSL >= 0.7
73
74 %package sfatables
75 Summary: sfatables policy tool for SFA
76 Group: Applications/System
77 Requires: sfa
78
79 %description
80 This package provides the python libraries that the SFA implementation requires
81
82 %description cm
83 This package implements the SFA interface which serves as a layer
84 between the existing PlanetLab NodeManager interfaces and the SFA API.
85  
86 %description plc
87 This package implements the SFA interface which serves as a layer
88 between the existing PlanetLab interfaces and the SFA API.
89
90 %description client
91 This package provides the client side of the SFA API, in particular
92 sfi.py, together with other utilities.
93
94 %description sfatables
95 sfatables is a tool for defining access and admission control policies
96 in an SFA network, in much the same way as iptables is for ip
97 networks. This is the command line interface to manage sfatables
98
99 %prep
100 %setup -q
101
102 %build
103 make
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 make install DESTDIR="$RPM_BUILD_ROOT"
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 # sfa and sfatables depend each other.
114 %{_bindir}/sfa-server.py*
115 /etc/sfatables/*
116 %{python_sitelib}/*
117 %{_bindir}/keyconvert.py*
118 /var/www/html/wsdl/*.wsdl
119
120 %files cm
121 /etc/init.d/sfa-cm
122 %{_bindir}/sfa_component_setup.py*
123 # cron jobs here 
124
125 %files plc
126 %defattr(-,root,root)
127 %config /etc/sfa/default_config.xml
128 %config (noreplace) /etc/sfa/aggregates.xml
129 %config (noreplace) /etc/sfa/registries.xml
130 /etc/init.d/sfa
131 /etc/sfa/pl.rng
132 %{_bindir}/sfa-config-tty
133 %{_bindir}/sfa-import-plc.py*
134 %{_bindir}/sfa-clean-peer-records.py*
135 %{_bindir}/sfa-nuke-plc.py*
136 %{_bindir}/gen-sfa-cm-config.py*
137 %{_bindir}/sfa-ca.py*
138
139 %files client
140 %config (noreplace) /etc/sfa/sfi_config
141 %{_bindir}/sfi*
142 %{_bindir}/getNodes.py*
143 %{_bindir}/getRecord.py*
144 %{_bindir}/setRecord.py*
145 %{_bindir}/sfadump.py*
146
147 %files sfatables
148 %{_bindir}/sfatables
149
150 ### sfa-plc installs the 'sfa' service
151 %post plc
152 chkconfig --add sfa
153
154 %preun plc
155 if [ "$1" = 0 ] ; then
156   /sbin/service sfa stop || :
157   /sbin/chkconfig --del sfa || :
158 fi
159
160 %postun plc
161 [ "$1" -ge "1" ] && service sfa restart
162
163 ### sfa-cm installs the 'sfa-cm' service
164 %post cm
165 chkconfig --add sfa-cm
166
167 %preun cm
168 if [ "$1" = 0 ] ; then
169    /sbin/service sfa-cm stop || :
170    /sbin/chkconfig --del sfa-cm || :
171 fi
172
173 %postun cm
174 [ "$1" -ge "1" ] && service sfa-cm restart
175
176
177 %changelog
178 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
179 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
180 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
181 - hrn-urn translations tweaked
182 - fixed 'service sfa status'
183 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
184 - started to repair sfadump - although not usable yet
185 - trust objects now have dump_string method that dump() actually prints
186 - unit tests under review
187 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
188 - binaries now support -v or -vv to increase loglevel
189 - trashed obsolete sfa.util.client
190
191 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
192 - various bugfixes and cleanup, improved/harmonized logging
193
194 * Tue Sep 07 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-16
195 - truncate login base of external (ProtoGeni, etc) slices to 20 characters
196   to avoid returning a PLCAPI exception that might confuse users.
197 - Enhance PLC aggregate performace by using a better filter when querying SliceTags.      
198 - fix build errors.  
199
200 * Tue Aug 24 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-15
201 - (Architecture) Credential format changed to match ProtoGENI xml format
202 - (Architecture) All interfaces export a new set of methods that are compatible
203    with the ProtoGeni Aggregate spec. These new methods are considered a 
204    replacement  for the pervious methods exported by the interfaces. All 
205    previous methods are still exported and work as normal, but they are 
206    considered deprecated and will not be supported in future releases.  
207 - (Architecture) SFI has been updated to use the new interface methods.
208 - (Architecture) Changed keyconvet implementation from c to python.
209 - (Architecture) Slice Manager now attempts looks for a delegated credential
210   provided by the client before using its own server credential.
211 - (Archiceture) Slice Interface no longers stores cache of resources on disk. 
212   This cache now exists only in memory and is cleared when service is restarted
213   or cache lifetime is exceeded.  
214 - (Performance) SliceManager sends request to Aggregates in parallel instead 
215   of sequentially.
216 - (Bug fix) SFA tickets now support the new rspec format.
217 - (Bug fix) SFI only uses cahced credential if they aren't expired.
218 - (Bug fix) Cerdential delegation modified to work with new credential format.
219 - (Enhancement) SFI -a --aggregatge option now sends requests directly to the
220   Aggregate instead of relaying through the Slice Manager.
221 - (Enhancement) Simplified caching. Accociated a global cache instance with
222   the api handler on every new server request, making it easier to access the 
223   cache and use in more general ways.     
224
225 %changelog
226 * Mon Oct 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-2
227 - deprecated old methods (e.g. List/list, and GetCredential/get_credential)
228 - NOTE:  get_(self_)credential both have type and hrn swapped when moving to Get(Self)Credential
229 - hrn-urn translations tweaked
230 - fixed 'service sfa status'
231 - sfa-nuke-plc has a -f/--file-system option to clean up /var/lib/authorities (exp.)
232 - started to repair sfadump - although not usable yet
233 - trust objects now have dump_string method that dump() actually prints
234 - unit tests under review
235 - logging cleanup ongoing (always safe to use sfalogging.sfa_logger())
236 - binaries now support -v or -vv to increase loglevel
237 - trashed obsolete sfa.util.client
238
239 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-1.0-1
240 - various bugfixes and cleanup, improved/harmonized logging
241
242 * Thu May 11 2010 Tony Mack <tmack@cs.princeton.edu> - sfa-0.9-11
243 - SfaServer now uses a pool of threads to handle requests concurrently
244 - sfa.util.rspec no longer used to process/manage rspecs (deprecated). This is now handled by sfa.plc.network and is not backwards compatible
245 - PIs can now get a slice credential for any slice at their site without having to be a member of the slice
246 - Registry records for federated peers (defined in registries.xml, aggregates.xml) updated when sfa service is started
247 - Interfaces will try to fetch and install gids from peers listed in registries.xml/aggregates.xml if gid is not found in /etc/sfa/trusted_roots dir   
248 - Component manager does not install gid files if slice already has them  
249 - Server automatically fetches and installs peer certificats (defined in registries/aggregates.xml) when service is restarted.
250 - fix credential verification exploit (verify that the trusted signer is a parent of the object it it signed)
251 - made it easier for root authorities to sign their sub's certifiacate using the sfa-ca.py (sfa/server/sfa-ca.py) tool
252      
253 * Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
254 - This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
255 - - sfa-config-tty now has the same features like plc-config-tty
256 - - Contains code to support both urn and hrn
257 - - Cleaned up request_hash related stuff
258 - - SM, AM and Registry code is organized under respective managers
259 - - Site and Slice synchronization across federated aggregates
260 - - Script to generate sfa_component_config
261
262 * Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
263 - sfa-config-tty now has the same features like plc-config-tty
264 - Contains code to support both urn and hrn
265 - Cleaned up request_hash related stuff
266 - SM, AM and Registry code is organized under respective managers
267 - Slice synchronization across federated aggregates
268 - some bugs are fixed
269
270 * Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
271 - checkpoint with fewer mentions of geni
272
273 * Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
274 - checkpointing
275 - this is believed to pass the tests; among other things:
276 - reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
277
278 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
279 - This tag includes:
280 - - Sfatables
281 - - Preliminary version of hash based authentication
282 - - Initial code for Component Manager
283 - - Authority structure is moved to /var/lib/sfa/
284 - - some bug-fixes
285
286 * Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
287 - Create_slice and get_resources methods are connected to sfatables.
288 - Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
289
290 * Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
291 - Bug fix on update and remove_peer_object methods
292 - Compatibility with RP, preliminiary version of sfatables, call tracability and logging
293
294 * Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
295 - Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
296
297 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
298 - compatibility with RefreshPeer
299 - incremental mechanism for importing PLC records into SFA tables
300 - unified single database (still inside the underlying PLC db postgresql server)
301 - includes/improves call traceability and logging features
302 - several bug fixes
303
304 * Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
305 - added libxslt-python dependency
306
307 * Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
308 - unified single SFA database in the PLC-DB
309 - upcalls from  PLCAPI to SFA methods
310 - SFA call traceability and logging features
311 - many bug fixes
312 - includes first/rough version of sfatables for policy implementation
313
314 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
315 - snapshot after the GEC5 demo
316 - should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
317
318 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
319 - snapshot july 15 - has gone through superficial manual testing
320 - hopefully a good basis for gec5 demo
321 - multi-dir sfi client tested as well
322
323 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
324 - rename geniwrapper.spec into sfa.spec
325
326 * Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
327 - clean up in xmlrpc/soap, --protocol option to chose between both
328 - keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
329 - hopefully more helpful context in case of crashes when importing
330 - bugfixes for using only /etc/sfa for site-dep files
331 - bugfixes in wsdl generation
332
333 * Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
334 - cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
335 - config variables in sfa_config now start with SFA_ and not GENI_
336 - config.py can be loaded even with no config present
337
338 * Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
339 - first step for cleanup and reorganization
340 - mass-renaming from geni to sfa (some are still needed)
341 - sfa/trust implements the security architecture
342
343 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
344 - snapshot for reproducible builds
345
346 * Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
347 - snapshot for the convenience of alpha users
348
349 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
350 - build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
351
352 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
353 - ongoing work - snapshot for 4.3-rc9
354
355 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
356 - various fixes
357
358 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
359 - bugfixes - still a work in progress
360
361 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
362 - initial package
363
364
365 %define module_current_branch 0.2