install keyconvert to /usr/bin
[sfa.git] / geniwrapper.spec
index ae1935c..161040e 100644 (file)
@@ -2,7 +2,7 @@
 
 %define name sfa
 %define version 0.8
-%define taglevel 0
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -26,28 +26,28 @@ Requires: python
 Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 
-Summary: the GENI python libraries
+Summary: the SFA python libraries
 Group: Applications/System
 
 %package plc
-Summary: the GENI wrapper arounf MyPLC
+Summary: the SFA wrapper arounf MyPLC
 Group: Applications/System
 Requires: sfa
 
 %package client
-Summary: the GENI experimenter-side CLI
+Summary: the SFA experimenter-side CLI
 Group: Applications/System
 Requires: sfa
 
 %description
-This package provides the python libraries that the Geni implementation requires
+This package provides the python libraries that the SFA implementation requires
 
 %description plc
-Geniwrapper implements the Geni interface which serves as a layer
-between the existing PlanetLab interfaces and the Geni API.
+Geniwrapper implements the SFA interface which serves as a layer
+between the existing PlanetLab interfaces and the SFA API.
 
 %description client
-This package provides the client side of the Geni API, in particular
+This package provides the client side of the SFA API, in particular
 sfi.py, together with other utilities.
 
 %prep
@@ -65,31 +65,44 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %{python_sitelib}/*
-/usr/share/keyconvert/
+/usr/bin/keyconvert
 /var/www/html/wsdl/sfa.wsdl
 
 %files plc
 %defattr(-,root,root)
-%config (noreplace) /etc/geni/sfa_config
-%config (noreplace) /etc/geni/aggregates.xml
-%config (noreplace) /etc/geni/registries.xml
+%config (noreplace) /etc/sfa/sfa_config
+%config (noreplace) /etc/sfa/aggregates.xml
+%config (noreplace) /etc/sfa/registries.xml
 /etc/init.d/sfa
 %{_bindir}/sfa-config-tty
-%{_bindir}/gimport.py*
-%{_bindir}/plc.py*
+%{_bindir}/sfa-import-plc.py*
+%{_bindir}/sfa-server.py*
 
 %files client
-%config (noreplace) /etc/geni/sfi_config
+%config (noreplace) /etc/sfa/sfi_config
 %{_bindir}/sfi.py*
 %{_bindir}/getNodes.py*
 %{_bindir}/getRecord.py*
 %{_bindir}/setRecord.py*
 %{_bindir}/genidump.py*
 
+%pre plc
+[ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
+
 %post plc
-chkconfig --add geni
+chkconfig --add sfa
 
 %changelog
+* Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
+- cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
+- config variables in sfa_config now start with SFA_ and not GENI_
+- config.py can be loaded even with no config present
+
+* Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
+- first step for cleanup and reorganization
+- mass-renaming from geni to sfa (some are still needed)
+- sfa/trust implements the security architecture
+
 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
 - snapshot for reproducible builds