install keyconvert to /usr/bin
[sfa.git] / geniwrapper.spec
index f468c40..161040e 100644 (file)
@@ -1,12 +1,12 @@
-
 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
 
-%define name geniwrapper
+%define name sfa
 %define version 0.8
-%define taglevel 0
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
 Name: %{name}
 Version: %{version}
@@ -26,12 +26,29 @@ Requires: python
 Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 
+Summary: the SFA python libraries
+Group: Applications/System
+
+%package plc
+Summary: the SFA wrapper arounf MyPLC
+Group: Applications/System
+Requires: sfa
 
-Summary: Geniwrapper
+%package client
+Summary: the SFA experimenter-side CLI
 Group: Applications/System
+Requires: sfa
 
 %description
-Geniwrapper description...
+This package provides the python libraries that the SFA implementation requires
+
+%description plc
+Geniwrapper implements the SFA interface which serves as a layer
+between the existing PlanetLab interfaces and the SFA API.
+
+%description client
+This package provides the client side of the SFA API, in particular
+sfi.py, together with other utilities.
 
 %prep
 %setup -q
@@ -43,24 +60,49 @@ make
 rm -rf $RPM_BUILD_ROOT
 make install DESTDIR="$RPM_BUILD_ROOT"
 
-# hack to add installed files to the package
-python -c "print '\n'.join(['%s*'%i.strip() for i in open('GENI_INSTALLED_FILES').readlines() if not i.strip().endswith('.pyc')])" |uniq > GENI_INSTALLED_FILES.all
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files -f GENI_INSTALLED_FILES.all
-%defattr(-,root,root)
-/usr/share/keyconvert
-%config (noreplace) /etc/geni/geni_config
-%config (noreplace) /etc/geni/sfi_config
-%config (noreplace) /etc/geni/aggregates.xml
-%config (noreplace) /etc/geni/registries.xml
+%files
+%{python_sitelib}/*
+/usr/bin/keyconvert
+/var/www/html/wsdl/sfa.wsdl
 
-%post
-chkconfig --add geni
+%files plc
+%defattr(-,root,root)
+%config (noreplace) /etc/sfa/sfa_config
+%config (noreplace) /etc/sfa/aggregates.xml
+%config (noreplace) /etc/sfa/registries.xml
+/etc/init.d/sfa
+%{_bindir}/sfa-config-tty
+%{_bindir}/sfa-import-plc.py*
+%{_bindir}/sfa-server.py*
+
+%files client
+%config (noreplace) /etc/sfa/sfi_config
+%{_bindir}/sfi.py*
+%{_bindir}/getNodes.py*
+%{_bindir}/getRecord.py*
+%{_bindir}/setRecord.py*
+%{_bindir}/genidump.py*
+
+%pre plc
+[ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
+
+%post plc
+chkconfig --add sfa
 
 %changelog
+* Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
+- cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
+- config variables in sfa_config now start with SFA_ and not GENI_
+- config.py can be loaded even with no config present
+
+* Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
+- first step for cleanup and reorganization
+- mass-renaming from geni to sfa (some are still needed)
+- sfa/trust implements the security architecture
+
 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
 - snapshot for reproducible builds