renaming the toplevel geni/ package into sfa/
[sfa.git] / geniwrapper.spec
index ac58e96..f7f352b 100644 (file)
@@ -1,12 +1,12 @@
-
 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
 
-%define name geniwrapper
-%define version 0.2
-%define taglevel 1
+%define name sfa
+%define version 0.8
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
 Name: %{name}
 Version: %{version}
@@ -26,12 +26,29 @@ Requires: python
 Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 
+Summary: the SFA python libraries
+Group: Applications/System
 
-Summary: Geniwrapper
+%package plc
+Summary: the SFA wrapper arounf MyPLC
 Group: Applications/System
+Requires: sfa
+
+%package client
+Summary: the SFA experimenter-side CLI
+Group: Applications/System
+Requires: sfa
 
 %description
-Geniwrapper description...
+This package provides the python libraries that the SFA implementation requires
+
+%description plc
+Geniwrapper implements the SFA interface which serves as a layer
+between the existing PlanetLab interfaces and the SFA API.
+
+%description client
+This package provides the client side of the SFA API, in particular
+sfi.py, together with other utilities.
 
 %prep
 %setup -q
@@ -43,21 +60,56 @@ make
 rm -rf $RPM_BUILD_ROOT
 make install DESTDIR="$RPM_BUILD_ROOT"
 
-# hack to add installed files to the package
-python -c "print '\n'.join(['%s*'%i.strip() for i in open('GENI_INSTALLED_FILES').readlines() if not i.strip().endswith('.pyc')])" |uniq > GENI_INSTALLED_FILES.all
-
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files -f GENI_INSTALLED_FILES.all
-%defattr(-,root,root)
-/usr/share/keyconvert
+%files
+%{python_sitelib}/*
+/usr/share/keyconvert/
+/var/www/html/wsdl/sfa.wsdl
 
-%post
-chmod 0744 /etc/init.d/geniwrapper
+%files plc
+%defattr(-,root,root)
+%config (noreplace) /etc/sfa/sfa_config
+%config (noreplace) /etc/sfa/aggregates.xml
+%config (noreplace) /etc/sfa/registries.xml
+/etc/init.d/sfa
+%{_bindir}/sfa-config-tty
+%{_bindir}/sfa-import-plc.py*
+%{_bindir}/sfa-server.py*
+
+%files client
+%config (noreplace) /etc/sfa/sfi_config
+%{_bindir}/sfi.py*
+%{_bindir}/getNodes.py*
+%{_bindir}/getRecord.py*
+%{_bindir}/setRecord.py*
+%{_bindir}/genidump.py*
+
+%post plc
+chkconfig --add sfa
 
 %changelog
+* Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
+- snapshot for reproducible builds
+
+* Thu Jun 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-6
+- snapshot for the convenience of alpha users
+
+* Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-5
+- build fix - keyconvert was getting installed in /usr/share/keyconvert/keyconvert
+
+* Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-4
+- ongoing work - snapshot for 4.3-rc9
+
+* Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-3
+- various fixes
+
+* Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-2
+- bugfixes - still a work in progress
+
 * Fri May 18 2009 Baris Metin <tmetin@sophia.inria.fr>
 - initial package
 
+
+%define module_current_branch 0.2