another pass onf shebangs
[sfa.git] / sfa.spec
index 41318d3..519e381 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -1,6 +1,6 @@
 %define name sfa
-%define version 4.0
-%define taglevel 2
+%define version 5.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -29,27 +29,27 @@ BuildRequires: make
 Requires: util-linux-ng
 # for the registry
 Requires: postgresql >= 8.2, postgresql-server >= 8.2
-Requires: postgresql-python
-Requires: python2-psycopg2
-Requires: python2-sqlalchemy
-Requires: python2-migrate
+Requires: python3-pygresql
+Requires: python3-psycopg2
+Requires: python3-sqlalchemy
+Requires: python3-migrate
 # and of course the bulk of it
 Requires: sfa-common
 
 %package common
 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
 Group: Applications/System
-Requires: python
-Requires: pyOpenSSL
-Requires: m2crypto
-Requires: python2-dateutil
-Requires: python2-lxml
-%if "%{distro}" == "Fedora" && "%{distrorelease}" <= "27"
-Requires: python-ZSI
-%else
-Requires: python2-zsi
-%endif
-Requires: libxslt-python
+Requires: python3
+Requires: python3-pyOpenSSL
+Requires: python3-m2crypto
+Requires: python3-dateutil
+Requires: python3-lxml
+%if "%{distro}" == "Fedora" && "%{distrorelease}" <= "27"
+Requires: python-ZSI
+%else
+Requires: python2-zsi
+%endif
+Requires: libxslt-python
 Requires: xmlsec1-openssl-devel
 
 %package client
@@ -141,7 +141,6 @@ rm -rf $RPM_BUILD_ROOT
 %config (noreplace) /etc/sfa/api_versions.xml
 /usr/share/sfa/migrations
 /usr/share/sfa/examples
-/var/www/html/wsdl/*.wsdl
 
 %files common
 %{python_sitelib}/sfa/__init__.py*
@@ -218,6 +217,9 @@ fi
 true
 
 %changelog
+* Fri Mar 29 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - sfa-5.0-0
+- ported to python3 - no other change
+
 * Mon Jan 07 2019 Thierry <Parmentelat> - sfa-4.0-2
 - have shebangs mention python2 since it is what this version runs on
 - use rpm names in python2-something for expressing dependencies