more package names in python2-
[sfa.git] / sfa.spec
index 7882869..65c3190 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -24,31 +24,32 @@ URL: %{SCMURL}
 Summary: Server-side for SFA, generic implementation derived from PlanetLab
 Group: Applications/System
 BuildRequires: make
-BuildRequires: python-setuptools
 
+# for uuidgen - used in db password generation
+Requires: util-linux-ng
 # for the registry
 Requires: postgresql >= 8.2, postgresql-server >= 8.2
 Requires: postgresql-python
-Requires: python-psycopg2
-# f8=0.4 - f12=0.5 f14=0.6 f16=0.7
-Requires: python-sqlalchemy
-Requires: python-migrate
-# for uuidgen - used in db password generation
-# on f8 this actually comes with e2fsprogs, go figure
-Requires: util-linux-ng
-# and the SFA libraries of course
+Requires: python2-psycopg2
+Requires: python2-sqlalchemy
+Requires: python2-migrate
+# and of course the bulk of it
 Requires: sfa-common
 
 %package common
 Summary: Python libraries for SFA, generic implementation derived from PlanetLab
 Group: Applications/System
-Requires: python >= 2.7
-Requires: pyOpenSSL >= 0.7
+Requires: python
+Requires: pyOpenSSL
 Requires: m2crypto
-Requires: python-dateutil
-Requires: python-lxml
-Requires: libxslt-python
+Requires: python2-dateutil
+Requires: python2-lxml
+%if "%{distro}" == "Fedora" && "%{distrorelease}" <= "27"
 Requires: python-ZSI
+%else
+Requires: python2-zsi
+%endif
+Requires: libxslt-python
 Requires: xmlsec1-openssl-devel
 
 %package client