Set up different namespaces for match and target arguments.
[sfa.git] / sfa.spec
index 913352b..66185b0 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -7,7 +7,7 @@
 
 %define name sfa
 %define version 0.9
-%define taglevel 2
+%define taglevel 5
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -34,9 +34,10 @@ Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 Requires: libxslt-python
 
-# python 2.5 has uuid module added, for python 2.4 we still need it 
-%define uuid_missing %(`python -c "import uuid" 2> /dev/null ; echo $?`)
-%if uuid_missing
+# python 2.5 has uuid module added, for python 2.4 we still need it
+%define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
+%if has_uuid
+%else
 Requires: python-uuid
 %endif
 
@@ -69,7 +70,7 @@ sfi.py, together with other utilities.
 %description sfatables
 sfatables is a tool for defining access and admission control policies
 in an SFA network, in much the same way as iptables is for ip
-networks.
+networks. This is the command line interface to manage sfatables
 
 %prep
 %setup -q
@@ -85,10 +86,13 @@ make install DESTDIR="$RPM_BUILD_ROOT"
 rm -rf $RPM_BUILD_ROOT
 
 %files
+# sfa and sfatables depend each other.
+/etc/sfatables/*
 %{python_sitelib}/*
 /usr/bin/keyconvert
 /var/www/html/wsdl/*.wsdl
 
+
 %files plc
 %defattr(-,root,root)
 %config (noreplace) /etc/sfa/sfa_config
@@ -110,9 +114,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/genidump.py*
 
 %files sfatables
-/etc/sfatables/*
 %{_bindir}/sfatables
-%{python_sitelib}/sfatables/*
 
 %pre plc
 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
@@ -121,6 +123,17 @@ rm -rf $RPM_BUILD_ROOT
 chkconfig --add sfa
 
 %changelog
+* Fri Oct 09 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-5
+- Create_slice and get_resources methods are connected to sfatables.
+- Other features include compatibility with RP, handling remote objects created as part of federation, preliminary version of sfatables, call tracability and logging.
+
+* Wed Oct 07 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-4
+- Bug fix on update and remove_peer_object methods
+- Compatibility with RP, preliminiary version of sfatables, call tracability and logging
+
+* Mon Oct 05 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-3
+- Compatibility with RP, two additional methods to handle remote objects, call tracability and logging, PLCDB now has single table for sfa records, preliminary version of sfatables (still under development)
+
 * Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
 - compatibility with RefreshPeer
 - incremental mechanism for importing PLC records into SFA tables