- make matches and targets loaded w/o making hem python packages
[sfa.git] / sfa.spec
index 9947445..7f83bed 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -34,9 +34,10 @@ Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 Requires: libxslt-python
 
-# python 2.5 has uuid module added, for python 2.4 we still need it 
-%define uuid_missing %(`python -c "import uuid" 2> /dev/null ; echo $?`)
-%if uuid_missing
+# python 2.5 has uuid module added, for python 2.4 we still need it
+%define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
+%if has_uuid
+%else
 Requires: python-uuid
 %endif
 
@@ -69,7 +70,7 @@ sfi.py, together with other utilities.
 %description sfatables
 sfatables is a tool for defining access and admission control policies
 in an SFA network, in much the same way as iptables is for ip
-networks.
+networks. This is the command line interface to manage sfatables
 
 %prep
 %setup -q
@@ -85,10 +86,13 @@ make install DESTDIR="$RPM_BUILD_ROOT"
 rm -rf $RPM_BUILD_ROOT
 
 %files
+# sfa and sfatables depend each other.
+/etc/sfatables/*
 %{python_sitelib}/*
 /usr/bin/keyconvert
 /var/www/html/wsdl/*.wsdl
 
+
 %files plc
 %defattr(-,root,root)
 %config (noreplace) /etc/sfa/sfa_config
@@ -97,6 +101,7 @@ rm -rf $RPM_BUILD_ROOT
 /etc/init.d/sfa
 %{_bindir}/sfa-config-tty
 %{_bindir}/sfa-import-plc.py*
+%{_bindir}/sfa-clean-peer-records.py*
 %{_bindir}/sfa-nuke-plc.py*
 %{_bindir}/sfa-server.py*
 
@@ -109,9 +114,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/genidump.py*
 
 %files sfatables
-/etc/sfatables/*
 %{_bindir}/sfatables
-%{python_sitelib}/sfatables/*
 
 %pre plc
 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||: