- make matches and targets loaded w/o making hem python packages
[sfa.git] / sfa.spec
index bb5e2ea..7f83bed 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -1,8 +1,13 @@
-%define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
+
+#
+# $Id$
+#
+
+%define url $URL$
 
 %define name sfa
-%define version 0.8
-%define taglevel 0
+%define version 0.9
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -20,36 +25,53 @@ Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
+Summary: the SFA python libraries
+Group: Applications/System
 
 BuildRequires: make
 Requires: python
 Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
+Requires: libxslt-python
 
-Summary: the GENI python libraries
-Group: Applications/System
+# python 2.5 has uuid module added, for python 2.4 we still need it
+%define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
+%if has_uuid
+%else
+Requires: python-uuid
+%endif
 
 %package plc
-Summary: the GENI wrapper arounf MyPLC
+Summary: the SFA wrapper arounf MyPLC
 Group: Applications/System
 Requires: sfa
 
 %package client
-Summary: the GENI experimenter-side CLI
+Summary: the SFA experimenter-side CLI
+Group: Applications/System
+Requires: sfa
+
+%package sfatables
+Summary: sfatables policy tool for SFA
 Group: Applications/System
 Requires: sfa
 
 %description
-This package provides the python libraries that the Geni implementation requires
+This package provides the python libraries that the SFA implementation requires
 
 %description plc
-Geniwrapper implements the Geni interface which serves as a layer
-between the existing PlanetLab interfaces and the Geni API.
+Geniwrapper implements the SFA interface which serves as a layer
+between the existing PlanetLab interfaces and the SFA API.
 
 %description client
-This package provides the client side of the Geni API, in particular
+This package provides the client side of the SFA API, in particular
 sfi.py, together with other utilities.
 
+%description sfatables
+sfatables is a tool for defining access and admission control policies
+in an SFA network, in much the same way as iptables is for ip
+networks. This is the command line interface to manage sfatables
+
 %prep
 %setup -q
 
@@ -64,9 +86,12 @@ make install DESTDIR="$RPM_BUILD_ROOT"
 rm -rf $RPM_BUILD_ROOT
 
 %files
+# sfa and sfatables depend each other.
+/etc/sfatables/*
 %{python_sitelib}/*
-/usr/share/keyconvert/
-/var/www/html/wsdl/sfa.wsdl
+/usr/bin/keyconvert
+/var/www/html/wsdl/*.wsdl
+
 
 %files plc
 %defattr(-,root,root)
@@ -76,7 +101,9 @@ rm -rf $RPM_BUILD_ROOT
 /etc/init.d/sfa
 %{_bindir}/sfa-config-tty
 %{_bindir}/sfa-import-plc.py*
-%{_bindir}/sfa-plc.py*
+%{_bindir}/sfa-clean-peer-records.py*
+%{_bindir}/sfa-nuke-plc.py*
+%{_bindir}/sfa-server.py*
 
 %files client
 %config (noreplace) /etc/sfa/sfi_config
@@ -86,10 +113,62 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/setRecord.py*
 %{_bindir}/genidump.py*
 
+%files sfatables
+%{_bindir}/sfatables
+
+%pre plc
+[ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
+
 %post plc
-chkconfig --add geni
+chkconfig --add sfa
 
 %changelog
+* Fri Sep 18 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-2
+- compatibility with RefreshPeer
+- incremental mechanism for importing PLC records into SFA tables
+- unified single database (still inside the underlying PLC db postgresql server)
+- includes/improves call traceability and logging features
+- several bug fixes
+
+* Thu Sep 17 2009 Baris Metin <tmetin@sophia.inria.fr>
+- added libxslt-python dependency
+
+* Thu Sep 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-1
+- unified single SFA database in the PLC-DB
+- upcalls from  PLCAPI to SFA methods
+- SFA call traceability and logging features
+- many bug fixes
+- includes first/rough version of sfatables for policy implementation
+
+* Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-6
+- snapshot after the GEC5 demo
+- should be the last tag set in the geniwrapper module, are we are now moving to the sfa module
+
+* Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-5
+- snapshot july 15 - has gone through superficial manual testing
+- hopefully a good basis for gec5 demo
+- multi-dir sfi client tested as well
+
+* Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-4
+- rename geniwrapper.spec into sfa.spec
+
+* Wed Jul 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-3
+- clean up in xmlrpc/soap, --protocol option to chose between both
+- keyconvert packaged in /usr/bin, no /usr/share/keyconvert anymore
+- hopefully more helpful context in case of crashes when importing
+- bugfixes for using only /etc/sfa for site-dep files
+- bugfixes in wsdl generation
+
+* Mon Jul 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-2
+- cleanup of the config area; no dependency to a PLC config anymore as sfa can be run in standalone
+- config variables in sfa_config now start with SFA_ and not GENI_
+- config.py can be loaded even with no config present
+
+* Sun Jul 05 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.8-1
+- first step for cleanup and reorganization
+- mass-renaming from geni to sfa (some are still needed)
+- sfa/trust implements the security architecture
+
 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - geniwrapper-0.2-7
 - snapshot for reproducible builds